]> git.pld-linux.org Git - packages/gtkmm4.git/blame - gtkmm3.spec
- updated to 3.8.1
[packages/gtkmm4.git] / gtkmm3.spec
CommitLineData
33bee831
AF
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
5bdd83fd 5%define glibmm_ver 2.36.0
33bee831
AF
6Summary: A C++ interface for the GTK+ (a GUI library for X)
7Summary(pl.UTF-8): Wrapper C++ dla GTK+
8Name: gtkmm3
3ec80342 9Version: 3.8.1
33bee831
AF
10Release: 1
11License: LGPL v2+
12Group: X11/Libraries
5bdd83fd 13Source0: http://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.8/gtkmm-%{version}.tar.xz
3ec80342 14# Source0-md5: 15211fab12ea2ce955369dcc320baf5c
33bee831 15URL: http://www.gtkmm.org/
31a8d119 16BuildRequires: atkmm-devel >= 2.22.2
33bee831 17BuildRequires: autoconf >= 2.59
31a8d119 18BuildRequires: automake >= 1:1.11
33bee831 19BuildRequires: cairomm-devel >= 1.9.2
4b35a8ba 20BuildRequires: gdk-pixbuf2-devel >= 2.22.1
e34bbb24 21BuildRequires: glibmm-devel >= %{glibmm_ver}
5bdd83fd 22BuildRequires: gtk+3-devel >= 3.8.0
33bee831
AF
23BuildRequires: libsigc++-devel
24BuildRequires: libstdc++-devel >= 5:3.3.1
e3273d66 25BuildRequires: libtool >= 2:2.0
362eec70 26BuildRequires: mm-common >= 0.9.6
31a8d119 27BuildRequires: pangomm-devel >= 2.28.0
33bee831
AF
28BuildRequires: perl-base >= 1:5.6.0
29BuildRequires: pkgconfig
e3273d66
JB
30BuildRequires: tar >= 1:1.22
31BuildRequires: xz
31a8d119 32Requires: atkmm >= 2.22.2
33bee831 33Requires: cairomm >= 1.9.2
b4b481d5 34Requires: gdk-pixbuf2 >= 2.22.1
e34bbb24 35Requires: glibmm >= %{glibmm_ver}
5bdd83fd 36Requires: gtk+3 >= 3.8.0
31a8d119 37Requires: pangomm >= 2.28.0
33bee831
AF
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
42library. The interface provides a convenient interface for C++
43programmers to create GUIs with GTK+'s flexible object-oriented
44framework. Features include type safe callbacks, widgets that are
45extensible using inheritance and over 110 classes that can be freely
46combined to quickly create complex user interfaces.
47
48%description -l pl.UTF-8
49gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
50służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
51także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
52
53%package devel
54Summary: gtkmm and gdkmm header files
55Summary(pl.UTF-8): Pliki nagłówkowe gtkmm i gdkmm
56Group: X11/Development/Libraries
57Requires: %{name} = %{version}-%{release}
31a8d119 58Requires: atkmm-devel >= 2.22.2
b4b481d5
JB
59Requires: cairomm-devel >= 1.9.2
60Requires: gdk-pixbuf2-devel >= 2.22.1
e34bbb24 61Requires: glibmm-devel >= %{glibmm_ver}
5bdd83fd 62Requires: gtk+3-devel >= 3.8.0
31a8d119 63Requires: pangomm-devel >= 2.28.0
33bee831
AF
64
65%description devel
66Header files for gtkmm library.
67
68%description devel -l pl.UTF-8
69Pliki nagłówkowe biblioteki gtkmm.
70
71%package static
72Summary: gtkmm and gdkmm static libraries
73Summary(pl.UTF-8): Biblioteki statyczne gtkmm i gdkmm
74Group: X11/Development/Libraries
75Requires: %{name}-devel = %{version}-%{release}
76
77%description static
78gtkmm and gdkmm static libraries.
79
80%description static -l pl.UTF-8
81Biblioteki statyczne gtkmm i gdkmm.
82
83%package apidocs
84Summary: Reference documentation for gtkmm and gdkmm
85Summary(pl.UTF-8): Szczegółowa dokumentacja gtkmm i gdkmm
86Group: Documentation
87Requires: devhelp
88
89%description apidocs
90Reference documentation for gtkmm and gdkmm.
91
92%description apidocs -l pl.UTF-8
93Szczegółowa dokumentacja gtkmm i gdkmm.
94
95%prep
96%setup -q -n gtkmm-%{version}
97
98%build
99%{__libtoolize}
100%{__aclocal} -I build
101%{__autoconf}
102%{__autoheader}
103%{__automake}
104%configure \
105 %{?with_static_libs:--enable-static}
106
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(644,root,root,755)
125%doc AUTHORS ChangeLog NEWS PORTING README
126%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
127%attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
128%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
129%attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
130
131%files devel
132%defattr(644,root,root,755)
133%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
134%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
135%{_libdir}/gdkmm-3.0
136%{_libdir}/gtkmm-3.0
137%{_includedir}/gdkmm-3.0
138%{_includedir}/gtkmm-3.0
139%{_pkgconfigdir}/gdkmm-3.0.pc
140%{_pkgconfigdir}/gtkmm-3.0.pc
141
142%if %{with static_libs}
143%files static
144%defattr(644,root,root,755)
145%{_libdir}/libgdkmm-3.0.a
146%{_libdir}/libgtkmm-3.0.a
147%endif
148
149%files apidocs
150%defattr(644,root,root,755)
151%{_docdir}/gtkmm-3.0
152%{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.080419 seconds and 4 git commands to generate.