]> git.pld-linux.org Git - packages/gtkmm3.git/blob - gtkmm3.spec
1b26380422f51130a7e99a1191fa19b51ec800c9
[packages/gtkmm3.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         atkmm_ver       2.24.2
6 %define         glibmm_ver      2.54.0
7 %define         gtk3_ver        3.24.0
8 %define         pangomm_ver     2.38.2
9 Summary:        A C++ interface for the GTK+ (a GUI library for X)
10 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
11 Name:           gtkmm3
12 Version:        3.24.1
13 Release:        1
14 License:        LGPL v2+
15 Group:          X11/Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.24/gtkmm-%{version}.tar.xz
17 # Source0-md5:  9524ed4e5c821d13eeda49ba2a78f024
18 URL:            https://www.gtkmm.org/
19 BuildRequires:  atkmm-devel >= %{atkmm_ver}
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  cairomm-devel >= 1.12.0
23 BuildRequires:  gdk-pixbuf2-devel >= 2.36.0
24 BuildRequires:  glibmm-devel >= %{glibmm_ver}
25 BuildRequires:  gtk+3-devel >= %{gtk3_ver}
26 BuildRequires:  libepoxy-devel >= 1.2
27 BuildRequires:  libsigc++-devel
28 BuildRequires:  libstdc++-devel >= 6:4.7
29 BuildRequires:  libtool >= 2:2.0
30 BuildRequires:  mm-common >= 0.9.10
31 BuildRequires:  pangomm-devel >= %{pangomm_ver}
32 BuildRequires:  perl-base >= 1:5.6.0
33 BuildRequires:  pkgconfig
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 Requires:       atkmm >= %{atkmm_ver}
37 Requires:       cairomm >= 1.12.0
38 Requires:       gdk-pixbuf2 >= 2.36.0
39 Requires:       glibmm >= %{glibmm_ver}
40 Requires:       gtk+3 >= %{gtk3_ver}
41 Requires:       pangomm >= %{pangomm_ver}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
46 library. The interface provides a convenient interface for C++
47 programmers to create GUIs with GTK+'s flexible object-oriented
48 framework. Features include type safe callbacks, widgets that are
49 extensible using inheritance and over 110 classes that can be freely
50 combined to quickly create complex user interfaces.
51
52 %description -l pl.UTF-8
53 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
54 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
55 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
56
57 %package devel
58 Summary:        gtkmm and gdkmm header files
59 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       atkmm-devel >= %{atkmm_ver}
63 Requires:       cairomm-devel >= 1.12.0
64 Requires:       gdk-pixbuf2-devel >= 2.36.0
65 Requires:       glibmm-devel >= %{glibmm_ver}
66 Requires:       gtk+3-devel >= %{gtk3_ver}
67 Requires:       libstdc++-devel >= 6:4.6
68 Requires:       pangomm-devel >= %{pangomm_ver}
69
70 %description devel
71 Header files for gtkmm library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki gtkmm.
75
76 %package static
77 Summary:        gtkmm and gdkmm static libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
79 Group:          X11/Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 gtkmm and gdkmm static libraries.
84
85 %description static -l pl.UTF-8
86 Biblioteki statyczne gtkmm i gdkmm.
87
88 %package apidocs
89 Summary:        Reference documentation for gtkmm and gdkmm
90 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
91 Group:          Documentation
92 Requires:       devhelp
93 %if "%{_rpmversion}" >= "5"
94 BuildArch:      noarch
95 %endif
96
97 %description apidocs
98 Reference documentation for gtkmm and gdkmm.
99
100 %description apidocs -l pl.UTF-8
101 Szczegółowa dokumentacja gtkmm i gdkmm.
102
103 %prep
104 %setup -q -n gtkmm-%{version}
105
106 %build
107 %{__libtoolize}
108 %{__aclocal} -I build
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --disable-silent-rules \
114         %{?with_static_libs:--enable-static}
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog NEWS PORTING README
135 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
137 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
143 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
144 %{_libdir}/gdkmm-3.0
145 %{_libdir}/gtkmm-3.0
146 %{_includedir}/gdkmm-3.0
147 %{_includedir}/gtkmm-3.0
148 %{_pkgconfigdir}/gdkmm-3.0.pc
149 %{_pkgconfigdir}/gtkmm-3.0.pc
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libgdkmm-3.0.a
155 %{_libdir}/libgtkmm-3.0.a
156 %endif
157
158 %files apidocs
159 %defattr(644,root,root,755)
160 %{_docdir}/gtkmm-3.0
161 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.077301 seconds and 2 git commands to generate.