]> git.pld-linux.org Git - packages/gtk2-theme-engine-qt.git/commitdiff
- -kcm-fixinstallationdir.patch from Gentoo
authorpsz <psz@pld-linux.org>
Thu, 6 Apr 2006 20:35:54 +0000 (20:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- -dt.patch from Fedora
- -notebook.patch from Freedesktop
- build process fixed
- rel 1

Changed files:
    gtk2-theme-engine-qt-dt.patch -> 1.1
    gtk2-theme-engine-qt-kcm-fixinstallationdir.patch -> 1.1
    gtk2-theme-engine-qt-notebook.patch -> 1.1
    gtk2-theme-engine-qt.spec -> 1.13

gtk2-theme-engine-qt-dt.patch [new file with mode: 0644]
gtk2-theme-engine-qt-kcm-fixinstallationdir.patch [new file with mode: 0644]
gtk2-theme-engine-qt-notebook.patch [new file with mode: 0644]
gtk2-theme-engine-qt.spec

diff --git a/gtk2-theme-engine-qt-dt.patch b/gtk2-theme-engine-qt-dt.patch
new file mode 100644 (file)
index 0000000..b9c086b
--- /dev/null
@@ -0,0 +1,8 @@
+--- gtk-qt-engine-0.6/kcm_gtk/kcmgtk.desktop.dt        2004-08-22 03:40:29.000000000 -0500
++++ gtk-qt-engine-0.6/kcm_gtk/kcmgtk.desktop   2006-01-23 09:28:15.000000000 -0600
+@@ -12,3 +12,5 @@
+ X-KDE-Library=kcmgtk
+ X-KDE-ModuleType=Library
+ Type=Application
++
++NotShowIn=KDE
diff --git a/gtk2-theme-engine-qt-kcm-fixinstallationdir.patch b/gtk2-theme-engine-qt-kcm-fixinstallationdir.patch
new file mode 100644 (file)
index 0000000..4a5aca4
--- /dev/null
@@ -0,0 +1,21 @@
+--- kcm_gtk/Makefile.am.orig   2005-01-14 10:52:16.000000000 +0000
++++ kcm_gtk/Makefile.am        2005-01-15 10:44:20.006738856 +0000
+@@ -2,8 +2,7 @@
+ METASOURCES = AUTO
+ # Install this plugin in the KDE modules directory
+-kcmgtkmoduledir = $(KDE_PREFIX)/lib/kde3/
+-kcmgtkmodule_LTLIBRARIES = kcm_kcmgtk.la
++kde_module_LTLIBRARIES = kcm_kcmgtk.la
+ kcm_kcmgtk_la_SOURCES = kcmgtkwidget.ui kcmgtk.cpp
+ kcm_kcmgtk_la_LIBADD = $(LIB_KDEUI)
+@@ -11,7 +10,7 @@
+ kcmgtk_DATA = kcmgtk.desktop
+-kcmgtkdir = $(KDE_PREFIX)/share/applnk/Settings/LookNFeel
++kcmgtkdir = $(kde_appsdir)/Settings/LookNFeel
+ kcmgtkdebian_DATA = kcmgtk.menu
+ kcmgtkdebiandir = /usr/lib/menu
diff --git a/gtk2-theme-engine-qt-notebook.patch b/gtk2-theme-engine-qt-notebook.patch
new file mode 100644 (file)
index 0000000..d6cc2f0
--- /dev/null
@@ -0,0 +1,12 @@
+--- gtk-qt-engine-0.6/src/qt_qt_wrapper.cpp.3919       2004-12-19 09:31:48.000000000 -0600
++++ gtk-qt-engine-0.6/src/qt_qt_wrapper.cpp    2005-10-27 09:48:07.000000000 -0500
+@@ -1363,7 +1363,8 @@
+       int sdiff = 10000, pos = -1, diff = 1;
+       for ( int i = 0; i < g_list_length(notebook->children); i++ )
+       {
+-              diff = gtk_notebook_get_tab_label(notebook,gtk_notebook_get_nth_page(notebook,i))->allocation.x - x;
++              GtkWidget *tab_label=gtk_notebook_get_tab_label(notebook,gtk_notebook_get_nth_page(notebook,i));
++              if (tab_label) diff = tab_label->allocation.x - x;
+               if ((diff > 0) && (diff < sdiff))
+               {
+                       sdiff = diff; pos = i;
index 5fd10e282916102eeb725520e518d40b41b67822..e90eef7b3cfa949551548115546c502af12c522a 100644 (file)
@@ -1,19 +1,26 @@
 # TODO
 # - kde control panel applet doesn't get found
-# - where to place the .theme?
 Summary:       A GTK+ theme engine that uses Qt for drawing
 Summary(pl):   Silnik graficzny wykorzystuj±cy Qt do rysowania kontrolek GTK+
 Name:          gtk2-theme-engine-qt
 Version:       0.6
-Release:       0.6
+Release:       1
 License:       GPL
 Group:         Themes/GTK+
 Source0:       http://www.freedesktop.org/~davidsansome/gtk-qt-engine-%{version}.tar.bz2
 # Source0-md5: 9c02c95a6e8d304b1f2801429759e1c0
 Patch0:                %{name}-black-menus.patch
+Patch1:                %{name}-kcm-fixinstallationdir.patch
+# don't dup GTK-QT in kde menu(s)
+Patch2:                %{name}-dt.patch
+# segfault in libqtengine.so drawing notebook
+# https://bugs.freedesktop.org/show_bug.cgi?id=3919
+Patch3:                %{name}-notebook.patch
 URL:           http://www.freedesktop.org/Software/gtk-qt
+BuildRequires: automake
 BuildRequires: gtk+2-devel >= 1:2.0.0
 BuildRequires: kdelibs-devel
+BuildRequires: libbonoboui-devel
 BuildRequires: pkgconfig
 BuildRequires: qt-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -30,8 +37,14 @@ wygl
 %prep
 %setup -q -n gtk-qt-engine-%{version}
 %patch0 -p1
+%patch1 -p0
+%patch2 -p1
+%patch3 -p1
+
+%{__make} -f admin/Makefile.common cvs
 
 %build
+export QTLIB=%{_libdir}
 %configure
 %{__make}
 
@@ -48,9 +61,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS README
+%doc AUTHORS
 %attr(755,root,root) %{_libdir}/gtk-2.0/2.4.*/engines/*.so
 %{_datadir}/themes/Qt
+%{_datadir}/gtk-qt-engine/
+%{_desktopdir}/*.desktop
+%{_datadir}/applnk/Settings/LookNFeel/*.desktop
 %{_libdir}/kde3/kcm_kcmgtk.la
 %attr(755,root,root) %{_libdir}/kde3/kcm_kcmgtk.so
-%{_desktopdir}/kcmgtk-xdg.desktop
This page took 0.041091 seconds and 4 git commands to generate.