]> git.pld-linux.org Git - packages/gtk-webkit4.git/commitdiff
updated x32 patch (based on debian patch) auto/th/gtk-webkit4-2.26.1-2
authorJan Palus <atler@pld-linux.org>
Tue, 8 Oct 2019 21:04:35 +0000 (23:04 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 8 Oct 2019 21:04:35 +0000 (23:04 +0200)
x32.patch

index 490f23820377e666a449fa0bb7bf18a18786d598..715a4ff283cd90e50adc01090a774ae73bcb444f 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,19 +1,37 @@
-From: Daniel Schepler <dschepler@gmail.com>
-Subject: Fix FTBFS in x32
-Bug-Debian: https://bugs.debian.org/700795
+From: Alberto Garcia <berto@igalia.com>
+Description: Use WTF_CPU_UNKNOWN when building for X32
+ WebKitGTK doesn't build on X32 even with the JIT disabled.
+ Treating the CPU as unknown is perhaps a bit severe, but it allows us
+ to get the build done until someone steps up to maintain this
+ properly.
+Forwarded: no
 Index: webkitgtk/Source/WTF/wtf/Platform.h
 ===================================================================
 --- webkitgtk.orig/Source/WTF/wtf/Platform.h
 +++ webkitgtk/Source/WTF/wtf/Platform.h
-@@ -179,7 +179,11 @@
+@@ -142,10 +142,12 @@
  /* CPU(X86_64) - AMD64 / Intel64 / x86_64 64-bit */
  #if   defined(__x86_64__) \
      || defined(_M_X64)
-+#ifdef __ILP32__
-+#define WTF_CPU_X86_64_32 1
-+#else
++#if !defined(__ILP32__)
  #define WTF_CPU_X86_64 1
-+#endif
  #define WTF_CPU_X86_SSE2 1
  #define WTF_CPU_KNOWN 1
  #endif
++#endif
+ /* CPU(ARM64) - Apple */
+ #if (defined(__arm64__) && defined(__APPLE__)) || defined(__aarch64__)
+Index: webkitgtk/CMakeLists.txt
+===================================================================
+--- webkitgtk.orig/CMakeLists.txt
++++ webkitgtk/CMakeLists.txt
+@@ -93,6 +93,8 @@ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR
+     set(WTF_CPU_MIPS64 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "^mips")
+     set(WTF_CPU_MIPS 1)
++elseif (CMAKE_CXX_COMPILER_ABI STREQUAL "ELF X32")
++    set(WTF_CPU_UNKNOWN 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "(x64|x86_64|amd64)")
+     # FORCE_32BIT is set in the build script when --32-bit is passed
+     # on a Linux/intel 64bit host. This allows us to produce 32bit
This page took 0.208246 seconds and 4 git commands to generate.