]> git.pld-linux.org Git - packages/gtk-webkit4.git/commitdiff
- added driver-version-suffix, package all variants of WebKitWebDriver suffixed with... auto/th/gtk-webkit4-2.38.6-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 5 May 2023 18:43:26 +0000 (20:43 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 5 May 2023 18:43:26 +0000 (20:43 +0200)
  (instead of libsoup3 variant in libsoup 2 based package)
- added gcc13 patch to fix build with gcc 13.x
- release 2

gtk-webkit4-driver-version-suffix.patch [new file with mode: 0644]
gtk-webkit4-gcc13.patch [new file with mode: 0644]
gtk-webkit4.spec

diff --git a/gtk-webkit4-driver-version-suffix.patch b/gtk-webkit4-driver-version-suffix.patch
new file mode 100644 (file)
index 0000000..04ab08c
--- /dev/null
@@ -0,0 +1,8 @@
+--- webkitgtk-2.38.6/Source/WebDriver/PlatformGTK.cmake.orig   2022-08-19 13:14:27.800098000 +0200
++++ webkitgtk-2.38.6/Source/WebDriver/PlatformGTK.cmake        2023-05-05 06:13:51.566790434 +0200
+@@ -1,4 +1,4 @@
+-set(WebDriver_OUTPUT_NAME WebKitWebDriver)
++set(WebDriver_OUTPUT_NAME WebKitWebDriver-${WEBKITGTK_API_VERSION})
+ add_definitions(-DLIBEXECDIR="${CMAKE_INSTALL_FULL_LIBEXECDIR}")
diff --git a/gtk-webkit4-gcc13.patch b/gtk-webkit4-gcc13.patch
new file mode 100644 (file)
index 0000000..13ce0e9
--- /dev/null
@@ -0,0 +1,27 @@
+--- webkitgtk-2.38.6/Source/ThirdParty/ANGLE/include/GLSLANG/ShaderVars.h.orig 2022-08-19 13:14:22.903425000 +0200
++++ webkitgtk-2.38.6/Source/ThirdParty/ANGLE/include/GLSLANG/ShaderVars.h      2023-05-05 06:11:59.781732404 +0200
+@@ -12,6 +12,7 @@
+ #include <algorithm>
+ #include <array>
++#include <cstdint>
+ #include <string>
+ #include <vector>
+--- webkitgtk-2.38.6/Source/WebCore/platform/graphics/SourceBrush.cpp.orig     2022-09-20 10:13:48.250555000 +0200
++++ webkitgtk-2.38.6/Source/WebCore/platform/graphics/SourceBrush.cpp  2023-05-05 06:14:14.776532489 +0200
+@@ -65,12 +65,12 @@ Pattern* SourceBrush::pattern() const
+ void SourceBrush::setGradient(Ref<Gradient>&& gradient, const AffineTransform& spaceTransform)
+ {
+-    m_brush = { Brush::LogicalGradient { WTFMove(gradient), spaceTransform } };
++    m_brush = Brush { Brush::LogicalGradient { WTFMove(gradient), spaceTransform } };
+ }
+ void SourceBrush::setPattern(Ref<Pattern>&& pattern)
+ {
+-    m_brush = { WTFMove(pattern) };
++    m_brush = Brush { WTFMove(pattern) };
+ }
+ WTF::TextStream& operator<<(TextStream& ts, const SourceBrush& brush)
index 41f46eeefc1e581240cb87666e52e2bc649c6457..408bb8a35bac7778755e89fc0bf3f2a9ab10ea6a 100644 (file)
@@ -25,7 +25,7 @@ Summary(pl.UTF-8):    Port osadzalnego komponentu WWW WebKit do GTK+ 3
 Name:          gtk-webkit4
 # NOTE: 2.38.x is stable, 2.39.x devel
 Version:       2.38.6
-Release:       1
+Release:       2
 License:       BSD-like
 Group:         X11/Libraries
 Source0:       https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
@@ -33,6 +33,8 @@ Source0:      https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
 Patch0:                x32.patch
 Patch1:                %{name}-icu59.patch
 Patch2:                %{name}-gir.patch
+Patch3:                %{name}-driver-version-suffix.patch
+Patch4:                %{name}-gcc13.patch
 URL:           https://webkitgtk.org/
 BuildRequires: /usr/bin/ld.gold
 BuildRequires: EGL-devel
@@ -301,6 +303,8 @@ Dokumentacja API portu WebKitu do GTK 4.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
 %if %{with lowmem}
@@ -366,7 +370,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -f WebKit2GTK-4.0.lang
 %defattr(644,root,root,755)
 %doc NEWS
-%attr(755,root,root) %{_bindir}/WebKitWebDriver
+%attr(755,root,root) %{_bindir}/WebKitWebDriver-4.0
 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
@@ -412,6 +416,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n gtk-webkit4.1 -f WebKit2GTK-4.1.lang
 %defattr(644,root,root,755)
 %doc NEWS
+%attr(755,root,root) %{_bindir}/WebKitWebDriver-4.1
 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.1.so.0
 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so.*.*.*
@@ -457,6 +462,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n gtk-webkit5 -f WebKit2GTK-5.0.lang
 %defattr(644,root,root,755)
 %doc NEWS
+%attr(755,root,root) %{_bindir}/WebKitWebDriver-5.0
 %attr(755,root,root) %{_libdir}/libwebkit2gtk-5.0.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-5.0.so.0
 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-5.0.so.*.*.*
This page took 0.511274 seconds and 4 git commands to generate.