]> git.pld-linux.org Git - packages/gtk-webkit4.git/commitdiff
attempt to fix build against icu 65; rel 2
authorJan Palus <atler@pld-linux.org>
Tue, 8 Oct 2019 14:26:29 +0000 (16:26 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 8 Oct 2019 14:26:29 +0000 (16:26 +0200)
gtk-webkit4-icu65.patch [new file with mode: 0644]
gtk-webkit4.spec

diff --git a/gtk-webkit4-icu65.patch b/gtk-webkit4-icu65.patch
new file mode 100644 (file)
index 0000000..e1d7f8a
--- /dev/null
@@ -0,0 +1,39 @@
+diff -urN webkitgtk-2.26.1.orig/Source/WebCore/dom/Document.cpp webkitgtk-2.26.1/Source/WebCore/dom/Document.cpp
+--- webkitgtk-2.26.1.orig/Source/WebCore/dom/Document.cpp      2019-09-02 11:41:47.000000000 +0200
++++ webkitgtk-2.26.1/Source/WebCore/dom/Document.cpp   2019-10-08 16:24:57.649551493 +0200
+@@ -4944,12 +4944,12 @@
+     unsigned i = 0;
+     UChar32 c;
+-    U16_NEXT(characters, i, length, c)
++    U16_NEXT(characters, i, length, c);
+     if (!isValidNameStart(c))
+         return false;
+     while (i < length) {
+-        U16_NEXT(characters, i, length, c)
++        U16_NEXT(characters, i, length, c);
+         if (!isValidNamePart(c))
+             return false;
+     }
+@@ -5009,7 +5009,7 @@
+     for (unsigned i = 0; i < length; ) {
+         UChar32 c;
+-        U16_NEXT(qualifiedName, i, length, c)
++        U16_NEXT(qualifiedName, i, length, c);
+         if (c == ':') {
+             if (sawColon)
+                 return Exception { InvalidCharacterError };
+diff -urN webkitgtk-2.26.1.orig/Source/WTF/wtf/URLHelpers.cpp webkitgtk-2.26.1/Source/WTF/wtf/URLHelpers.cpp
+--- webkitgtk-2.26.1.orig/Source/WTF/wtf/URLHelpers.cpp        2019-08-28 13:46:29.000000000 +0200
++++ webkitgtk-2.26.1/Source/WTF/wtf/URLHelpers.cpp     2019-10-08 16:24:50.619850993 +0200
+@@ -301,7 +301,7 @@
+     Optional<UChar32> previousCodePoint;
+     while (i < length) {
+         UChar32 c;
+-        U16_NEXT(buffer, i, length, c)
++        U16_NEXT(buffer, i, length, c);
+         UErrorCode error = U_ZERO_ERROR;
+         UScriptCode script = uscript_getScript(c, &error);
+         if (error != U_ZERO_ERROR) {
index daa6582e05823c31264a13c8e97fdde6ea414a11..edad00c5042ffde6eabd692af13aa4811ae47046 100644 (file)
@@ -17,7 +17,7 @@ Summary(pl.UTF-8):    Port osadzalnego komponentu WWW WebKit do GTK+ 3
 Name:          gtk-webkit4
 # NOTE: 2.26.x is stable, 2.27.x devel (see DEVEL-2.27 branch)
 Version:       2.26.1
-Release:       1
+Release:       2
 License:       BSD-like
 Group:         X11/Libraries
 Source0:       https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
@@ -25,6 +25,7 @@ Source0:      https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
 Patch0:                x32.patch
 Patch1:                %{name}-icu59.patch
 Patch2:                %{name}-gir.patch
+Patch3:                %{name}-icu65.patch
 URL:           https://webkitgtk.org/
 BuildRequires: /usr/bin/ld.gold
 BuildRequires: EGL-devel
@@ -160,6 +161,7 @@ Dokumentacja API WebKita.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 install -d build
This page took 0.283956 seconds and 4 git commands to generate.