]> git.pld-linux.org Git - packages/gtk-webkit3.git/commitdiff
- added sh patch to kill bashisms
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 13 Apr 2013 04:48:22 +0000 (06:48 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 13 Apr 2013 04:48:22 +0000 (06:48 +0200)
gtk-webkit3-sh.patch [new file with mode: 0644]
gtk-webkit3.spec

diff --git a/gtk-webkit3-sh.patch b/gtk-webkit3-sh.patch
new file mode 100644 (file)
index 0000000..642f56b
--- /dev/null
@@ -0,0 +1,57 @@
+--- webkitgtk-2.0.0/Source/autotools/FindDependencies.m4.orig  2013-03-26 19:25:38.000000000 +0100
++++ webkitgtk-2.0.0/Source/autotools/FindDependencies.m4       2013-04-01 21:33:59.797598840 +0200
+@@ -441,18 +441,18 @@
+ if test "$with_acceleration_backend" = "opengl"; then
+     if test "$enable_gles2" = "yes"; then
+-        acceleration_backend_description+= "(gles2"
++        acceleration_backend_description="$acceleration_backend_description(gles2"
+         OPENGL_LIBS="-lGLESv2"
+     else
+-        acceleration_backend_description+="(gl"
++        acceleration_backend_description="$acceleration_backend_description(gl"
+         OPENGL_LIBS="-lGL"
+     fi
+     if test "$enable_egl" = "yes"; then
+-        acceleration_backend_description+=", egl"
+-        OPENGL_LIBS+=" -lEGL"
++        acceleration_backend_description="$acceleration_backend_description, egl"
++        OPENGL_LIBS="$OPENGL_LIBS -lEGL"
+     fi
+     if test "$enable_glx" = "yes"; then
+-        acceleration_backend_description+=", glx"
++        acceleration_backend_description="$acceleration_backend_description, glx"
+     fi
+     # Check whether dlopen() is in the core libc like on FreeBSD, or in a separate
+@@ -460,8 +460,8 @@
+     AC_CHECK_FUNC([dlopen], [], [AC_CHECK_LIB([dl], [dlopen], [DLOPEN_LIBS="-ldl"])])
+     AC_SUBST([DLOPEN_LIBS])
+-    OPENGL_LIBS+=" $DLOPEN_LIBS"
+-    acceleration_backend_description+=")"
++    OPENGL_LIBS="$OPENGL_LIBS $DLOPEN_LIBS"
++    acceleration_backend_description="$acceleration_backend_description)"
+ fi
+ AC_SUBST([OPENGL_LIBS])
+--- webkitgtk-2.0.0/Source/autotools/SetupWebKitFeatures.m4.orig       2013-04-12 19:48:10.867922095 +0200
++++ webkitgtk-2.0.0/Source/autotools/SetupWebKitFeatures.m4    2013-04-12 20:02:21.254571037 +0200
+@@ -12,7 +12,7 @@
+ # This list of features represents those selected for release builds.
+ # If you are adding a new or unstable feature, you should mark it
+ # disabled here.
+-read -d '' DEFAULT_FEATURE_DEFINES <<"EOF"
++DEFAULT_FEATURE_DEFINES="
+       ENABLE_ACCELERATED_2D_CANVAS=0
+       ENABLE_BATTERY_STATUS=0
+       ENABLE_BLOB=1
+@@ -107,7 +107,7 @@
+       ENABLE_WEB_TIMING=1
+       ENABLE_WORKERS=1
+       ENABLE_XHR_TIMEOUT=1
+-EOF
++"
+ if test "$enable_spellcheck" = "yes"; then
+     DEFAULT_FEATURE_DEFINES="$DEFAULT_FEATURE_DEFINES ENABLE_SPELLCHECK=1"
index 7df2c18236c38c63c20a19e09ce73db87cca19e3..8e1e1f5afbfeb2e6ddf4ceaf9ae51ecb9e7caeb4 100644 (file)
@@ -17,6 +17,7 @@ Group:                X11/Libraries
 Source0:       http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
 # Source0-md5: fa231ba8c9cd33575b9692614324be21
 Patch0:                sync-builtins.patch
+Patch1:                %{name}-sh.patch
 URL:           http://webkitgtk.org/
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGLES-devel
@@ -111,6 +112,7 @@ Dokumentacja API WebKita.
 %prep
 %setup -q -n webkitgtk-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.118087 seconds and 4 git commands to generate.