]> git.pld-linux.org Git - packages/gtk-webkit3.git/blob - gtk-webkit3.spec
a83bd6354e98bd41061d23c8a64b8e9021432fac
[packages/gtk-webkit3.git] / gtk-webkit3.spec
1 # TODO: review configure options:
2 # - webgl, xhtmlmp, mathml, wml, wcss, web-audio, web-timing
3 # - client-based-geolocation
4 # - directory-upload
5 # - APIs: indexed-database, input-speech, image-resizer
6 # - HTML5: notifications, datagrid, data-transfer-items, file-system
7 #
8 # Conditional build:
9 %bcond_without  introspection   # disable introspection
10 #
11 Summary:        Port of WebKit embeddable web component to GTK+ 3
12 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
13 Name:           gtk-webkit3
14 Version:        1.8.0
15 Release:        1
16 License:        BSD-like
17 Group:          X11/Libraries
18 Source0:        http://webkitgtk.org/releases/webkit-%{version}.tar.xz
19 # Source0-md5:  52b2feb0fae01e68432b547bd85e8d74
20 URL:            http://webkitgtk.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake
24 BuildRequires:  bison
25 BuildRequires:  cairo-devel >= 1.10
26 BuildRequires:  enchant-devel >= 0.22
27 BuildRequires:  flex >= 2.5.33
28 BuildRequires:  fontconfig-devel >= 2.4.0
29 BuildRequires:  freetype-devel >= 1:2.1.8
30 BuildRequires:  geoclue-devel
31 BuildRequires:  gettext-devel
32 BuildRequires:  glib2-devel >= 1:2.32.0
33 BuildRequires:  glibc-misc
34 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
35 BuildRequires:  gperf
36 BuildRequires:  gstreamer-devel >= 0.10
37 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.30
38 BuildRequires:  gtk+3-devel >= 3.0.0
39 BuildRequires:  gtk-doc >= 1.10
40 BuildRequires:  libicu-devel >= 4.2.1
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libpng-devel
43 BuildRequires:  libsoup-devel >= 2.38.0
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool >= 2:1.5
46 BuildRequires:  libxml2-devel >= 1:2.6.30
47 BuildRequires:  libxslt-devel >= 1.1.7
48 BuildRequires:  pango-devel >= 1:1.21.0
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpmbuild(macros) >= 1.592
51 BuildRequires:  sqlite3-devel >= 3.0
52 BuildRequires:  xorg-lib-libXrender-devel
53 BuildRequires:  xorg-lib-libXt-devel
54 BuildRequires:  zlib-devel
55 Requires:       cairo >= 1.10
56 Requires:       enchant >= 0.22
57 Requires:       glib2 >= 1:2.32.0
58 Requires:       gstreamer-plugins-base >= 0.10.30
59 Requires:       gtk+3 >= 3.0.0
60 Requires:       libsoup >= 2.38.0
61 Requires:       libxml2 >= 1:2.6.30
62 Requires:       libxslt >= 1.1.7
63 Requires:       pango >= 1:1.21.0
64 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 gtk-webkit3 is a port of the WebKit embeddable web component to GTK+ 3.
69
70 %description -l pl.UTF-8
71 gtk-webkit3 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
72
73 %package devel
74 Summary:        Development files for WebKit for GTK+ 3
75 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       glib2-devel >= 1:2.32.0
79 Requires:       gtk+3-devel >= 3.0.0
80 Requires:       libsoup-devel >= 2.38.0
81
82 %description devel
83 Development files for WebKit for GTK+ 3.
84
85 %description devel -l pl.UTF-8
86 Pliki programistyczne komponentu WebKit dla GTK+ 3.
87
88 %package apidocs
89 Summary:        WebKit API documentation
90 Summary(pl.UTF-8):      Dokumentacja API WebKita
91 Group:          Documentation
92 Requires:       gtk-doc-common
93
94 %description apidocs
95 WebKit API documentation.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API WebKita.
99
100 %prep
101 %setup -q -n webkit-%{version}
102
103 %build
104 %{__gtkdocize}
105 %{__libtoolize}
106 %{__aclocal} -I Source/autotools
107 %{__autoheader}
108 %{__automake}
109 %{__autoconf}
110 %configure \
111         --disable-silent-rules \
112         %{__enable_disable introspection} \
113         --with-gtk=3.0 \
114         --enable-geolocation \
115         --enable-gtk-doc \
116         --with-html-dir=%{_gtkdocdir}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
127
128 %find_lang webkit-3.0
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files -f webkit-3.0.lang
137 %defattr(644,root,root,755)
138 %doc ChangeLog NEWS
139 %attr(755,root,root) %{_bindir}/jsc-3
140 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
142 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-3.0.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-3.0.so.0
144 %if %{with introspection}
145 %{_libdir}/girepository-1.0/JSCore-3.0.typelib
146 %{_libdir}/girepository-1.0/WebKit-3.0.typelib
147 %endif
148 %dir %{_datadir}/webkitgtk-3.0
149 %{_datadir}/webkitgtk-3.0/images
150 %{_datadir}/webkitgtk-3.0/resources
151 %{_datadir}/webkitgtk-3.0/webinspector
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
156 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-3.0.so
157 %if %{with introspection}
158 %{_datadir}/gir-1.0/JSCore-3.0.gir
159 %{_datadir}/gir-1.0/WebKit-3.0.gir
160 %endif
161 %{_includedir}/webkitgtk-3.0
162 %{_pkgconfigdir}/webkitgtk-3.0.pc
163 %{_pkgconfigdir}/javascriptcoregtk-3.0.pc
164
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_gtkdocdir}/webkitgtk
This page took 0.064016 seconds and 2 git commands to generate.