]> git.pld-linux.org Git - packages/gtk-webkit3.git/blob - gtk-webkit3.spec
8732ecb5b0673827f1d341173175c7fb5ede5194
[packages/gtk-webkit3.git] / gtk-webkit3.spec
1 # TODO: review configure options:
2 # - webgl, xhtmlmp, mathml, wml, wcss, web-audio, web-timing
3 # - client-based-geolocation
4 # - directory-upload
5 # - APIs: indexed-database, input-speech, image-resizer
6 # - HTML5: notifications, datagrid, data-transfer-items, file-system
7 #
8 # Conditional build:
9 %bcond_without  introspection   # disable introspection
10 #
11 Summary:        Port of WebKit embeddable web component to GTK+ 3
12 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
13 Name:           gtk-webkit3
14 Version:        1.6.1
15 Release:        2
16 License:        BSD-like
17 Group:          X11/Libraries
18 Source0:        http://webkitgtk.org/webkit-%{version}.tar.gz
19 # Source0-md5:  c11743694b1b71dad287b2e7a9e73b05
20 URL:            http://webkitgtk.org/
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake
23 BuildRequires:  bison
24 BuildRequires:  cairo-devel >= 1.10
25 BuildRequires:  enchant-devel >= 0.22
26 BuildRequires:  flex >= 2.5.33
27 BuildRequires:  fontconfig-devel >= 2.4.0
28 BuildRequires:  freetype-devel >= 1:2.1.8
29 BuildRequires:  geoclue-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  glib2-devel >= 1:2.28.0
32 BuildRequires:  glibc-misc
33 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
34 BuildRequires:  gperf
35 BuildRequires:  gstreamer-devel >= 0.10
36 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.30
37 BuildRequires:  gtk+3-devel >= 3.0.0
38 BuildRequires:  gtk-doc >= 1.10
39 BuildRequires:  libicu-devel >= 4.2.1
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libpng-devel
42 BuildRequires:  libsoup-devel >= 2.34.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 2:1.5
45 BuildRequires:  libxml2-devel >= 1:2.6.30
46 BuildRequires:  libxslt-devel >= 1.1.7
47 BuildRequires:  pango-devel >= 1:1.12
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(macros) >= 1.592
50 BuildRequires:  sqlite3-devel >= 3.0
51 BuildRequires:  xorg-lib-libXt-devel
52 BuildRequires:  xorg-lib-libXrender-devel
53 Requires(post,postun):  glib2 >= 1:2.26.0
54 Requires:       cairo >= 1.10
55 Requires:       enchant >= 0.22
56 Requires:       gstreamer-plugins-base >= 0.10.30
57 Requires:       gtk+3 >= 3.0.0
58 Requires:       libsoup >= 2.34.0
59 Requires:       libxml2 >= 1:2.6.30
60 Requires:       libxslt >= 1.1.7
61 Requires:       pango >= 1:1.12
62 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 gtk-webkit3 is a port of the WebKit embeddable web component to GTK+ 3.
67
68 %description -l pl.UTF-8
69 gtk-webkit3 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
70
71 %package devel
72 Summary:        Development files for WebKit for GTK+ 3
73 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       glib2-devel >= 1:2.28.0
77 Requires:       gtk+3-devel >= 3.0.0
78 Requires:       libsoup-devel >= 2.34.0
79
80 %description devel
81 Development files for WebKit for GTK+ 3.
82
83 %description devel -l pl.UTF-8
84 Pliki programistyczne komponentu WebKit dla GTK+ 3.
85
86 %prep
87 %setup -q -n webkit-%{version}
88
89 %build
90 %{__gtkdocize}
91 %{__libtoolize}
92 %{__aclocal} -I Source/autotools
93 %{__autoheader}
94 %{__automake}
95 %{__autoconf}
96 %configure \
97         --disable-silent-rules \
98         %{__enable_disable introspection} \
99         --with-gtk=3.0 \
100         --enable-3d-transforms \
101         --enable-geolocation
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
112
113 %find_lang webkit-3.0
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 /sbin/ldconfig
120 %glib_compile_schemas
121
122 %postun
123 /sbin/ldconfig
124 %glib_compile_schemas
125
126 %files -f webkit-3.0.lang
127 %defattr(644,root,root,755)
128 %doc ChangeLog NEWS
129 %attr(755,root,root) %{_bindir}/jsc-3
130 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
132 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-3.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-3.0.so.0
134 %if %{with introspection}
135 %{_libdir}/girepository-1.0/JSCore-3.0.typelib
136 %{_libdir}/girepository-1.0/WebKit-3.0.typelib
137 %endif
138 %dir %{_datadir}/webkitgtk-3.0
139 %{_datadir}/webkitgtk-3.0/images
140 %{_datadir}/webkitgtk-3.0/resources
141 %{_datadir}/webkitgtk-3.0/webinspector
142 %{_datadir}/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
147 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-3.0.so
148 %if %{with introspection}
149 %{_datadir}/gir-1.0/JSCore-3.0.gir
150 %{_datadir}/gir-1.0/WebKit-3.0.gir
151 %endif
152 %{_includedir}/webkit-3.0
153 %{_pkgconfigdir}/webkitgtk-3.0.pc
154 %{_pkgconfigdir}/javascriptcoregtk-3.0.pc
This page took 0.050368 seconds and 2 git commands to generate.