]> git.pld-linux.org Git - packages/gtk-webkit3.git/blob - gtk-webkit3.spec
291381038e4c4b2c4d0a9c661c74914ecb7d8c61
[packages/gtk-webkit3.git] / gtk-webkit3.spec
1 # TODO: 
2 # - optflags
3 # - review BR and R
4 # - review configure options
5 #
6 # Conditional build:
7 %bcond_without  introspection   # disable introspection
8 #
9 Summary:        Port of WebKit embeddable web component to GTK+
10 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
11 Name:           gtk-webkit3
12 Version:        1.3.13
13 Release:        0.1
14 License:        BSD-like
15 Group:          X11/Libraries
16 Source0:        http://webkitgtk.org/webkit-%{version}.tar.gz
17 # Source0-md5:  984adaafac545a89c24351fd4dbd743c
18 URL:            http://webkitgtk.org/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  cairo-devel >= 1.6
23 BuildRequires:  enchant-devel >= 0.22
24 BuildRequires:  flex >= 2.5.33
25 BuildRequires:  fontconfig-devel >= 2.4.0
26 BuildRequires:  freetype-devel >= 1:2.1.8
27 BuildRequires:  geoclue-devel
28 BuildRequires:  gettext-devel
29 BuildRequires:  glib2-devel >= 1:2.22.0
30 BuildRequires:  glibc-misc
31 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.5}
32 BuildRequires:  gperf
33 BuildRequires:  gstreamer-devel >= 0.10
34 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.25
35 BuildRequires:  gtk+2-devel >= 2:2.20.0
36 BuildRequires:  gtk-doc >= 1.10
37 BuildRequires:  libicu-devel >= 4.2.1
38 BuildRequires:  libjpeg-devel
39 BuildRequires:  libpng-devel
40 BuildRequires:  libsoup-devel >= 2.33.4
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool >= 2:1.5
43 BuildRequires:  libxml2-devel >= 1:2.6.30
44 BuildRequires:  libxslt-devel >= 1.1.7
45 BuildRequires:  pango-devel >= 1:1.12
46 BuildRequires:  pkgconfig
47 BuildRequires:  sqlite3-devel
48 BuildRequires:  xorg-lib-libXft-devel >= 2.0.0
49 BuildRequires:  xorg-lib-libXt-devel
50 Requires:       cairo >= 1.6
51 Requires:       enchant >= 0.22
52 Requires:       gstreamer-plugins-base >= 0.10.25
53 Requires:       gtk+2 >= 2:2.20.0
54 Requires:       libsoup >= 2.30.0
55 Requires:       libxml2 >= 1:2.6.30
56 Requires:       libxslt >= 1.1.7
57 Requires:       pango >= 1:1.12
58 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 webkit is a port of the WebKit embeddable web component to GTK+.
63
64 %description -l pl.UTF-8
65 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
66
67 %package devel
68 Summary:        Development files for WebKit
69 Summary(pl.UTF-8):      Pliki programistyczne WebKit
70 Group:          X11/Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       cairo-devel >= 1.6
73 Requires:       enchant-devel >= 0.22
74 Requires:       fontconfig-devel >= 2.4.0
75 Requires:       freetype-devel >= 1:2.1.8
76 Requires:       geoclue-devel
77 Requires:       glib2-devel >= 1:2.22.0
78 Requires:       gstreamer-devel >= 0.10
79 Requires:       gstreamer-plugins-base-devel >= 0.10.25
80 Requires:       gtk+2-devel >= 2:2.20.0
81 Requires:       libicu-devel >= 4.2.1
82 Requires:       libjpeg-devel
83 Requires:       libpng-devel
84 Requires:       libsoup-devel >= 2.30.0
85 Requires:       libstdc++-devel
86 Requires:       libxml2-devel >= 1:2.6.30
87 Requires:       libxslt-devel >= 1.1.7
88 Requires:       pango-devel >= 1:1.12
89 Requires:       sqlite3-devel
90 Requires:       xorg-lib-libXt-devel
91
92 %description devel
93 Development files for WebKit.
94
95 %description devel -l pl.UTF-8
96 Pliki programistyczne WebKit.
97
98 %prep
99 %setup -q -n webkit-%{version}
100
101 %build
102 %{__gtkdocize}
103 %{__libtoolize}
104 %{__aclocal} -I Source/autotools
105 %{__autoheader}
106 %{__automake}
107 %{__autoconf}
108 %configure \
109         --with-gtk=3.0 \
110         --disable-silent-rules \
111         --enable-3d-transforms \
112         --enable-dom-storage \
113         --enable-geolocation \
114         --enable-icon-database \
115         %{__enable_disable introspection} \
116         --enable-video \
117         --with-font-backend=freetype
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwebkitgtk-3.0.la
128
129 : > webkit-3.0.lang
130 #find_lang webkit-3.0
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files -f webkit-3.0.lang
139 %defattr(644,root,root,755)
140 %doc ChangeLog
141 %attr(755,root,root) %{_bindir}/jsc-3
142 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
144 %if %{with introspection}
145 %{_libdir}/girepository-1.0/JSCore-3.0.typelib
146 %{_libdir}/girepository-1.0/WebKit-3.0.typelib
147 %endif
148 %dir %{_datadir}/webkit-3.0
149 %{_datadir}/webkit-3.0/resources
150 %dir %{_datadir}/webkitgtk-3.0
151 %{_datadir}/webkitgtk-3.0/images
152 %{_datadir}/webkitgtk-3.0/webinspector
153 /usr/share/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
158 %if %{with introspection}
159 %{_datadir}/gir-1.0/JSCore-3.0.gir
160 %{_datadir}/gir-1.0/WebKit-3.0.gir
161 %endif
162 %{_includedir}/webkit-3.0
163 %{_pkgconfigdir}/webkitgtk-3.0.pc
This page took 0.055741 seconds and 2 git commands to generate.