]> git.pld-linux.org Git - packages/gtatool.git/blob - gtatool.spec
- release 16 (by relup.sh)
[packages/gtatool.git] / gtatool.spec
1 # TODO: pmd (BR: proprietary libpmdaccess2)
2 # libequalizer (pkgconfig(Equalizer) >= 1.0.0) for multi-display OpenGL support
3 # libgls (pkgconfig(gls) >= 1.0.0) for stereoscopic-3D OpenGL support
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # do not build and package API docs
7 %bcond_without  qt              # Qt-based GUI
8 %bcond_without  muparser        # compute component module (based on MuParser)
9 %bcond_without  dcmtk           # DCMTK conv module
10 %bcond_without  ffmpeg          # FFmpeg conv module
11 %bcond_without  gdal            # GDAL conv module
12 %bcond_without  jpeg            # JPEG conv module (based on libjpeg)
13 %bcond_without  magick          # Magick conv module (based on ImageMagick's libMagick++)
14 %bcond_without  matio           # MAT conv module (MATLAB import/export, based on [lib]matio)
15 %bcond_without  netcdf          # NetCDF conv module
16 %bcond_without  netpbm          # NetPBM conv module
17 %bcond_without  openexr         # EXR conv module (based on OpenEXR)
18 %bcond_without  pcl             # PCD conv module (based on PCL's libpcl_io)
19 %bcond_without  pfs             # PFS conv module
20 %bcond_without  sndfile         # sndfile conv module
21 %bcond_without  teem            # teem (nrrd) conv module
22 #
23 Summary:        Tools to manipulate Generic Tagged Array (GTA) files
24 Summary(pl.UTF-8):      Narzędzia do obróbki plików GTA (ogólnych tablic etykietowanych)
25 Name:           gtatool
26 Version:        2.0.1
27 Release:        16
28 License:        GPL v3+
29 Group:          Applications/File
30 Source0:        http://download.savannah.gnu.org/releases/gta/%{name}-%{version}.tar.xz
31 # Source0-md5:  1133c5687bd14d321eefffab6b495d74
32 Patch0:         ffmpeg2.patch
33 Patch1:         %{name}-getopt.patch
34 Patch2:         %{name}-bashcomp.patch
35 Patch3:         pfstools2.patch
36 Patch4:         ffmpeg3.patch
37 Patch5:         imagemagick7.patch
38 URL:            http://gta.nongnu.org/gtatool.html
39 %{?with_magick:BuildRequires:   ImageMagick-c++-devel}
40 %{?with_openexr:BuildRequires:  OpenEXR-devel}
41 %{?with_qt:BuildRequires:       OpenGL-devel}
42 %{?with_qt:BuildRequires:       QtGui-devel >= 4.8}
43 %{?with_qt:BuildRequires:       QtOpenGL-devel >= 4.8}
44 BuildRequires:  autoconf >= 2.65
45 BuildRequires:  automake >= 1:1.11.1
46 %{?with_dcmtk:BuildRequires:    dcmtk-devel}
47 %{?with_apidocs:BuildRequires:  doxygen}
48 # libavformat >= 52.110.0 libavdevice libswscale
49 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
50 %{?with_gdal:BuildRequires:     gdal-devel}
51 %{?with_qt:BuildRequires:       glew-devel >= 1.6.0}
52 BuildRequires:  libgta-devel >= 0.9.4
53 %{?with_jpeg:BuildRequires:     libjpeg-devel}
54 %{?with_sndfile:BuildRequires:  libsndfile-devel}
55 BuildRequires:  libstdc++-devel
56 BuildRequires:  libtool >= 2:2.2.6
57 %{?with_matio:BuildRequires:    matio-devel >= 1.5.0}
58 %{?with_muparser:BuildRequires: muparser-devel}
59 %{?with_netcdf:BuildRequires:   netcdf-devel}
60 %{?with_netpbm:BuildRequires:   netpbm-devel}
61 %{?with_pcl:BuildRequires:      pcl-devel >= 1.7}
62 %{?with_pfs:BuildRequires:      pfstools-devel >= 2.0}
63 BuildRequires:  pkgconfig
64 %{?with_qt:BuildRequires:       qt4-build >= 4.8}
65 BuildRequires:  rpmbuild(macros) >= 1.673
66 BuildRequires:  tar >= 1:1.22
67 %{?with_teem:BuildRequires:     teem-devel}
68 BuildRequires:  xz
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Gtatool manipulates Generic Tagged Array (GTA) files.
73
74 It provides a set of commands that manipulate GTAs on various levels,
75 and it can import from and export to many other file formats.
76
77 %description -l pl.UTF-8
78 gtatool pracuje na plikach GTA (Generic Tagged Array - ogólnych
79 tablicach etykietowanych).
80
81 Pakiet zawiera zestaw poleceń obrabiających GTA na różnych poziomach,
82 potrafiących importować i eksportować do wielu innych formatów plików.
83
84 %package component-compute
85 Summary:        gtatool module to compute array element components
86 Summary(pl.UTF-8):      Moduł gtatool do obliczania składowych elementów tablicy
87 Group:          Applications/File
88 Requires:       %{name} = %{version}-%{release}
89
90 %description component-compute
91 gtatool module to compute array element components.
92
93 %description component-compute -l pl.UTF-8
94 Moduł gtatool do obliczania składowych elementów tablicy.
95
96 %package conv-dcmtk
97 Summary:        gtatool module to convert from DICOM format
98 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatu DICOM
99 Group:          Applications/File
100 Requires:       %{name} = %{version}-%{release}
101
102 %description conv-dcmtk
103 gtatool module to convert from DICOM format.
104
105 %description conv-dcmtk -l pl.UTF-8
106 Moduł gtatool do konwersji z formatu DICOM.
107
108 %package conv-exr
109 Summary:        gtatool module to convert from/to EXR format
110 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu EXR
111 Group:          Applications/File
112 Requires:       %{name} = %{version}-%{release}
113
114 %description conv-exr
115 gtatool module to convert from/to EXR format.
116
117 %description conv-exr -l pl.UTF-8
118 Moduł gtatool do konwersji z/do formatu EXR.
119
120 %package conv-ffmpeg
121 Summary:        gtatool module to convert from FFmpeg formats
122 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatów FFmpeg
123 Group:          Applications/File
124 Requires:       %{name} = %{version}-%{release}
125
126 %description conv-ffmpeg
127 gtatool module to convert from FFmpeg formats.
128
129 %description conv-ffmpeg -l pl.UTF-8
130 Moduł gtatool do konwersji z formatów FFmpeg.
131
132 %package conv-gdal
133 Summary:        gtatool module to convert from/to GDAL supported formats
134 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL
135 Group:          Applications/File
136 Requires:       %{name} = %{version}-%{release}
137
138 %description conv-gdal
139 gtatool module to convert from/to GDAL supported formats.
140
141 %description conv-gdal -l pl.UTF-8
142 Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL.
143
144 %package conv-jpeg
145 Summary:        gtatool module to convert from/to JPEG formats
146 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu JPEG
147 Group:          Applications/File
148 Requires:       %{name} = %{version}-%{release}
149
150 %description conv-jpeg
151 gtatool module to convert from/to JPEG formats.
152
153 %description conv-jpeg -l pl.UTF-8
154 Moduł gtatool do konwersji z/do formatu JPEG.
155
156 %package conv-magick
157 Summary:        gtatool module to convert from/to ImageMagick supported formats
158 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez ImageMagick
159 Group:          Applications/File
160 Requires:       %{name} = %{version}-%{release}
161
162 %description conv-magick
163 gtatool module to convert from/to ImageMagick supported formats.
164
165 %description conv-magick -l pl.UTF-8
166 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
167 ImageMagick.
168
169 %package conv-mat
170 Summary:        gtatool module to convert from/to MAT format
171 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu MAT
172 Group:          Applications/File
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       matio >= 1.5.0
175
176 %description conv-mat
177 gtatool module to convert from/to MAT (Matlab) format.
178
179 %description conv-mat -l pl.UTF-8
180 Moduł gtatool do konwersji z/do formatu MAT (z programu Matlab).
181
182 %package conv-netcdf
183 Summary:        gtatool module to convert from/to NetCDF format
184 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu NetCDF
185 Group:          Applications/File
186 Requires:       %{name} = %{version}-%{release}
187
188 %description conv-netcdf
189 gtatool module to convert from/to NetCDF format.
190
191 %description conv-netcdf -l pl.UTF-8
192 Moduł gtatool do konwersji z/do formatu NetCDF.
193
194 %package conv-netpbm
195 Summary:        gtatool module to convert from/to NetPBM supported formats
196 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM
197 Group:          Applications/File
198 Requires:       %{name} = %{version}-%{release}
199
200 %description conv-netpbm
201 gtatool module to convert from/to NetPBM supported formats.
202
203 %description conv-netpbm -l pl.UTF-8
204 Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM.
205
206 %package conv-pcd
207 Summary:        gtatool module to convert from/to PCD format
208 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PCD
209 Group:          Applications/File
210 Requires:       %{name} = %{version}-%{release}
211
212 %description conv-pcd
213 gtatool module to convert from/to PCD format.
214
215 %description conv-pcd -l pl.UTF-8
216 Moduł gtatool do konwersji z/do formatu PCD.
217
218 %package conv-pfs
219 Summary:        gtatool module to convert from/to PFS format
220 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PFS
221 Group:          Applications/File
222 Requires:       %{name} = %{version}-%{release}
223
224 %description conv-pfs
225 gtatool module to convert from/to PFS format.
226
227 %description conv-pfs -l pl.UTF-8
228 Moduł gtatool do konwersji z/do formatu PFS.
229
230 %package conv-sndfile
231 Summary:        gtatool module to convert from/to libsndfile supported formats
232 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez libsndfile
233 Group:          Applications/File
234 Requires:       %{name} = %{version}-%{release}
235
236 %description conv-sndfile
237 gtatool module to convert from/to libsndfile supported formats.
238
239 %description conv-sndfile -l pl.UTF-8
240 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
241 libsndfile.
242
243 %package conv-teem
244 Summary:        gtatool module to convert from/to Teem (NRRD) format
245 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu Teem (NRRD)
246 Group:          Applications/File
247 Requires:       %{name} = %{version}-%{release}
248
249 %description conv-teem
250 gtatool module to convert from/to Teem (NRRD) format.
251
252 %description conv-teem -l pl.UTF-8
253 Moduł gtatool do konwersji z/do formatu Teem (NRRD).
254
255 %package gui
256 Summary:        Qt-based GUI module for gtatool
257 Summary(pl.UTF-8):      Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia gtatool
258 Group:          X11/Applications
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       QtGui >= 4.8
261
262 %description gui
263 Qt-based GUI module for gtatool.
264
265 %description gui -l pl.UTF-8
266 Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia
267 gtatool.
268
269 %package -n bash-completion-gtatool
270 Summary:        Bash completion for gtatool command
271 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów programu gtatool
272 Group:          Applications/Shells
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       bash-completion >= 2
275 %if "%{_rpmversion}" >= "5"
276 BuildArch:      noarch
277 %endif
278
279 %description -n bash-completion-gtatool
280 Bash completion for gtatool command.
281
282 %description -n bash-completion-gtatool -l pl.UTF-8
283 Bashowe uzupełnianie parametrów programu gtatool.
284
285 %prep
286 %setup -q
287 %patch0 -p1
288 %patch1 -p1
289 %patch2 -p1
290 %patch3 -p1
291 %patch4 -p1
292 %patch5 -p1
293
294 %build
295 %{__libtoolize}
296 %{__aclocal} -I m4
297 %{__autoconf}
298 %{__autoheader}
299 %{__automake}
300 %if %{with netpbm}
301 export CFLAGS="%{rpmcflags} -I/usr/include/netpbm"
302 export CXXFLAGS="%{rpmcxxflags} -I/usr/include/netpbm"
303 %endif
304 %configure \
305         BASHCOMPLETIONDIR=%{bash_compdir} \
306         --disable-silent-rules \
307         --with-bashcompletion \
308         %{!?with_dcmtk:--without-dcmtk} \
309         %{!?with_ffmpeg:--without-ffmpeg} \
310         %{!?with_gdal:--without-gdal} \
311         %{!?with_jpeg:--without-jpeg} \
312         %{?with_magick:--with-magick-flavor=ImageMagick} \
313         %{!?with_magick:--without-magick} \
314         %{!?with_matio:--without-matio} \
315         %{!?with_muparser:--without-muparser} \
316         %{!?with_netcdf:--without-netcdf} \
317         %{!?with_netpbm:--without-netpbm} \
318         %{!?with_openexr:--without-openexr} \
319         %{!?with_pcl:--without-pcd} \
320         %{!?with_pfs:--without-pfs} \
321         %{!?with_qt:--without-qt} \
322         %{!?with_sndfile:--without-sndfile} \
323         %{!?with_teem:--without-teem}
324 %{__make}
325
326 %install
327 rm -rf $RPM_BUILD_ROOT
328
329 %{__make} install \
330         DESTDIR=$RPM_BUILD_ROOT
331
332 %clean
333 rm -rf $RPM_BUILD_ROOT
334
335 %post   -p /sbin/postshell
336 -/usr/sbin/fix-info-dir -c %{_infodir}
337
338 %postun -p /sbin/postshell
339 -/usr/sbin/fix-info-dir -c %{_infodir}
340
341 %files
342 %defattr(644,root,root,755)
343 %doc AUTHORS ChangeLog NEWS README
344 %attr(755,root,root) %{_bindir}/gta
345 %dir %{_libdir}/gtatool
346 %attr(755,root,root) %{_libdir}/gtatool/conv-csv.so
347 %attr(755,root,root) %{_libdir}/gtatool/conv-datraw.so
348 %attr(755,root,root) %{_libdir}/gtatool/conv-ply.so
349 %attr(755,root,root) %{_libdir}/gtatool/conv-pvm.so
350 %attr(755,root,root) %{_libdir}/gtatool/conv-rat.so
351 %attr(755,root,root) %{_libdir}/gtatool/conv-raw.so
352 %{_mandir}/man1/gta.1*
353 %{_infodir}/gta.info*
354
355 %if %{with muparser}
356 %files component-compute
357 %defattr(644,root,root,755)
358 %attr(755,root,root) %{_libdir}/gtatool/component-compute.so
359 %endif
360
361 %if %{with dcmtk}
362 %files conv-dcmtk
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/gtatool/conv-dcmtk.so
365 %endif
366
367 %if %{with openexr}
368 %files conv-exr
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_libdir}/gtatool/conv-exr.so
371 %endif
372
373 %if %{with ffmpeg}
374 %files conv-ffmpeg
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{_libdir}/gtatool/conv-ffmpeg.so
377 %endif
378
379 %if %{with gdal}
380 %files conv-gdal
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/gtatool/conv-gdal.so
383 %endif
384
385 %if %{with jpeg}
386 %files conv-jpeg
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_libdir}/gtatool/conv-jpeg.so
389 %endif
390
391 %if %{with magick}
392 %files conv-magick
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_libdir}/gtatool/conv-magick.so
395 %endif
396
397 %if %{with matio}
398 %files conv-mat
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/gtatool/conv-mat.so
401 %endif
402
403 %if %{with netcdf}
404 %files conv-netcdf
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_libdir}/gtatool/conv-netcdf.so
407 %endif
408
409 %if %{with netpbm}
410 %files conv-netpbm
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_libdir}/gtatool/conv-netpbm.so
413 %endif
414
415 %if %{with pcl}
416 %files conv-pcd
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/gtatool/conv-pcd.so
419 %endif
420
421 %if %{with pfs}
422 %files conv-pfs
423 %defattr(644,root,root,755)
424 %attr(755,root,root) %{_libdir}/gtatool/conv-pfs.so
425 %endif
426
427 %if %{with sndfile}
428 %files conv-sndfile
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_libdir}/gtatool/conv-sndfile.so
431 %endif
432
433 %if %{with teem}
434 %files conv-teem
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_libdir}/gtatool/conv-teem.so
437 %endif
438
439 %if %{with qt}
440 %files gui
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_libdir}/gtatool/gui.so
443 %attr(755,root,root) %{_libdir}/gtatool/view.so
444 %{_desktopdir}/gta_gui.desktop
445 %{_iconsdir}/hicolor/*/apps/gta.png
446 %{_iconsdir}/hicolor/scalable/apps/gta.svg
447 %endif
448
449 %files -n bash-completion-gtatool
450 %defattr(644,root,root,755)
451 %{bash_compdir}/gta
This page took 0.108476 seconds and 3 git commands to generate.