]> git.pld-linux.org Git - packages/gstreamermm.git/blob - gstreamermm.spec
e4b88e17ae17efb4008284845766b1daf4edd27d
[packages/gstreamermm.git] / gstreamermm.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        A C++ bindings for the GStreamer library
6 Summary(pl.UTF-8):      Wiązania C++ do biblioteki GStreamera
7 Name:           gstreamermm
8 Version:        1.4.3
9 Release:        2
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gstreamermm/1.4/%{name}-%{version}.tar.xz
13 # Source0-md5:  8f6c4b85083308def933eab1433a1865
14 URL:            https://gstreamer.freedesktop.org/bindings/cplusplus.html
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  glibmm-devel >= 2.36.0
18 BuildRequires:  gstreamer-devel >= 1.4.3
19 BuildRequires:  gstreamer-plugins-base-devel >= 1.4.3
20 # for not packaged examples only
21 #BuildRequires: gtkmm3-devel >= 3.0
22 BuildRequires:  libstdc++-devel >= 6:4.3
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  m4
25 BuildRequires:  mm-common >= 0.9.6
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       glibmm >= 2.36.0
30 Requires:       gstreamer >= 1.4.3
31 Requires:       gstreamer-plugins-base >= 1.4.3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 gstreamermm provides C++ bindings for the GStreamer streaming
36 multimedia library. With gstreamermm it is possible to develop
37 applications that work with multimedia in C++.
38
39 %description -l pl.UTF-8
40 gstreamermm dostarcza wiązania C++ dla biblioteki strumieniowej
41 GStreamer. Za pomocą gstreamermm jest możliwe tworzenie aplikacji
42 multimedialnych w C++.
43
44 %package devel
45 Summary:        gstreamermm header files
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gstreamermm
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       glibmm-devel >= 2.36.0
50 Requires:       gstreamer-devel >= 1.4.3
51 Requires:       gstreamer-plugins-base-devel >= 1.4.3
52
53 %description devel
54 Header files for gstreamermm library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki gstreamermm.
58
59 %package static
60 Summary:        gstreamermm static libraries
61 Summary(pl.UTF-8):      Biblioteki statyczne gstreamermm
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 gstreamermm static libraries.
67
68 %description static -l pl.UTF-8
69 Biblioteki statyczne gstreamermm.
70
71 %package doc
72 Summary:        Reference documentation for gstreamermm
73 Summary(pl.UTF-8):      Szczegółowa dokumentacja gstreamermm
74 Group:          Documentation
75 Requires:       devhelp
76
77 %description doc
78 Reference documentation for gstreamermm.
79
80 %description doc -l pl.UTF-8
81 Szczegółowa dokumentacja gstreamermm.
82
83 %prep
84 %setup -q
85
86 %build
87 %{__libtoolize}
88 %{__aclocal} -I build
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 CXXFLAGS="%{rpmcxxflags} -std=c++0x"
93 %configure \
94         %{?with_static_libs:--enable-static}
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # obsoleted by pkg-config
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgstreamermm*.la
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README
115 %attr(755,root,root) %{_libdir}/libgstreamermm-1.0.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libgstreamermm-1.0.so.0
117 %attr(755,root,root) %{_libdir}/libgstreamermm_get_plugin_defs-1.0.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libgstreamermm_get_plugin_defs-1.0.so.0
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libgstreamermm-1.0.so
123 %attr(755,root,root) %{_libdir}/libgstreamermm_get_plugin_defs-1.0.so
124 %dir %{_libdir}/gstreamermm-1.0
125 %dir %{_libdir}/gstreamermm-1.0/gen
126 %attr(755,root,root) %{_libdir}/gstreamermm-1.0/gen/generate_plugin_gmmproc_file
127 %{_libdir}/gstreamermm-1.0/gen/m4
128 %{_libdir}/gstreamermm-1.0/include
129 %{_includedir}/gstreamermm-1.0
130 %{_pkgconfigdir}/gstreamermm-1.0.pc
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libgstreamermm-1.0.a
136 %{_libdir}/libgstreamermm_get_plugin_defs-1.0.a
137 %endif
138
139 %files doc
140 %defattr(644,root,root,755)
141 %{_docdir}/gstreamermm-1.0
142 %{_datadir}/devhelp/books/gstreamermm-1.0
This page took 0.104356 seconds and 2 git commands to generate.