]> git.pld-linux.org Git - packages/gstreamer.git/commitdiff
- up to 1.19.3 auto/th/gstreamer-1.19.3-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 23 Nov 2021 23:30:55 +0000 (00:30 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 23 Nov 2021 23:30:55 +0000 (00:30 +0100)
gstreamer-inspect-rpm-format.patch
gstreamer.spec

index 7919cc414b8d5340cbf705b54e682dcf9956d971..0114c064119c10ae56e32588c90bb8711327c917 100644 (file)
@@ -1,6 +1,26 @@
---- gstreamer-1.16.0/tools/gst-inspect.c.orig  2019-04-12 00:58:09.000000000 +0200
-+++ gstreamer-1.16.0/tools/gst-inspect.c       2019-05-20 09:39:11.295876148 +0200
-@@ -1726,11 +1726,228 @@ print_tracer_info (GstPluginFeature * fe
+From 642d0d6fef226fb89eaecf0016f8e5e333b9023e Mon Sep 17 00:00:00 2001
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Tue, 23 Jun 2015 10:28:29 +0200
+Subject: [PATCH] gst-inspect: add mode to output RPM requires format
+
+---
+ tools/gst-inspect.c | 279 +++++++++++++++++++++++++++++++++++++++++---
+ 1 file changed, 263 insertions(+), 16 deletions(-)
+
+diff --git a/tools/gst-inspect.c b/tools/gst-inspect.c
+index 8da042946..a057cba09 100644
+--- a/tools/gst-inspect.c
++++ b/tools/gst-inspect.c
+@@ -394,7 +394,7 @@ print_object_properties_info (GObject * obj, GObjectClass * obj_class,
+     first_flag = TRUE;
+     n_print ("%sflags%s: ", PROP_ATTR_NAME_COLOR, RESET_COLOR);
+-    readable = ! !(param->flags & G_PARAM_READABLE);
++    readable = !!(param->flags & G_PARAM_READABLE);
+     if (readable && obj != NULL) {
+       g_object_get_property (obj, param->name, &value);
+     } else {
+@@ -1739,11 +1739,228 @@ print_tracer_info (GstPluginFeature * feature, gboolean print_names)
    return 0;
  }
  
    return 0;
  }
  
  {
    GstPadDirection direction;
    const gchar *type_name;
  {
    GstPadDirection direction;
    const gchar *type_name;
-@@ -1756,6 +1973,12 @@ print_plugin_automatic_install_info_code
+@@ -1769,6 +1986,13 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
      return;
    }
  
 +  if (rpm_format) {
 +    /* Ignore NONE ranked plugins */
      return;
    }
  
 +  if (rpm_format) {
 +    /* Ignore NONE ranked plugins */
-+      if ((gst_plugin_feature_get_rank (GST_PLUGIN_FEATURE (factory))) == GST_RANK_NONE)
++    if ((gst_plugin_feature_get_rank (GST_PLUGIN_FEATURE (factory))) ==
++        GST_RANK_NONE)
 +      return;
 +  }
 +
    /* decoder/demuxer sink pads should always be static and there should only
     * be one, the same applies to encoders/muxers and source pads */
    static_templates = gst_element_factory_get_static_pad_templates (factory);
 +      return;
 +  }
 +
    /* decoder/demuxer sink pads should always be static and there should only
     * be one, the same applies to encoders/muxers and source pads */
    static_templates = gst_element_factory_get_static_pad_templates (factory);
-@@ -1792,15 +2015,20 @@ print_plugin_automatic_install_info_code
+@@ -1805,15 +2029,20 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
      gst_structure_remove_field (s, "rate");
      gst_structure_remove_field (s, "depth");
      gst_structure_remove_field (s, "clock-rate");
      gst_structure_remove_field (s, "rate");
      gst_structure_remove_field (s, "depth");
      gst_structure_remove_field (s, "clock-rate");
  {
    const gchar *const *protocols;
  
  {
    const gchar *const *protocols;
  
-@@ -1809,13 +2037,19 @@ print_plugin_automatic_install_info_prot
+@@ -1822,13 +2051,19 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
      switch (gst_element_factory_get_uri_type (factory)) {
        case GST_URI_SINK:
          while (*protocols != NULL) {
      switch (gst_element_factory_get_uri_type (factory)) {
        case GST_URI_SINK:
          while (*protocols != NULL) {
            ++protocols;
          }
          break;
            ++protocols;
          }
          break;
-@@ -1826,7 +2060,7 @@ print_plugin_automatic_install_info_prot
+@@ -1839,7 +2074,7 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
  }
  
  static void
  }
  
  static void
  {
    GList *features, *l;
  
  {
    GList *features, *l;
  
-@@ -1845,11 +2079,15 @@ print_plugin_automatic_install_info (Gst
+@@ -1858,11 +2093,15 @@ print_plugin_automatic_install_info (GstPlugin * plugin)
      if (feature_plugin == plugin) {
        GstElementFactory *factory;
  
      if (feature_plugin == plugin) {
        GstElementFactory *factory;
  
      }
      if (feature_plugin)
        gst_object_unref (feature_plugin);
      }
      if (feature_plugin)
        gst_object_unref (feature_plugin);
-@@ -1871,7 +2109,7 @@ print_all_plugin_automatic_install_info
+@@ -1884,7 +2123,7 @@ print_all_plugin_automatic_install_info (void)
      plugin = (GstPlugin *) (plugins->data);
      plugins = g_list_next (plugins);
  
      plugin = (GstPlugin *) (plugins->data);
      plugins = g_list_next (plugins);
  
    }
    gst_plugin_list_free (orig_plugins);
  }
    }
    gst_plugin_list_free (orig_plugins);
  }
-@@ -1938,6 +2176,7 @@ main (int argc, char *argv[])
+@@ -1951,6 +2190,7 @@ main (int argc, char *argv[])
    gboolean do_print_blacklist = FALSE;
    gboolean plugin_name = FALSE;
    gboolean print_aii = FALSE;
 +  gboolean print_aii_rpm = FALSE;
    gboolean uri_handlers = FALSE;
    gboolean check_exists = FALSE;
    gboolean do_print_blacklist = FALSE;
    gboolean plugin_name = FALSE;
    gboolean print_aii = FALSE;
 +  gboolean print_aii_rpm = FALSE;
    gboolean uri_handlers = FALSE;
    gboolean check_exists = FALSE;
-   gchar *min_version = NULL;
-@@ -1958,6 +2197,9 @@ main (int argc, char *argv[])
+   gboolean color_always = FALSE;
+@@ -1972,6 +2212,9 @@ main (int argc, char *argv[])
                "or all plugins provide.\n                                       "
                "Useful in connection with external automatic plugin "
                "installation mechanisms"), NULL},
                "or all plugins provide.\n                                       "
                "Useful in connection with external automatic plugin "
                "installation mechanisms"), NULL},
      {"plugin", '\0', 0, G_OPTION_ARG_NONE, &plugin_name,
          N_("List the plugin contents"), NULL},
      {"types", 't', 0, G_OPTION_ARG_STRING, &types,
      {"plugin", '\0', 0, G_OPTION_ARG_NONE, &plugin_name,
          N_("List the plugin contents"), NULL},
      {"types", 't', 0, G_OPTION_ARG_STRING, &types,
-@@ -2113,7 +2355,7 @@ main (int argc, char *argv[])
+@@ -2135,7 +2378,7 @@ main (int argc, char *argv[])
        /* if there is such a plugin, print out info */
        if (plugin) {
          if (print_aii) {
        /* if there is such a plugin, print out info */
        if (plugin) {
          if (print_aii) {
          } else {
            print_plugin_info (plugin);
            print_plugin_features (plugin);
          } else {
            print_plugin_info (plugin);
            print_plugin_features (plugin);
-@@ -2126,13 +2368,17 @@ main (int argc, char *argv[])
+@@ -2148,13 +2391,17 @@ main (int argc, char *argv[])
  
            if (plugin) {
              if (print_aii) {
  
            if (plugin) {
              if (print_aii) {
              g_clear_error (&error);
              exit_code = -1;
              goto done;
              g_clear_error (&error);
              exit_code = -1;
              goto done;
+-- 
+2.26.2
+
index a728be366855bd876c99e390938e7c74c200c67d..d9a4fe7a61d586c5a399a3392f64914588207222 100644 (file)
@@ -4,12 +4,12 @@
 Summary:       GStreamer Streaming-media framework runtime
 Summary(pl.UTF-8):     GStreamer - biblioteki środowiska do obróbki strumieni
 Name:          gstreamer
 Summary:       GStreamer Streaming-media framework runtime
 Summary(pl.UTF-8):     GStreamer - biblioteki środowiska do obróbki strumieni
 Name:          gstreamer
-Version:       1.16.3
-Release:       2
+Version:       1.19.3
+Release:       1
 License:       LGPL v2+
 Group:         Libraries
 Source0:       https://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.xz
 License:       LGPL v2+
 Group:         Libraries
 Source0:       https://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.xz
-# Source0-md5: beecf6965a17fb17fa3b262fd36df70a
+# Source0-md5: 5af65dab2d400fbc5a9850b16bb5db05
 Patch0:                %{name}-inspect-rpm-format.patch
 URL:           https://gstreamer.freedesktop.org/
 BuildRequires: autoconf >= 2.69
 Patch0:                %{name}-inspect-rpm-format.patch
 URL:           https://gstreamer.freedesktop.org/
 BuildRequires: autoconf >= 2.69
@@ -25,7 +25,7 @@ BuildRequires:        glibc-localedb-all
 %endif
 BuildRequires: glibc-misc
 BuildRequires: gobject-introspection-devel >= 1.31.1
 %endif
 BuildRequires: glibc-misc
 BuildRequires: gobject-introspection-devel >= 1.31.1
-BuildRequires: gtk-doc >= 1.12
+BuildRequires: hotdoc
 BuildRequires: libcap-devel
 BuildRequires: libtool >= 2:2.2.6
 %ifarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
 BuildRequires: libcap-devel
 BuildRequires: libtool >= 2:2.2.6
 %ifarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
@@ -35,6 +35,7 @@ BuildRequires:        perl-base
 BuildRequires: pkgconfig >= 1:0.9.0
 BuildRequires: python >= 2.1
 BuildRequires: rpm-build >= 4.6
 BuildRequires: pkgconfig >= 1:0.9.0
 BuildRequires: python >= 2.1
 BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.726
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 Requires:      glib2 >= 1:2.40.0
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 Requires:      glib2 >= 1:2.40.0
@@ -89,19 +90,6 @@ Static versions of GStreamer libraries.
 %description static -l pl.UTF-8
 Statyczne wersje bibliotek GStreamer.
 
 %description static -l pl.UTF-8
 Statyczne wersje bibliotek GStreamer.
 
-%package apidocs
-Summary:       GStreamer API documentation
-Summary(pl.UTF-8):     Dokumentacja API Gstreamera
-Group:         Documentation
-Requires:      gtk-doc-common
-BuildArch:     noarch
-
-%description apidocs
-GStreamer API documentation.
-
-%description apidocs -l pl.UTF-8
-Dokumentacja API Gstreamera.
-
 %package gdb
 Summary:       GStreamer pretty printers for GDB
 Summary(pl.UTF-8):     Funkcje wypisujące dane GStreamer dla GDB
 %package gdb
 Summary:       GStreamer pretty printers for GDB
 Summary(pl.UTF-8):     Funkcje wypisujące dane GStreamer dla GDB
@@ -133,37 +121,26 @@ gst-launch.
 %setup -q
 %patch0 -p1
 
 %setup -q
 %patch0 -p1
 
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
+      docs/gst-plugins-doc-cache-generator.py
+
 %build
 %build
-# po/Makefile.in.in is modified
-#{__gettextize}
-%{__libtoolize}
-%{__aclocal} -I common/m4 -I m4 -I .
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       --disable-examples \
-       --disable-silent-rules \
-       --disable-tests \
-       --enable-gtk-doc \
-       --with-html-dir=%{_gtkdocdir} \
-       --enable-static
-
-LC_ALL=C.UTF-8 \
-%{__make}
+%meson build \
+       -D doc=enabled \
+       -D tests=disabled \
+       -D examples=disabled
+
+%ninja_build -C build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{name} --all-name --with-gnome
 
 
 %find_lang %{name} --all-name --with-gnome
 
-# no *.la for modules nor static modules - shut up check files
-%{__rm} $RPM_BUILD_ROOT%{gstlibdir}/lib*.{la,a}
-# obsoleted by pkg-config
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgst*.la
+# no static modules - shut up check files
+%{__rm} $RPM_BUILD_ROOT%{gstlibdir}/lib*.a
 
 %py_comp $RPM_BUILD_ROOT%{_datadir}/gstreamer-1.0/gdb/
 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/gstreamer-1.0/gdb/
 
 %py_comp $RPM_BUILD_ROOT%{_datadir}/gstreamer-1.0/gdb/
 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/gstreamer-1.0/gdb/
@@ -230,6 +207,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/gir-1.0/GstCheck-%{gstmver}.gir
 %{_datadir}/gir-1.0/GstController-%{gstmver}.gir
 %{_datadir}/gir-1.0/GstNet-%{gstmver}.gir
 %{_datadir}/gir-1.0/GstCheck-%{gstmver}.gir
 %{_datadir}/gir-1.0/GstController-%{gstmver}.gir
 %{_datadir}/gir-1.0/GstNet-%{gstmver}.gir
+%{_libdir}/gstreamer-1.0/pkgconfig/gstcoreelements.pc
+%{_libdir}/gstreamer-1.0/pkgconfig/gstcoretracers.pc
 
 %files static
 %defattr(644,root,root,755)
 
 %files static
 %defattr(644,root,root,755)
@@ -239,11 +218,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgstnet-%{gstmver}.a
 %{_libdir}/libgstreamer-%{gstmver}.a
 
 %{_libdir}/libgstnet-%{gstmver}.a
 %{_libdir}/libgstreamer-%{gstmver}.a
 
+%if 0
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/gstreamer-%{gstmver}
 %{_gtkdocdir}/gstreamer-libs-%{gstmver}
 %{_gtkdocdir}/gstreamer-plugins-%{gstmver}
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/gstreamer-%{gstmver}
 %{_gtkdocdir}/gstreamer-libs-%{gstmver}
 %{_gtkdocdir}/gstreamer-plugins-%{gstmver}
+%endif
 
 %files gdb
 %defattr(644,root,root,755)
 
 %files gdb
 %defattr(644,root,root,755)
This page took 0.209486 seconds and 4 git commands to generate.