]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
b1f3df3537bfbf151f5dbd985349f9f565168b0b
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.8.0
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
9 # Source0-md5:  275384c4001c6b934f159952f39e2f36
10 Patch0:         %{name}-without_ps_pdf.patch
11 URL:            http://gstreamer.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  glib2-devel >= 1:2.4.0
17 BuildRequires:  gtk-doc >= 1.0
18 BuildRequires:  libtool
19 BuildRequires:  libxml2-devel >= 2.4.17
20 BuildRequires:  nasm
21 BuildRequires:  perl-base
22 BuildRequires:  pkgconfig
23 BuildRequires:  popt-devel >= 1.6.3
24 BuildRequires:  transfig
25 BuildRequires:  xmlto
26 Requires(post): /sbin/ldconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _gstlibdir      %{_libdir}/gstreamer-0.8
30 %define         _gstincludedir  %{_includedir}/gstreamer-0.8
31 %define         _gstcachedir    %{_var}/cache/gstreamer
32
33 %description
34 GStreamer is a streaming-media framework, based on graphs of filters
35 which operate on media data. Applications using this library can do
36 anything from real-time sound processing to playing videos, and just
37 about anything else media-related. Its plugin-based architecture means
38 that new data types or processing capabilities can be added simply by
39 installing new plugins.
40
41 %description -l pl
42 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
43 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
44 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
45 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
46 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
47 nowych typów danych lub mo¿liwo¶ci obróbki.
48
49 %package devel
50 Summary:        Include files for GStreamer streaming-media framework
51 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.4.0
55 Requires:       libxml2-devel >= 2.4.17
56 Requires:       popt-devel >= 1.6.3
57
58 %description devel
59 This package contains the includes files necessary to develop
60 applications and plugins for GStreamer.
61
62 %description devel -l pl
63 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
64 i wtyczek do GStreamera.
65
66 %package static
67 Summary:        GStreamer static libraries
68 Summary(pl):    Biblioteki statyczne GStreamer
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static versions of GStreamer libraries.
74
75 %description static -l pl
76 Statyczne wersje bibliotek GStreamer.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 #intltoolize --copy --force
84 #%%{__gettextize}
85 %{__libtoolize}
86 %{__aclocal} -I common/m4
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90
91 %configure \
92         --program-suffix="" \
93 %ifarch i586 i686 athlon
94         --enable-fast-stack-trash \
95 %else
96         --disable-fast-stack-trash \
97 %endif
98         --enable-glib2 \
99         --enable-libmmx \
100         --enable-atomic \
101         --disable-examples \
102         --disable-tests \
103         --disable-debug \
104         --disable-debug-color \
105         --enable-docs-build \
106         --with-html-dir=%{_gtkdocdir} \
107         --with-cachedir=%{_gstcachedir}
108         
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
119
120 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
121         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
122
123 %find_lang %{name} --all-name --with-gnome
124
125 # no static modules and *.la for them - shut up check files
126 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 /sbin/ldconfig
133 # how to do it ????
134 %{_bindir}/gst-register --gst-registry=%{_gstcachedir}/registry.xml
135 #%%{_bindir}/gst-register --gst-mask=0
136
137 %postun -p /sbin/ldconfig
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README TODO
142 %attr(755,root,root) %{_bindir}/*
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
144 %dir %{_gstlibdir}
145 %attr(755,root,root) %{_gstlibdir}/*.so
146 %dir %{_gstcachedir}
147 %ghost %{_gstcachedir}/registry.xml
148 %{_mandir}/man1/*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %doc DEVEL
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_libdir}/lib*.la
155 %{_gstincludedir}
156 %{_gtkdocdir}/*
157 %{_pkgconfigdir}/*
158 %{_aclocaldir}/*
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
This page took 0.035079 seconds and 3 git commands to generate.