]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
1a49817b9969f89dce976416a0bd713bbeba1c3b
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  cdio            # don't build cdio plugin
7 %bcond_without  gconf           # don't build GConf plugin
8 %bcond_without  ladspa          # don't build ladspa plugin
9 %bcond_without  speex           # don't build speex plugin
10 #
11 %define         gstname         gst-plugins-good
12 %define         gst_major_ver   0.10
13 %define         gst_req_ver     0.10.9
14 %define         gstpb_req_ver   0.10.9
15 #
16 Summary:        Good GStreamer Streaming-media framework plugins
17 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
18 Name:           gstreamer-plugins-good
19 Version:        0.10.4
20 Release:        1
21 License:        LGPL
22 Group:          Libraries
23 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
24 # Source0-md5:  e189496e7987898823d28d26b79f63dc
25 Patch0:         %{name}-bashish.patch
26 Patch1:         %{name}-libcaca.patch
27 URL:            http://gstreamer.freedesktop.org/
28 BuildRequires:  autoconf >= 2.59-9
29 BuildRequires:  automake >= 1.5
30 BuildRequires:  glib2-devel >= 1:2.12.1
31 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
32 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
33 BuildRequires:  gtk-doc >= 1.7
34 BuildRequires:  gtk+2-devel >= 2:2.10.1
35 BuildRequires:  liboil-devel >= 0.3.6
36 BuildRequires:  libtool >= 1.4
37 BuildRequires:  pkgconfig >= 1:0.9.0
38 ##
39 ## plugins
40 ##
41 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.14.0}
42 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
43 %{?with_cairo:BuildRequires:    cairo-devel >= 1.2.0}
44 BuildRequires:  dbus-devel >= 0.91
45 BuildRequires:  esound-devel >= 0.2.12
46 BuildRequires:  flac-devel >= 1.1.2
47 BuildRequires:  hal-devel >= 0.5.7.1
48 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
49 BuildRequires:  libavc1394-devel
50 %{?with_caca:BuildRequires:     libcaca-devel}
51 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
52 BuildRequires:  libdv-devel >= 0.104
53 BuildRequires:  libiec61883-devel >= 1.0.0
54 BuildRequires:  libjpeg-devel
55 BuildRequires:  libpng-devel >= 1.2.0
56 BuildRequires:  libraw1394-devel >= 1.2.1
57 BuildRequires:  libshout-devel >= 2.0
58 # for taglib
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  libxml2-devel >= 1:2.6.26
61 BuildRequires:  python-PyXML
62 BuildRequires:  rpmbuild(macros) >= 1.198
63 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
64 BuildRequires:  taglib-devel >= 1.4
65 BuildRequires:  xorg-lib-libX11-devel
66 BuildRequires:  xorg-lib-libXdamage-devel
67 BuildRequires:  xorg-lib-libXext-devel
68 BuildRequires:  xorg-lib-libXfixes-devel
69 BuildRequires:  zlib-devel
70 Requires:       gstreamer >= %{gst_req_ver}
71 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
72 Obsoletes:      gstreamer-avi
73 Obsoletes:      gstreamer-flx
74 Obsoletes:      gstreamer-matroska
75 Obsoletes:      gstreamer-mixer
76 Obsoletes:      gstreamer-navigation
77 Obsoletes:      gstreamer-rtp
78 Obsoletes:      gstreamer-udp
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
82
83 %description
84 GStreamer is a streaming-media framework, based on graphs of filters
85 which operate on media data. Applications using this library can do
86 anything from real-time sound processing to playing videos, and just
87 about anything else media-related. Its plugin-based architecture means
88 that new data types or processing capabilities can be added simply by
89 installing new plugins.
90
91 %description -l pl
92 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
93 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
94 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
95 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
96 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
97 nowych typów danych lub mo¿liwo¶ci obróbki.
98
99 %package -n gstreamer-GConf
100 Summary:        GStreamer GConf schemas
101 Summary(pl):    Schematy GConf GStreamera
102 Group:          Libraries
103 Requires(post,preun):   GConf2
104 Requires:       gstreamer >= %{gst_req_ver}
105 Obsoletes:      gstreamer-GConf-devel
106
107 %description -n gstreamer-GConf
108 Installation of GStreamer GConf schemas. These set usable defaults
109 used by all GStreamer-enabled GNOME applications.
110
111 %description -n gstreamer-GConf -l pl
112 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
113 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
114
115 ##
116 ## Plugins
117 ##
118
119 %package -n gstreamer-videosink-aa
120 Summary:        GStreamer plugin for Ascii-art output
121 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
122 Group:          Libraries
123 Requires:       gstreamer >= %{gst_req_ver}
124 Provides:       gstreamer-videosink = %{version}
125 Obsoletes:      gstreamer-aalib
126
127 %description -n gstreamer-videosink-aa
128 Plugin for viewing movies in Ascii-art using aalib library.
129
130 %description -n gstreamer-videosink-aa -l pl
131 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
132
133 %package -n gstreamer-audio-effects-good
134 Summary:        Good GStreamer audio effects plugins
135 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
136 Group:          Libraries
137 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
138 Obsoletes:      gstreamer-audio-effects
139
140 %description -n gstreamer-audio-effects-good
141 Good GStreamer audio effects plugins.
142
143 %description -n gstreamer-audio-effects-good -l pl
144 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
145
146 %package -n gstreamer-audio-formats
147 Summary:        GStreamer audio format plugins
148 Summary(pl):    Wtyczki formatów d¼wiêku
149 Group:          Libraries
150 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
151 # for locales in wavparse module
152 Requires:       %{name} = %{version}-%{release}
153
154 %description -n gstreamer-audio-formats
155 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
156
157 %description -n gstreamer-audio-formats -l pl
158 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
159
160 %package -n gstreamer-cairo
161 Summary:        GStreamer cairo plugin
162 Summary(pl):    Wtyczka cairo do GStreamera
163 Group:          Libraries
164 Requires:       gstreamer >= %{gst_req_ver}
165
166 %description -n gstreamer-cairo
167 GStreamer cairo plugin.
168
169 %description -n gstreamer-cairo -l pl
170 Wtyczka cairo do GStreamera.
171
172 %package -n gstreamer-cdio
173 Summary:        GStreamer plugin for CD audio input using libcdio
174 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca p³yty CD-Audio przy u¿yciu libcdio
175 Group:          Libraries
176 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
177 Requires:       libcdio >= 0.71
178
179 %description -n gstreamer-cdio
180 Plugin for playing audio tracks using libcdio under GStreamer.
181
182 %description -n gstreamer-cdio -l pl
183 Wtyczka do odtwarzania ¶cie¿ek d¼wiêkowych pod GStreamerem za pomoc±
184 libcdio.
185
186 %package -n gstreamer-dv
187 Summary:        GStreamer dv plugin
188 Summary(pl):    Wtyczka dv do GStreamera
189 Group:          Libraries
190 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
191
192 %description -n gstreamer-dv
193 Plugin for digital video support.
194
195 %description -n gstreamer-dv -l pl
196 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
197
198 %package -n gstreamer-audiosink-esd
199 Summary:        GStreamer plugin for ESD sound output
200 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
201 Group:          Libraries
202 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
203 Provides:       gstreamer-audiosink = %{version}
204 Obsoletes:      gstreamer-esound
205
206 %description -n gstreamer-audiosink-esd
207 Output plugin for GStreamer for use with the esound package.
208
209 %description -n gstreamer-audiosink-esd -l pl
210 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
211
212 %package -n gstreamer-flac
213 Summary:        GStreamer plugin for FLAC lossless audio format
214 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
215 Group:          Libraries
216 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
217
218 %description -n gstreamer-flac
219 Plugin for the free FLAC lossless audio format.
220
221 %description -n gstreamer-flac -l pl
222 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
223
224 %package -n gstreamer-gdkpixbuf
225 Summary:        GStreamer images input plugin
226 Summary(pl):    Wtyczka do GStreamera wczytuj±ca obrazki
227 Group:          Libraries
228 Requires:       gstreamer >= %{gst_req_ver}
229
230 %description -n gstreamer-gdkpixbuf
231 This GStreamer plugin load images via gdkpixbuf library.
232
233 %description -n gstreamer-gdkpixbuf -l pl
234 Ta wtyczka GStreamera wczytuje obrazki za po¶rednictwem biblioteki
235 gdkpixbuf.
236
237 %package -n gstreamer-hal
238 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
239 Summary(pl):    Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku z HAL-em
240 Group:          Libraries
241 Requires:       gstreamer >= %{gst_req_ver}
242
243 %description -n gstreamer-hal
244 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
245
246 %description -n gstreamer-hal -l pl
247 Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku miêdzy
248 GStreamerem a HAL-em.
249
250 %package -n gstreamer-ladspa
251 Summary:        GStreamer wrapper for LADSPA plugins
252 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
253 Group:          Libraries
254 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
255
256 %description -n gstreamer-ladspa
257 Plugin which wraps LADSPA plugins for use by GStreamer applications.
258
259 %description -n gstreamer-ladspa -l pl
260 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
261 GStreamera.
262
263 %package -n gstreamer-videosink-libcaca
264 Summary:        GStreamer plugin for libcaca Ascii-art output
265 Summary(pl):    Wtyczka libcaca do GStreamera
266 Group:          Libraries
267 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
268 Provides:       gstreamer-videosink = %{version}
269
270 %description -n gstreamer-videosink-libcaca
271 GStreamer plug-in for libcaca Ascii-art output.
272
273 %description -n gstreamer-videosink-libcaca -l pl
274 Wtyczka libcaca do GStreamera.
275
276 %package -n gstreamer-libpng
277 Summary:        GStreamer plugin to encode png images
278 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
279 Group:          Libraries
280 #Requires:      gstreamer >= %{gst_req_ver}
281 # for locales
282 Requires:       %{name} = %{version}-%{release}
283 Requires:       libpng >= 1.2.0
284
285 %description -n gstreamer-libpng
286 Plugin for encoding png images.
287
288 %description -n gstreamer-libpng -l pl
289 Wtyczka koduj±ca pliki png.
290
291 %package -n gstreamer-audiosink-oss
292 Summary:        GStreamer plugins for input and output using OSS
293 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
294 Group:          Libraries
295 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
296 # for locales
297 Requires:       %{name} = %{version}-%{release}
298 Provides:       gstreamer-audiosink = %{version}
299 Obsoletes:      gstreamer-oss
300
301 %description -n gstreamer-audiosink-oss
302 Plugins for output and input to the OpenSoundSystem audio drivers
303 found in the Linux kernels or commercially available from OpenSound.
304
305 %description -n gstreamer-audiosink-oss -l pl
306 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
307 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
308 od OpenSound.
309
310 %package -n gstreamer-raw1394
311 Summary:        GStreamer raw1394 Firewire plugin
312 Summary(pl):    Wtyczka FireWire dla GStreamera
313 Group:          Libraries
314 Requires:       gstreamer >= %{gst_req_ver}
315
316 %description -n gstreamer-raw1394
317 Plugin for digital video support using raw1394.
318
319 %description -n gstreamer-raw1394 -l pl
320 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
321
322 %package -n gstreamer-shout2
323 Summary:        GStreamer plugin for communicating with Shoutcast servers
324 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
325 Group:          Libraries
326 Requires:       gstreamer >= %{gst_req_ver}
327
328 %description -n gstreamer-shout2
329 GStreamer plugin for communicating with Shoutcast servers.
330
331 %description -n gstreamer-shout2 -l pl
332 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
333
334 %package -n gstreamer-speex
335 Summary:        GStreamer speex codec decoder/encoder plugin
336 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
337 Group:          Libraries
338 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
339 Requires:       speex >= 1:1.1.6
340
341 %description -n gstreamer-speex
342 GStreamer speex codec decoder/encoder plugin.
343
344 %description -n gstreamer-speex -l pl
345 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
346
347 %package -n gstreamer-taglib
348 Summary:        GStreamer tag writing plugin based on taglib
349 Summary(pl):    Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib
350 Group:          Libraries
351 Requires:       gstreamer >= %{gst_req_ver}
352
353 %description -n gstreamer-taglib
354 GStreamer tag writing plugin based on taglib.
355
356 %description -n gstreamer-taglib -l pl
357 Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib.
358
359 %package -n gstreamer-video-effects
360 Summary:        GStreamer video effects plugins
361 Summary(pl):    Wtyczki efektów wideo do GStreamera
362 Group:          Libraries
363 # for locales in jpeg module
364 Requires:       %{name} = %{version}-%{release}
365
366 %description -n gstreamer-video-effects
367 GStreamer video effects plugins.
368
369 %description -n gstreamer-video-effects -l pl
370 Wtyczki efektów wideo do GStreamera.
371
372 %package -n gstreamer-visualisation
373 Summary:        GStreamer visualisations plugins
374 Summary(pl):    Wtyczki wizualizacji do GStreamera
375 Group:          Libraries
376 Requires:       gstreamer >= %{gst_req_ver}
377
378 %description -n gstreamer-visualisation
379 Various plugins for visual effects to use with audio. Included are
380 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
381
382 %description -n gstreamer-visualisation -l pl
383 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
384 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
385
386 %package -n gstreamer-ximagesrc
387 Summary:        GStreamer X11 video input plugin using standard Xlib calls
388 Summary(pl):    Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ Xlib
389 Group:          Libraries
390 Requires:       %{name} = %{version}-%{release}
391
392 %description -n gstreamer-ximagesrc
393 GStreamer X11 video input plugin using standard Xlib calls.
394
395 %description -n gstreamer-ximagesrc -l pl
396 Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ
397 Xlib.
398
399 %prep
400 %setup -q -n %{gstname}-%{version}
401 %patch0 -p1
402 %patch1 -p1
403
404 %build
405 %{__libtoolize}
406 %{__aclocal} -I m4 -I common/m4
407 %{__autoconf}
408 %{__autoheader}
409 %{__automake}
410 %configure \
411         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
412         %{!?with_aalib:--disable-aalib} \
413         %{!?with_caca:--disable-libcaca} \
414         %{!?with_cairo:--disable-cairo} \
415         %{!?with_cdio:--disable-cdio} \
416         %{!?with_ladspa:--disable-ladspa} \
417         %{!?with_speex:--disable-speex} \
418         --disable-static \
419         --enable-gtk-doc \
420         --with-html-dir=%{_gtkdocdir}
421
422 %{__make}
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426
427 %{__make} install \
428         DESTDIR=$RPM_BUILD_ROOT
429
430 # We don't need plugins' *.la files
431 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
432
433 %find_lang %{gstname}-%{gst_major_ver}
434
435 %clean
436 rm -rf $RPM_BUILD_ROOT
437
438 %post   -n gstreamer-GConf
439 %gconf_schema_install gstreamer-0.10.schemas
440
441 %preun  -n gstreamer-GConf
442 %gconf_schema_uninstall gstreamer-0.10.schemas
443
444 %files -f %{gstname}-%{gst_major_ver}.lang
445 %defattr(644,root,root,755)
446 %doc AUTHORS ChangeLog NEWS README RELEASE 
447 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
448 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
449 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
450 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
451 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
452 %attr(755,root,root) %{gstlibdir}/libgstavi.so
453 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
454 %attr(755,root,root) %{gstlibdir}/libgstefence.so
455 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
456 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
457 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
458 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
459 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
460 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
461 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
462 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
463 %attr(755,root,root) %{gstlibdir}/libgstudp.so
464 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
465 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
466 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
467 %{_gtkdocdir}/gst-plugins-good-plugins-*
468
469 %if %{with gconf}
470 %files -n gstreamer-GConf
471 %defattr(644,root,root,755)
472 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
473 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
474 %endif
475
476 ##
477 ## Plugins
478 ##
479
480 %if %{with aalib}
481 %files -n gstreamer-videosink-aa
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
484 %endif
485
486 %files -n gstreamer-audio-effects-good
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
489 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
490 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
491 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
492
493 %files -n gstreamer-audio-formats
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
496 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
497 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
498
499 %if %{with cairo}
500 %files -n gstreamer-cairo
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
503 %endif
504
505 %if %{with cdio}
506 %files -n gstreamer-cdio
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
509 %endif
510
511 %files -n gstreamer-dv
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{gstlibdir}/libgstdv.so
514
515 %files -n gstreamer-audiosink-esd
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{gstlibdir}/libgstesd.so
518
519 %files -n gstreamer-flac
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{gstlibdir}/libgstflac.so
522
523 %files -n gstreamer-gdkpixbuf
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
526
527 %files -n gstreamer-hal
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
530
531 #%if %{with ladspa}
532 #%files -n gstreamer-ladspa
533 #%defattr(644,root,root,755)
534 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
535 #%endif
536
537 %if %{with caca}
538 %files -n gstreamer-videosink-libcaca
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
541 %endif
542
543 %files -n gstreamer-libpng
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{gstlibdir}/libgstpng.so
546
547 %files -n gstreamer-audiosink-oss
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
550
551 %files -n gstreamer-raw1394
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{gstlibdir}/libgst1394.so
554
555 %files -n gstreamer-shout2
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
558
559 %if %{with speex}
560 %files -n gstreamer-speex
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
563 %endif
564
565 %files -n gstreamer-taglib
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
568
569 %files -n gstreamer-video-effects
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
572 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
573 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
574 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
575
576 %files -n gstreamer-visualisation
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
579
580 %files -n gstreamer-ximagesrc
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.147453 seconds and 3 git commands to generate.