]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/commitdiff
- added opencv patch (update for opencv 2.2.0), package opencv plugin
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 9 Mar 2011 18:10:14 +0000 (18:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gstreamer-plugins-bad-opencv.patch -> 1.1
    gstreamer-plugins-bad.spec -> 1.92

gstreamer-plugins-bad-opencv.patch [new file with mode: 0644]
gstreamer-plugins-bad.spec

diff --git a/gstreamer-plugins-bad-opencv.patch b/gstreamer-plugins-bad-opencv.patch
new file mode 100644 (file)
index 0000000..bcfa96c
--- /dev/null
@@ -0,0 +1,33 @@
+--- gst-plugins-bad-0.10.21/configure.ac.orig  2011-01-22 18:42:03.006361617 +0100
++++ gst-plugins-bad-0.10.21/configure.ac       2011-01-29 13:24:36.352691389 +0100
+@@ -1226,7 +1226,7 @@
+   dnl a new version and the no-backward-compatibility define. (There doesn't
+   dnl seem to be a switch to suppress the warnings the cvcompat.h header
+   dnl causes.)
+-  PKG_CHECK_MODULES(OPENCV, opencv >= 2.0.0 opencv <= 2.1.0 , [
++  PKG_CHECK_MODULES(OPENCV, opencv >= 2.2.0 opencv < 2.3.0 , [
+     AC_PROG_CXX
+     AC_LANG_CPLUSPLUS
+     OLD_CPPFLAGS=$CPPFLAGS
+--- gst-plugins-bad-0.10.21/ext/opencv/gstfaceblur.c.orig      2010-12-07 17:22:30.000000000 +0100
++++ gst-plugins-bad-0.10.21/ext/opencv/gstfaceblur.c   2011-03-09 16:42:20.807412942 +0100
+@@ -269,7 +269,7 @@ gst_faceblur_chain (GstPad * pad, GstBuf
+   if (filter->cvCascade) {
+     faces =
+         cvHaarDetectObjects (filter->cvGray, filter->cvCascade,
+-        filter->cvStorage, 1.1, 2, 0, cvSize (30, 30));
++        filter->cvStorage, 1.1, 2, 0, cvSize (30, 30), cvSize (0, 0));
+     if (faces && faces->total > 0) {
+       buf = gst_buffer_make_writable (buf);
+--- gst-plugins-bad-0.10.21/ext/opencv/gstfacedetect.c.orig    2010-12-07 17:22:30.000000000 +0100
++++ gst-plugins-bad-0.10.21/ext/opencv/gstfacedetect.c 2011-03-09 16:45:47.607417132 +0100
+@@ -409,7 +409,7 @@ gst_facedetect_transform_ip (GstOpencvVi
+         cvHaarDetectObjects (filter->cvGray, filter->cvCascade,
+         filter->cvStorage, filter->scale_factor, filter->min_neighbors,
+         filter->flags,
+-        cvSize (filter->min_size_width, filter->min_size_height));
++        cvSize (filter->min_size_width, filter->min_size_height), cvSize (0, 0));
+     if (faces && faces->total > 0) {
+       msg = gst_facedetect_message_new (filter, buf);
index 939d78ef6df388f6108e12f98b653158cb3f4ef2..cb82e71a85328d31f2da4f09b72ae44594897117 100644 (file)
@@ -15,6 +15,7 @@
 %bcond_without musepack        # don't build musepack plugin
 %bcond_without neon            # don't build neonhttpsrc plugin
 %bcond_without ofa             # don't build OFA plugin
+%bcond_without opencv          # don't build OpenCV plugin
 %bcond_without sdl             # don't build sdl plugin
 %bcond_with    swfdec          # swfdec plugin
 %bcond_without spc             # don't build spc plugin
@@ -44,6 +45,7 @@ Patch2:               %{name}-divx4linux.patch
 Patch4:                %{name}-timidity.patch
 Patch5:                %{name}-nas.patch
 Patch6:                %{name}-celt.patch
+Patch7:                %{name}-opencv.patch
 URL:           http://gstreamer.freedesktop.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.10
@@ -111,12 +113,10 @@ BuildRequires:    libtiger-devel >= 0.3.2
 BuildRequires: libtimidity-devel
 BuildRequires: libvpx-devel
 BuildRequires: libx264-devel >= 0.1.2
-BuildRequires: lv2core-devel
 %{?with_mjpegtools:BuildRequires:      mjpegtools-devel >= 1.9.0}
 BuildRequires: nas-devel
 %{?with_neon:BuildRequires:    neon-devel >= 0.27.0}
-# TODO
-#BuildRequires:        opencv-devel >= 2.0.0
+%{?with_opencv:BuildRequires:  opencv-devel >= 2.2.0}
 BuildRequires: openssl-devel >= 0.9.5
 BuildRequires: schroedinger-devel >= 1.0.7
 BuildRequires: slv2-devel >= 0.6.6
@@ -504,6 +504,25 @@ files.
 Wtyczka OFA do GStreamera służąca do obliczania odcisków MusicIP
 plików dźwiękowych.
 
+%package -n gstreamer-opencv
+Summary:       GStreamer OpenCV plugin
+Summary(pl.UTF-8):     Wtyczka OpenCV do GStreamera
+Group:         Libraries
+Requires:      gstreamer >= %{gst_req_ver}
+Requires:      opencv >= 2.2.0
+
+%description -n gstreamer-opencv
+GStreamer OpenCV plugin. It contains the following elements:
+facedetect, faceblur, edgedetect, cvsobel, cvsmooth, cvlaplace,
+cverode, cvequalizehist, cvdilate, textwrite, templatematch,
+pyramidsegment.
+
+%description -n gstreamer-opencv -l pl.UTF-8
+Wtyczka OpenCV do GStreamera. Zawiera następujące elementy:
+facedetect, faceblur, edgedetect, cvsobel, cvsmooth, cvlaplace,
+cverode, cvequalizehist, cvdilate, textwrite, templatematch,
+pyramidsegment.
+
 %package -n gstreamer-resindvd
 Summary:       GStreamer Resin DVD playback plugin
 Summary(pl.UTF-8):     Wtyczka odtwarzania Resin DVD do GStreamera
@@ -682,6 +701,7 @@ Wtyczka do GStreamera skanująca kody kreskowe.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 %build
 %{__libtoolize}
@@ -997,6 +1017,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{gstlibdir}/libgstofa.so
 %endif
 
+%if %{with opencv}
+%files -n gstreamer-opencv
+%defattr(644,root,root,755)
+%attr(755,root,root) %{gstlibdir}/libgstopencv.so
+%endif
+
 %files -n gstreamer-resindvd
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gstlibdir}/libresindvd.so
This page took 0.117955 seconds and 4 git commands to generate.