]> git.pld-linux.org Git - packages/grub2.git/commitdiff
- rel 4; fix build with gcc8 auto/th/grub2-2.02-4
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 13 Aug 2018 15:20:44 +0000 (17:20 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 13 Aug 2018 15:20:44 +0000 (17:20 +0200)
gcc8.patch [new file with mode: 0644]
grub2.spec

diff --git a/gcc8.patch b/gcc8.patch
new file mode 100644 (file)
index 0000000..63a8917
--- /dev/null
@@ -0,0 +1,62 @@
+commit 563b1da6e6ae7af46cc8354cadb5dab416989f0a
+Author: Michael Chang <mchang@suse.com>
+Date:   Mon Mar 26 16:52:34 2018 +0800
+
+    Fix packed-not-aligned error on GCC 8
+    
+    When building with GCC 8, there are several errors regarding packed-not-aligned.
+    
+    ./include/grub/gpt_partition.h:79:1: error: alignment 1 of ‘struct grub_gpt_partentry’ is less than 8 [-Werror=packed-not-aligned]
+    
+    This patch fixes the build error by cleaning up the ambiguity of placing
+    aligned structure in a packed one. In "struct grub_btrfs_time" and "struct
+    grub_gpt_part_type", the aligned attribute seems to be superfluous, and also
+    has to be packed, to ensure the structure is bit-to-bit mapped to the format
+    laid on disk. I think we could blame to copy and paste error here for the
+    mistake. In "struct efi_variable", we have to use grub_efi_packed_guid_t, as
+    the name suggests. :)
+    
+    Signed-off-by: Michael Chang <mchang@suse.com>
+    Tested-by: Michael Chang <mchang@suse.com>
+    Tested-by: Paul Menzel <paulepanter@users.sourceforge.net>
+    Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
+
+diff --git a/grub-core/fs/btrfs.c b/grub-core/fs/btrfs.c
+index 4849c1ceb..be195448d 100644
+--- a/grub-core/fs/btrfs.c
++++ b/grub-core/fs/btrfs.c
+@@ -175,7 +175,7 @@ struct grub_btrfs_time
+ {
+   grub_int64_t sec;
+   grub_uint32_t nanosec;
+-} __attribute__ ((aligned (4)));
++} GRUB_PACKED;
+ struct grub_btrfs_inode
+ {
+diff --git a/include/grub/efiemu/runtime.h b/include/grub/efiemu/runtime.h
+index 9b6b729f4..36d2dedf4 100644
+--- a/include/grub/efiemu/runtime.h
++++ b/include/grub/efiemu/runtime.h
+@@ -29,7 +29,7 @@ struct grub_efiemu_ptv_rel
+ struct efi_variable
+ {
+-  grub_efi_guid_t guid;
++  grub_efi_packed_guid_t guid;
+   grub_uint32_t namelen;
+   grub_uint32_t size;
+   grub_efi_uint32_t attributes;
+diff --git a/include/grub/gpt_partition.h b/include/grub/gpt_partition.h
+index 1b32f6725..9668a68c3 100644
+--- a/include/grub/gpt_partition.h
++++ b/include/grub/gpt_partition.h
+@@ -28,7 +28,7 @@ struct grub_gpt_part_type
+   grub_uint16_t data2;
+   grub_uint16_t data3;
+   grub_uint8_t data4[8];
+-} __attribute__ ((aligned(8)));
++} GRUB_PACKED;
+ typedef struct grub_gpt_part_type grub_gpt_part_type_t;
+ #define GRUB_GPT_PARTITION_TYPE_EMPTY \
index f4c1234dc36b382184ccd7478a53ebd17fdcb5a3..7bd9eb73e9648fa31dd61de121463272c408fdab 100644 (file)
@@ -47,7 +47,7 @@ Summary(pl.UTF-8):    GRUB2 - bootloader dla x86 i ppc
 Summary(pt_BR.UTF-8):  Gerenciador de inicialização GRUB2
 Name:          grub2
 Version:       2.02
-Release:       3
+Release:       4
 License:       GPL v2
 Group:         Base
 Source0:       ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
@@ -73,6 +73,7 @@ Patch14:      blscfg.patch
 # https://git.archlinux.org/svntogit/packages.git/plain/trunk/0002-intel-ucode.patch?h=packages/grub
 Patch15:       intel-ucode.patch
 Patch16:       xfs.patch
+Patch17:       gcc8.patch
 URL:           http://www.gnu.org/software/grub/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1:1.11.1-1
@@ -303,6 +304,7 @@ Motyw starfield dla GRUB-a.
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
+%patch17 -p1
 
 # we don't have C.utf-8 and need an UTF-8 locale for build
 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
This page took 0.122994 seconds and 4 git commands to generate.