]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
Mangle root device name only for LVM devices, release 5
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 Name:           grub2
48 Version:        2.00
49 Release:        5
50 License:        GPL v2
51 Group:          Base
52 Source0:        http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
53 # Source0-md5:  a1043102fbc7bcedbf53e7ee3d17ab91
54 Source1:        update-grub
55 Source2:        update-grub.8
56 Source3:        grub.sysconfig
57 Source4:        grub-custom.cfg
58 Patch1:         pld-sysconfdir.patch
59 Patch2:         grub-garbage.patch
60 Patch3:         grub-lvmdevice.patch
61 Patch4:         pld-mkconfigdir.patch
62 Patch5:         grub-mkconfig-diagnostics.patch
63 Patch6:         ppc.patch
64 Patch7:         %{name}-awk.patch
65 Patch8:         posix.patch
66 Patch9:         %{name}-gets.patch
67 Patch10:        %{name}-fonts_path.patch
68 Patch11:        %{name}-tftp_fix.patch
69 Patch12:        add-vlan-tag-support.patch
70 Patch13:        just-say-linux.patch
71 Patch14:        add-GRUB-DISABLE-SUBMENU-option.patch
72 Patch15:        add-X-option-to-printf-functions.patch
73 Patch16:        dhcp-client-id-and-uuid-options-added.patch
74 Patch17:        fix-http-crash.patch
75 Patch18:        Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
76 Patch19:        search-for-specific-config-file-for-netboot.patch
77 Patch20:        ignore-kernel-symlinks.patch
78 Patch21:        choose-preferred-initrd.patch
79 Patch22:        %{name}-cfg.patch
80 URL:            http://www.gnu.org/software/grub/
81 BuildRequires:  autoconf >= 2.53
82 BuildRequires:  automake >= 1:1.11.1-1
83 BuildRequires:  bison
84 BuildRequires:  device-mapper-devel
85 BuildRequires:  flex >= 2.5.35
86 BuildRequires:  fonts-TTF-DejaVu
87 BuildRequires:  freetype-devel >= 2
88 BuildRequires:  gawk
89 BuildRequires:  gettext-devel
90 BuildRequires:  glibc-static
91 BuildRequires:  help2man
92 BuildRequires:  libfuse-devel
93 BuildRequires:  libtool
94 BuildRequires:  ncurses-devel
95 BuildRequires:  rpm >= 4.4.9-56
96 BuildRequires:  rpmbuild(macros) >= 1.213
97 BuildRequires:  sed >= 4.0
98 BuildRequires:  tar >= 1:1.22
99 BuildRequires:  texinfo
100 BuildRequires:  xz
101 BuildRequires:  xz-devel
102 %ifarch %{x8664}
103 BuildRequires:  /usr/lib/libc.so
104 %if "%{pld_release}" == "ac"
105 BuildRequires:  libgcc32
106 %else
107 BuildRequires:  gcc-multilib
108 %endif
109 %endif
110 Requires:       %{name}-platform = %{version}-%{release}
111 Requires:       pld-release
112 Requires:       which
113 %ifarch %{ix86} %{x8664}
114 Suggests:       %{name}-platform-pc
115 %endif
116 Suggests:       cdrkit-mkisofs
117 Suggests:       os-prober
118 Provides:       bootloader
119 Conflicts:      grub
120 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         _sbindir        /sbin
124 %define         _bindir         %{_sbindir}
125 %define         _libdir         /lib
126 %define         _datadir        %{_libdir}
127 %define         _libexecdir     %{_libdir}/grub
128 %define         _grubdir        /boot/grub
129 %define         _localedir      /usr/share/locale
130
131 # part of grub code is not relocable (these are not Linux libs)
132 # stack protector also breaks non-Linux binaries
133 # any kind of forced optimizations makes grub2 unreliable (random
134 # reboots and hangs on boot menu screen)
135 %define         filterout_c     -fPIC -O.
136 %undefine       _ssp_cflags
137 %undefine       _fortify_cflags
138
139 %description
140 GRUB is a GPLed bootloader intended to unify bootloading across x86
141 operating systems. In addition to loading the Linux and *BSD kernels,
142 it implements the Multiboot standard, which allows for flexible
143 loading of multiple boot images (needed for modular kernels such as
144 the GNU Hurd).
145
146 GRUB 2 is derived from PUPA which was a research project to
147 investigate the next generation of GRUB. GRUB 2 has been rewritten
148 from scratch to clean up everything for modularity and portability.
149
150 GRUB 2 targets at the following goals:
151 - Scripting support, such as conditionals, loops, variables and
152   functions.
153 - Graphical interface.
154 - Dynamic loading of modules in order to extend itself at the run time
155   rather than at the build time.
156 - Portability for various architectures.
157 - Internationalization. This includes support for non-ASCII character
158   code, message catalogs like gettext, fonts, graphics console, and so
159   on.
160 - Real memory management, to make GNU GRUB more extensible.
161 - Modular, hierarchical, object-oriented framework for file systems,
162   files, devices, drives, terminals, commands, partition tables and OS
163   loaders.
164 - Cross-platform installation which allows for installing GRUB from a
165   different architecture.
166 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167 - Fix design mistakes in GRUB Legacy, which could not be solved for
168   backward-compatibility, such as the way of numbering partitions.
169
170 %description -l de.UTF-8
171 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
173 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
174
175 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
176 und wird unter der GPL vertrieben. Aufgrund seiner höheren
177 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
178 traditionellen Boot-Loader LILO.
179
180 %description -l hu.UTF-8
181 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184 GNU Hurd).
185
186 GRUB2 céljai a következők:
187 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188   függvények.
189 - grafikus felület
190 - modulok dinamikus betöltése futási időben
191 - hordozhatóság több architektúrára
192 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193   mint gettext, betűtípusok, grafikus konzolon, és így tovább
194 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195 - moduláris, hierarchikus, objektum-orientált keretrendszer
196   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
199 %description -l es.UTF-8
200 Éste es GRUB - Grand Unified Boot Loader - un administrador de
201 inicialización capaz de entrar en la mayoría de los sistemas
202 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
203 también en la mayoría de los sistemas operacionales comerciales para
204 PC.
205
206 El administrador GRUB puede ser una buena alternativa a LILO, para
207 usuarios conmás experiencia y que deseen obtener más recursos de su
208 cargador de inicialización (boot loader).
209
210 %description -l pl.UTF-8
211 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
212 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
213 Linuksa i *BSD: posiada również implementację standardu Multiboot,
214 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215 (czego wymagają modułowe jądra, takie jak GNU Hurd).
216
217 %description -l pt_BR.UTF-8
218 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
219 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221 operacionais comerciais para PC.
222
223 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224 avançados e que querem mais recursos de seu boot loader.
225
226 %package -n bash-completion-%{name}
227 Summary:        bash-completion for GRUB
228 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
229 Group:          Applications/Shells
230 Requires:       bash-completion
231
232 %description -n bash-completion-%{name}
233 This package provides bash-completion for GRUB.
234
235 %description -n bash-completion-%{name} -l pl.UTF-8
236 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
237
238 %package platform-pc
239 Summary:        PC BIOS platform support for GRUB
240 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
241 Group:          Base
242 Provides:       %{name}-platform = %{version}-%{release}
243
244 %description platform-pc
245 PC BIOS platform support for GRUB.
246
247 %description platform-pc -l pl.UTF-8
248 Obsługa platformy PC BIOS dla GRUB-a.
249
250 %package platform-efi
251 Summary:        (U)EFI platform support for GRUB
252 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
253 Group:          Base
254 Suggests:       efibootmgr
255 Provides:       %{name}-platform = %{version}-%{release}
256
257 %description platform-efi
258 (U)EFI platform support for GRUB.
259
260 %description platform-efi -l pl.UTF-8
261 Obsługa platformy (U)EFI dla GRUB-a.
262
263 %package mkfont
264 Summary:        GRUB font files converter
265 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
266 Group:          Base
267
268 %description mkfont
269 Converts common font file formats into PF2.
270
271 %description mkfont -l pl.UTF-8
272 Program do konwersji popularnych formatów plików fontów do PF2.
273
274 %package theme-starfield
275 Summary:        starfield theme for GRUB
276 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
277 Group:          Base
278
279 %description theme-starfield
280 starfield theme for GRUB.
281
282 %description theme-starfield -l pl.UTF-8
283 Motyw starfield dla GRUB-a.
284
285 %prep
286 %setup -q -n grub-%{version}
287 %patch1 -p1
288 %patch2 -p1
289 %patch3 -p1
290 %patch4 -p1
291 %patch5 -p1
292 %patch6 -p1
293 %patch7 -p1
294 %patch8 -p1
295 %patch9 -p1
296 %patch10 -p1
297 %patch11 -p1
298 %patch12 -p1
299 %patch13 -p1
300 %patch14 -p1
301 %patch15 -p1
302 %patch16 -p1
303 %patch17 -p1
304 %patch18 -p1
305 %patch19 -p1
306 %patch20 -p1
307 %patch21 -p1
308 %patch22 -p0
309
310 %build
311 # if gold is used then grub doesn't even boot
312 # https://savannah.gnu.org/bugs/?34539
313 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
314 install -d our-ld
315 ln -s /usr/bin/ld.bfd our-ld/ld
316 export PATH=$(pwd)/our-ld:$PATH
317
318 cp -f /usr/share/automake/config.sub .
319 %{__libtoolize}
320 %{__aclocal} -I m4
321 %{__autoheader}
322 echo timestamp > stamp-h.in
323 %{__autoconf}
324 %{__automake}
325
326 for platform in %{platforms} ; do
327         install -d build-${platform}
328         cd build-${platform}
329
330         if [ "$platform" != "efi" ] ; then
331                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
332         else
333                 platform_opts=""
334         fi
335
336         ln -s ../configure .
337         # mawk stalls at ./genmoddep.awk, so force gawk
338         AWK=gawk \
339         %configure \
340                 --with-platform=${platform} \
341                 --disable-werror \
342         %if %{with grubemu}
343                 --enable-grub-emu-usb \
344                 --enable-grub-emu-sdl \
345                 --enable-grub-emu-pci \
346         %endif
347                 $platform_opts \
348                 TARGET_LDFLAGS=-static
349
350         %{__make}
351         cd ..
352 done
353
354 %install
355 rm -rf $RPM_BUILD_ROOT
356
357 for platform in %{platforms} ; do
358         cd build-${platform}
359         %{__make} install \
360                 pkgdatadir=%{_libexecdir} \
361                 pkglibdir=%{_libexecdir} \
362                 DESTDIR=$RPM_BUILD_ROOT
363         cd ..
364 done
365
366 # not in Th (?)
367 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
368 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
369
370 %find_lang grub
371
372 # this must be after 'make install'
373 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
374
375 install -d $RPM_BUILD_ROOT%{_grubdir}
376 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
377
378 # grub.d/41_custom
379 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
380 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
381
382 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
383 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
384
385 install -d $RPM_BUILD_ROOT/etc/sysconfig
386 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
387
388 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
389 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
390
391 # platform specific, unnecessarily always installed
392 %ifnarch %{ix86} %{x8664}
393 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
394 %endif
395 %ifnarch sparc64
396 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
397 %endif
398
399 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
400 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
401 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
402
403 # needs to be exactly 1KiB
404 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
405 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
406
407 %clean
408 rm -rf $RPM_BUILD_ROOT
409
410 %post -p %{_sbindir}/postshell
411 -/usr/sbin/fix-info-dir -c %{_infodir}
412
413 %postun -p %{_sbindir}/postshell
414 -/usr/sbin/fix-info-dir -c %{_infodir}
415
416 %triggerpostun -- %{name} < 2.00-2
417 # Note this trigger on version upgrade needed only for upgrade from
418 # old grub2 packages which contained modules in /boot/grub
419 # or were built with optimizations enabled
420 # don't do anything on --downgrade
421 if [ $1 -le 1 ]; then
422         exit 0
423 fi
424 echo "Grub was upgraded, trying to setup it to boot sector"
425 /sbin/grub-install '(hd0)' || :
426
427 %triggerpostun -- %{name} < 1.99-7.3
428 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
429 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
430         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
431         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
432 fi
433
434 %files -f grub.lang
435 %defattr(644,root,root,755)
436 %doc AUTHORS ChangeLog NEWS README THANKS TODO
437 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
438 %attr(755,root,root) %{_sbindir}/grub-editenv
439 %attr(755,root,root) %{_sbindir}/grub-fstest
440 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
441 %attr(755,root,root) %{_sbindir}/grub-install
442 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
443 %attr(755,root,root) %{_sbindir}/grub-mkconfig
444 %attr(755,root,root) %{_sbindir}/grub-mklayout
445 %attr(755,root,root) %{_sbindir}/grub-mknetdir
446 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
447 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
448 %attr(755,root,root) %{_sbindir}/grub-mkrescue
449 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
450 %attr(755,root,root) %{_sbindir}/grub-mount
451 %attr(755,root,root) %{_sbindir}/grub-ofpathname
452 %attr(755,root,root) %{_sbindir}/grub-reboot
453 %attr(755,root,root) %{_sbindir}/grub-script-check
454 %attr(755,root,root) %{_sbindir}/grub-set-default
455 %attr(755,root,root) %{_sbindir}/update-grub
456 %ifarch %{ix86} %{x8664}
457 %attr(755,root,root) %{_sbindir}/grub-bios-setup
458 %{_mandir}/man8/grub-bios-setup.8*
459 %endif
460 %ifarch %{ix86} %{x8664}
461 %attr(755,root,root) %{_sbindir}/grub-mkimage
462 %{_mandir}/man1/grub-mkimage.1*
463 %else
464 %attr(755,root,root) %{_sbindir}/grub-probe
465 %{_mandir}/man8/grub-probe.8*
466 %endif
467 %ifarch sparc64
468 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
469 %{_mandir}/man8/grub-sparc64-setup.8*
470 %endif
471 %{_mandir}/man1/grub-editenv.1*
472 %{_mandir}/man1/grub-fstest.1*
473 %{_mandir}/man1/grub-kbdcomp.1*
474 %{_mandir}/man1/grub-menulst2cfg.1*
475 %{_mandir}/man1/grub-mklayout.1*
476 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
477 %{_mandir}/man1/grub-mkrelpath.1*
478 %{_mandir}/man1/grub-mkrescue.1*
479 %{_mandir}/man1/grub-mkstandalone.1*
480 %{_mandir}/man1/grub-mount.1*
481 %{_mandir}/man1/grub-script-check.1*
482 %{_mandir}/man8/grub-install.8*
483 %{_mandir}/man8/grub-mkconfig.8*
484 %{_mandir}/man8/grub-mknetdir.8*
485 %{_mandir}/man8/grub-ofpathname.8*
486 %{_mandir}/man8/grub-reboot.8*
487 %{_mandir}/man8/grub-set-default.8*
488 %{_mandir}/man8/update-grub.8*
489 %if %{with grubemu}
490 %attr(755,root,root) %{_sbindir}/grub-emu
491 %{_mandir}/man8/grub-emu.8*
492 %endif
493 %{_libexecdir}/grub-mkconfig_lib
494
495 %dir %{_grubdir}
496 %dir %{_libexecdir}
497 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
498
499 %dir %{_libexecdir}/locale
500 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
501 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
502
503 # generated by grub at runtime
504 %ghost %{_grubdir}/device.map
505 %ghost %{_grubdir}/core.img
506 %ghost %{_grubdir}/grubenv
507
508 %dir /lib/grub.d
509 %doc /lib/grub.d/README
510 %attr(755,root,root) /lib/grub.d/00_header
511 %attr(755,root,root) /lib/grub.d/10_linux
512 %attr(755,root,root) /lib/grub.d/20_linux_xen
513 %attr(755,root,root) /lib/grub.d/30_os-prober
514 %attr(755,root,root) /lib/grub.d/41_custom
515
516 %ifarch %{ix86} %{x8664}
517 %attr(755,root,root) %{_sbindir}/grub-probe
518 %{_mandir}/man8/grub-probe.8*
519 %endif
520
521 %{_infodir}/grub*.info*
522
523 %dir %{_datadir}/grub/themes
524
525 %if %{with pc}
526 %files platform-pc
527 %defattr(644,root,root,755)
528 %dir %{_libexecdir}/*-pc
529 %{_libexecdir}/*-pc/modinfo.sh
530 %{_libexecdir}/*-pc/*.exec
531 %{_libexecdir}/*-pc/*.image
532 %{_libexecdir}/*-pc/*.lst
533 %{_libexecdir}/*-pc/*.mod
534 %{_libexecdir}/*-pc/*.module
535 %{_libexecdir}/*-pc/lzma_decompress.img
536 %{_libexecdir}/*-pc/config.h
537 %{_libexecdir}/*-pc/gdb_grub
538 %{_libexecdir}/*-pc/gmodule.pl
539 %if %{with efiemu}
540 %{_libexecdir}/*-pc/efiemu*.o
541 %endif
542 %{_libexecdir}/*-pc/kernel.img
543 %ifarch %{ix86} %{x8664} sparc sparc64
544 %{_libexecdir}/*-pc/boot.img
545 %{_libexecdir}/*-pc/cdboot.img
546 %{_libexecdir}/*-pc/diskboot.img
547 %{_libexecdir}/*-pc/lnxboot.img
548 %{_libexecdir}/*-pc/pxeboot.img
549 %endif
550 %endif
551
552 %if %{with efi}
553 %files platform-efi
554 %defattr(644,root,root,755)
555 %dir %{_libexecdir}/*-efi
556 %{_libexecdir}/*-efi/modinfo.sh
557 %{_libexecdir}/*-efi/*.exec
558 %{_libexecdir}/*-efi/*.lst
559 %{_libexecdir}/*-efi/*.mod
560 %{_libexecdir}/*-efi/*.module
561 %{_libexecdir}/*-efi/config.h
562 %{_libexecdir}/*-efi/gdb_grub
563 %{_libexecdir}/*-efi/gmodule.pl
564 %{_libexecdir}/*-efi/kernel.img
565 %endif
566
567 %files mkfont
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_sbindir}/grub-mkfont
570 %{_mandir}/man1/grub-mkfont.1*
571
572 %files theme-starfield
573 %defattr(644,root,root,755)
574 %{_datadir}/grub/themes/starfield
575
576 %files -n bash-completion-%{name}
577 %defattr(644,root,root,755)
578 /etc/bash_completion.d/grub
This page took 0.094703 seconds and 4 git commands to generate.