]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
add boot loader specification support
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d 15
50ffb0ba 16%ifnarch %{ix86} %{x8664} x32
feaacba3
JB
17%undefine with_pc
18%endif
50ffb0ba 19%ifnarch %{ix86} %{x8664} x32 ia64
feaacba3
JB
20%undefine with_efi
21%endif
22
50ffb0ba 23%ifnarch %{x8664} x32
2d8da575
AM
24# non-x86_64 arch doesn't support this
25%undefine with_efiemu
26%endif
27
1536aaf2 28# the 'most natural' platform should go last
50ffb0ba 29%ifarch %{ix86} %{x8664} x32 ia64
1536aaf2 30%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
31%endif
32%ifarch ppc ppc64 sparc64
33%define platforms ieee1275
34%endif
35%ifarch mips
36%define platforms arc
37%endif
38%ifarch mipsel
39%define platforms loongson
40%endif
1536aaf2 41
5ae70a42 42%define rel 5
afe8504a 43Summary: GRand Unified Bootloader
c8155f7f 44Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 45Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
46Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
47Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
139b6f37 48%define beta beta2
afe8504a 49Name: grub2
b876d99a 50Version: 2.02
cd9d315f 51Release: 0.%{beta}.%{rel}
2e4bec6f 52License: GPL v2
afe8504a 53Group: Base
5bafb558 54# git://git.savannah.gnu.org/grub.git
b876d99a
JK
55# git checkout %{version}~%{beta} ; make dist
56Source0: grub-%{version}~%{beta}.tar.gz
57# Source0-md5: ca6c18f6c5f1ed05b7444017a40573d9
22909ca1
ER
58Source1: update-grub
59Source2: update-grub.8
b46589aa 60Source3: grub.sysconfig
e2964b87 61Source4: grub-custom.cfg
5bafb558
JK
62# ./linguas.sh
63# TS=$(date +'%Y%m%d') ; tar cjvf grub-po-2.00.git$TS.tar.bz2 po/*.po po/LINGUAS
139b6f37 64Source5: grub-po-%{version}.git20140104.tar.bz2
b876d99a 65# Source5-md5: aeef3e636178093cf9d780d92da7afdb
b46589aa 66Patch1: pld-sysconfdir.patch
872700b0 67Patch2: grub-garbage.patch
c9273ffc
JK
68Patch3: grub-lvmdevice.patch
69Patch4: pld-mkconfigdir.patch
70Patch5: grub-mkconfig-diagnostics.patch
668ecb01
JK
71Patch6: posix.patch
72Patch7: %{name}-fonts_path.patch
73Patch8: add-vlan-tag-support.patch
74Patch9: just-say-linux.patch
75Patch10: ignore-kernel-symlinks.patch
76Patch11: choose-preferred-initrd.patch
77Patch12: %{name}-cfg.patch
c287192d 78Patch13: efi-net-fix.patch
2c79d729
JR
79Patch14: grub2-xfs-Add-helper-for-inode-size.patch
80Patch15: grub2-xfs-Convert-inode-numbers-to-cpu-endianity-immediate.patch
81Patch16: grub2-xfs-Fix-termination-loop-for-directory-iteration.patch
82Patch17: grub2-xfs-V5-filesystem-format-support.patch
36121927 83Patch18: blscfg.patch
feaacba3 84URL: http://www.gnu.org/software/grub/
27550907
ER
85BuildRequires: autoconf >= 2.53
86BuildRequires: automake >= 1:1.11.1-1
8b781299 87BuildRequires: bison
06df59fd 88BuildRequires: device-mapper-devel
feaacba3 89BuildRequires: flex >= 2.5.35
26996aed 90BuildRequires: fonts-TTF-DejaVu
feaacba3 91BuildRequires: freetype-devel >= 2
12fd19f5 92BuildRequires: gawk
39b1c916 93BuildRequires: gcc >= 5:3.4
5d291ad2 94BuildRequires: gettext-tools
5bafb558 95BuildRequires: glibc-localedb-all
feaacba3 96BuildRequires: glibc-static
1349ebb8 97BuildRequires: help2man
42985b0d 98BuildRequires: libfuse-devel
afe8504a 99BuildRequires: libtool
feaacba3 100BuildRequires: ncurses-devel
5bafb558
JK
101BuildRequires: python
102BuildRequires: python-modules
feaacba3
JB
103BuildRequires: rpm >= 4.4.9-56
104BuildRequires: rpmbuild(macros) >= 1.213
105BuildRequires: sed >= 4.0
106BuildRequires: tar >= 1:1.22
81a7e0ba 107BuildRequires: texinfo
feaacba3
JB
108BuildRequires: xz
109BuildRequires: xz-devel
c668211a
ER
110%ifarch %{x8664}
111BuildRequires: /usr/lib/libc.so
8905dae4
ER
112%if "%{pld_release}" == "ac"
113BuildRequires: libgcc32
114%else
50ffb0ba 115BuildRequires: gcc-multilib-32
c668211a 116%endif
dee0d6f5 117%endif
feaacba3 118Requires: %{name}-platform = %{version}-%{release}
a5138d8d 119Requires: pld-release
dc6928bc 120Requires: which
feaacba3
JB
121%ifarch %{ix86} %{x8664}
122Suggests: %{name}-platform-pc
123%endif
190cc685 124Suggests: cdrkit-mkisofs
97ee543c 125Suggests: os-prober
afe8504a 126Provides: bootloader
fc835b5e 127Conflicts: grub
50ffb0ba 128ExclusiveArch: %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
129BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
130
131%define _sbindir /sbin
4a00f3b7 132%define _bindir %{_sbindir}
1536aaf2 133%define _libdir /lib
e6fbd304 134%define _datadir %{_libdir}
26e757db 135%define _libexecdir %{_libdir}/grub
1536aaf2 136%define _grubdir /boot/grub
da9b7cf9 137%define _localedir /usr/share/locale
9d44d75e 138
0e2cbb94
JK
139# part of grub code is not relocable (these are not Linux libs)
140# stack protector also breaks non-Linux binaries
8c5e5aa2
JR
141# any kind of forced optimizations makes grub2 unreliable (random
142# reboots and hangs on boot menu screen)
5bc5d891 143%define filterout_c -fPIC -O.
5967241e 144%undefine _ssp_cflags
5bc5d891 145%undefine _fortify_cflags
0e2cbb94 146
afe8504a
SP
147%description
148GRUB is a GPLed bootloader intended to unify bootloading across x86
149operating systems. In addition to loading the Linux and *BSD kernels,
150it implements the Multiboot standard, which allows for flexible
151loading of multiple boot images (needed for modular kernels such as
152the GNU Hurd).
153
211df1ed
ER
154GRUB 2 is derived from PUPA which was a research project to
155investigate the next generation of GRUB. GRUB 2 has been rewritten
156from scratch to clean up everything for modularity and portability.
157
158GRUB 2 targets at the following goals:
159- Scripting support, such as conditionals, loops, variables and
160 functions.
161- Graphical interface.
162- Dynamic loading of modules in order to extend itself at the run time
163 rather than at the build time.
164- Portability for various architectures.
165- Internationalization. This includes support for non-ASCII character
166 code, message catalogs like gettext, fonts, graphics console, and so
167 on.
168- Real memory management, to make GNU GRUB more extensible.
169- Modular, hierarchical, object-oriented framework for file systems,
170 files, devices, drives, terminals, commands, partition tables and OS
171 loaders.
172- Cross-platform installation which allows for installing GRUB from a
173 different architecture.
174- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
175- Fix design mistakes in GRUB Legacy, which could not be solved for
176 backward-compatibility, such as the way of numbering partitions.
177
6b0aefbf 178%description -l de.UTF-8
afe8504a
SP
179GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
180Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 181läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
182
183GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
184und wird unter der GPL vertrieben. Aufgrund seiner höheren
185Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
186traditionellen Boot-Loader LILO.
187
f97cafb4
ZU
188%description -l hu.UTF-8
189GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
190betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
191teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
192GNU Hurd).
193
194GRUB2 céljai a következők:
195- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
196 függvények.
197- grafikus felület
198- modulok dinamikus betöltése futási időben
199- hordozhatóság több architektúrára
200- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
201 mint gettext, betűtípusok, grafikus konzolon, és így tovább
202- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
203- moduláris, hierarchikus, objektum-orientált keretrendszer
204 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
205 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
206
6b0aefbf
JR
207%description -l es.UTF-8
208Éste es GRUB - Grand Unified Boot Loader - un administrador de
209inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 210operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 211también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
212PC.
213
214El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
215usuarios conmás experiencia y que deseen obtener más recursos de su
216cargador de inicialización (boot loader).
afe8504a 217
6b0aefbf 218%description -l pl.UTF-8
feaacba3 219GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 220procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 221Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
222który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
223(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 224
6b0aefbf
JR
225%description -l pt_BR.UTF-8
226Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
227capaz de entrar na maioria dos sistemas operacionais livres - Linux,
228FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
229operacionais comerciais para PC.
230
6b0aefbf
JR
231O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
232avançados e que querem mais recursos de seu boot loader.
afe8504a 233
565fe2e3
ER
234%package -n bash-completion-%{name}
235Summary: bash-completion for GRUB
feaacba3 236Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
237Group: Applications/Shells
238Requires: bash-completion
d28207fb
ER
239%if "%{_rpmversion}" >= "5"
240BuildArch: noarch
241%endif
565fe2e3
ER
242
243%description -n bash-completion-%{name}
244This package provides bash-completion for GRUB.
245
246%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 247Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 248
6d8475a4 249%package platform-pc
62081337 250Summary: PC BIOS platform support for GRUB
feaacba3 251Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 252Group: Base
6d8475a4 253Provides: %{name}-platform = %{version}-%{release}
1536aaf2 254
6d8475a4 255%description platform-pc
62081337 256PC BIOS platform support for GRUB.
1536aaf2 257
feaacba3
JB
258%description platform-pc -l pl.UTF-8
259Obsługa platformy PC BIOS dla GRUB-a.
260
6d8475a4 261%package platform-efi
1536aaf2 262Summary: (U)EFI platform support for GRUB
feaacba3 263Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 264Group: Base
6e81e1fe 265Suggests: efibootmgr
6d8475a4 266Provides: %{name}-platform = %{version}-%{release}
1536aaf2 267
6d8475a4 268%description platform-efi
1536aaf2
JK
269(U)EFI platform support for GRUB.
270
feaacba3
JB
271%description platform-efi -l pl.UTF-8
272Obsługa platformy (U)EFI dla GRUB-a.
273
7615a862
JK
274%package mkfont
275Summary: GRUB font files converter
feaacba3 276Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
277Group: Base
278
279%description mkfont
280Converts common font file formats into PF2.
281
feaacba3
JB
282%description mkfont -l pl.UTF-8
283Program do konwersji popularnych formatów plików fontów do PF2.
284
8ac8605d
JK
285%package theme-starfield
286Summary: starfield theme for GRUB
feaacba3 287Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
288Group: Base
289
290%description theme-starfield
291starfield theme for GRUB.
292
feaacba3
JB
293%description theme-starfield -l pl.UTF-8
294Motyw starfield dla GRUB-a.
295
afe8504a 296%prep
b876d99a 297%setup -q -n grub-%{version}~%{beta} -a5
b46589aa 298%patch1 -p1
872700b0 299%patch2 -p1
f951fcbe 300%patch3 -p1
aec70abd 301%patch4 -p1
f7ae30d0 302%patch5 -p1
668ecb01
JK
303%patch6 -p1
304%patch7 -p1
61d105fa 305%patch8 -p1
668ecb01 306%patch9 -p1
26996aed 307%patch10 -p1
668ecb01
JK
308%patch11 -p1
309%patch12 -p0
c287192d 310%patch13 -p1
2c79d729
JR
311%patch14 -p1
312%patch15 -p1
313%patch16 -p1
314%patch17 -p1
36121927 315%patch18 -p1
5bafb558
JK
316
317# we don't have C.utf-8 and need an UTF-8 locale for build
318sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
afe8504a
SP
319
320%build
928eb9c1 321# if gold is used then grub doesn't even boot
9bc7aab3
AM
322# https://savannah.gnu.org/bugs/?34539
323# http://sourceware.org/bugzilla/show_bug.cgi?id=14196
7a73b7a5 324install -d our-ld
70fd3248 325ln -f -s /usr/bin/ld.bfd our-ld/ld
7a73b7a5 326export PATH=$(pwd)/our-ld:$PATH
928eb9c1 327
b876d99a
JK
328## not only the typicall autotools stuff
329#./autogen.sh
330
50ffb0ba 331#{__gettextize}
b876d99a
JK
332%{__aclocal} -I m4
333%{__autoconf}
334%{__autoheader}
335%{__automake}
12fd19f5 336
1536aaf2 337for platform in %{platforms} ; do
fc490c3e
JK
338 install -d build-${platform}
339 cd build-${platform}
0e2cbb94
JK
340
341 if [ "$platform" != "efi" ] ; then
feaacba3 342 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
343 else
344 platform_opts=""
345 fi
346
55d67ca1 347 ln -f -s ../configure .
1536aaf2
JK
348 # mawk stalls at ./genmoddep.awk, so force gawk
349 AWK=gawk \
350 %configure \
351 --with-platform=${platform} \
352 --disable-werror \
353 %if %{with grubemu}
354 --enable-grub-emu-usb \
355 --enable-grub-emu-sdl \
356 --enable-grub-emu-pci \
357 %endif
0e2cbb94 358 $platform_opts \
1536aaf2
JK
359 TARGET_LDFLAGS=-static
360
ec98fb4c 361 %{__make} -j1 -C po update-gmo
1536aaf2
JK
362 %{__make}
363 cd ..
364done
0fb8b1a5 365
afe8504a
SP
366%install
367rm -rf $RPM_BUILD_ROOT
afe8504a 368
1536aaf2 369for platform in %{platforms} ; do
fc490c3e 370 cd build-${platform}
1536aaf2
JK
371 %{__make} install \
372 pkgdatadir=%{_libexecdir} \
373 pkglibdir=%{_libexecdir} \
374 DESTDIR=$RPM_BUILD_ROOT
375 cd ..
376done
afe8504a 377
7615a862
JK
378# not in Th (?)
379%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
380%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
381
f951fcbe
AM
382%find_lang grub
383
bcd6a47e
ER
384# this must be after 'make install'
385install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
386
1536aaf2
JK
387install -d $RPM_BUILD_ROOT%{_grubdir}
388cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
389
7b6caae9 390# grub.d/41_custom
1536aaf2 391cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
392%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
393
22909ca1 394install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
395cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
396
397install -d $RPM_BUILD_ROOT/etc/sysconfig
398cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
399
400# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 401rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 402
feaacba3 403# platform specific, unnecessarily always installed
50ffb0ba 404%ifnarch %{ix86} %{x8664} x32
feaacba3
JB
405%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
406%endif
407%ifnarch sparc64
408%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
409%endif
410
cbd79801 411# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
412touch $RPM_BUILD_ROOT%{_grubdir}/core.img
413touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 414
8b5c394b
ER
415# needs to be exactly 1KiB
416# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 417dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 418
afe8504a
SP
419%clean
420rm -rf $RPM_BUILD_ROOT
421
5028d8c9 422%post -p %{_sbindir}/postshell
fc58858a 423-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 424
5028d8c9 425%postun -p %{_sbindir}/postshell
fc58858a 426-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 427
8c5e5aa2
JR
428%triggerpostun -- %{name} < 2.00-2
429# Note this trigger on version upgrade needed only for upgrade from
430# old grub2 packages which contained modules in /boot/grub
431# or were built with optimizations enabled
92904505
ER
432# don't do anything on --downgrade
433if [ $1 -le 1 ]; then
434 exit 0
435fi
436echo "Grub was upgraded, trying to setup it to boot sector"
437/sbin/grub-install '(hd0)' || :
438
7b6caae9
ER
439%triggerpostun -- %{name} < 1.99-7.3
440# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
441if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
442 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
443 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
444fi
445
f951fcbe 446%files -f grub.lang
afe8504a 447%defattr(644,root,root,755)
2e4bec6f 448%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 449%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 450%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 451%attr(755,root,root) %{_sbindir}/grub-fstest
5bafb558
JK
452%attr(755,root,root) %{_sbindir}/grub-file
453%attr(755,root,root) %{_sbindir}/grub-glue-efi
e9d73181 454%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 455%attr(755,root,root) %{_sbindir}/grub-install
5bafb558 456%attr(755,root,root) %{_sbindir}/grub-macbless
e9d73181 457%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 458%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
459%attr(755,root,root) %{_sbindir}/grub-mklayout
460%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
461%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
462%attr(755,root,root) %{_sbindir}/grub-mkrelpath
463%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
464%attr(755,root,root) %{_sbindir}/grub-mkstandalone
465%attr(755,root,root) %{_sbindir}/grub-mount
466%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0 467%attr(755,root,root) %{_sbindir}/grub-reboot
5bafb558 468%attr(755,root,root) %{_sbindir}/grub-render-label
71c933c0
ER
469%attr(755,root,root) %{_sbindir}/grub-script-check
470%attr(755,root,root) %{_sbindir}/grub-set-default
5bafb558 471%attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
22909ca1 472%attr(755,root,root) %{_sbindir}/update-grub
50ffb0ba 473%ifarch %{ix86} %{x8664} x32
feaacba3
JB
474%attr(755,root,root) %{_sbindir}/grub-bios-setup
475%{_mandir}/man8/grub-bios-setup.8*
476%endif
50ffb0ba 477%ifarch %{ix86} %{x8664} x32
76be4c4a 478%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 479%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
480%else
481%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 482%{_mandir}/man8/grub-probe.8*
76be4c4a 483%endif
feaacba3
JB
484%ifarch sparc64
485%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
486%{_mandir}/man8/grub-sparc64-setup.8*
487%endif
71c933c0 488%{_mandir}/man1/grub-editenv.1*
5bafb558 489%{_mandir}/man1/grub-file.1*
3ea0c40e 490%{_mandir}/man1/grub-fstest.1*
5bafb558 491%{_mandir}/man1/grub-glue-efi.1*
7615a862 492%{_mandir}/man1/grub-kbdcomp.1*
5bafb558 493%{_mandir}/man1/grub-macbless.1*
e9d73181 494%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 495%{_mandir}/man1/grub-mklayout.1*
5bafb558 496%{_mandir}/man1/grub-mknetdir.1*
71c933c0 497%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 498%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 499%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
500%{_mandir}/man1/grub-mkstandalone.1*
501%{_mandir}/man1/grub-mount.1*
5bafb558 502%{_mandir}/man1/grub-render-label.1*
71c933c0 503%{_mandir}/man1/grub-script-check.1*
5bafb558 504%{_mandir}/man1/grub-syslinux2cfg.1*
71c933c0 505%{_mandir}/man8/grub-install.8*
fc835b5e 506%{_mandir}/man8/grub-mkconfig.8*
7615a862 507%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
508%{_mandir}/man8/grub-reboot.8*
509%{_mandir}/man8/grub-set-default.8*
22909ca1 510%{_mandir}/man8/update-grub.8*
797addca 511%if %{with grubemu}
8fcee4aa
ER
512%attr(755,root,root) %{_sbindir}/grub-emu
513%{_mandir}/man8/grub-emu.8*
797addca 514%endif
e6fbd304 515%{_libexecdir}/grub-mkconfig_lib
aec70abd 516
1536aaf2 517%dir %{_grubdir}
26e757db 518%dir %{_libexecdir}
bcd6a47e 519# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 520
bcd6a47e 521%dir %{_libexecdir}/locale
1536aaf2
JK
522%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
523%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 524
cbd79801 525# generated by grub at runtime
1536aaf2
JK
526%ghost %{_grubdir}/device.map
527%ghost %{_grubdir}/core.img
528%ghost %{_grubdir}/grubenv
cbd79801 529
e2964b87
ER
530%dir /lib/grub.d
531%doc /lib/grub.d/README
532%attr(755,root,root) /lib/grub.d/00_header
533%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 534%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 535%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 536%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 537
b876d99a
JK
538# these are now installed only on matching hosts
539#%attr(755,root,root) /lib/grub.d/10_hurd
540#%attr(755,root,root) /lib/grub.d/10_illumos
541#%attr(755,root,root) /lib/grub.d/10_kfreebsd
542#%attr(755,root,root) /lib/grub.d/10_netbsd
543#%attr(755,root,root) /lib/grub.d/10_xnu
544
50ffb0ba 545%ifarch %{ix86} %{x8664} x32
1ffaf1f6 546%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 547%{_mandir}/man8/grub-probe.8*
4a00f3b7 548%endif
aec70abd 549
f4604ef8 550%{_infodir}/grub*.info*
565fe2e3 551
8ac8605d
JK
552%dir %{_datadir}/grub/themes
553
1536aaf2 554%if %{with pc}
6d8475a4 555%files platform-pc
1536aaf2
JK
556%defattr(644,root,root,755)
557%dir %{_libexecdir}/*-pc
558%{_libexecdir}/*-pc/modinfo.sh
559%{_libexecdir}/*-pc/*.exec
560%{_libexecdir}/*-pc/*.image
561%{_libexecdir}/*-pc/*.lst
562%{_libexecdir}/*-pc/*.mod
563%{_libexecdir}/*-pc/*.module
564%{_libexecdir}/*-pc/lzma_decompress.img
565%{_libexecdir}/*-pc/config.h
566%{_libexecdir}/*-pc/gdb_grub
567%{_libexecdir}/*-pc/gmodule.pl
568%if %{with efiemu}
1536aaf2
JK
569%{_libexecdir}/*-pc/efiemu*.o
570%endif
1536aaf2 571%{_libexecdir}/*-pc/kernel.img
50ffb0ba 572%ifarch %{ix86} %{x8664} x32 sparc sparc64
1536aaf2 573%{_libexecdir}/*-pc/boot.img
5bafb558 574%{_libexecdir}/*-pc/boot_hybrid.img
1536aaf2
JK
575%{_libexecdir}/*-pc/cdboot.img
576%{_libexecdir}/*-pc/diskboot.img
577%{_libexecdir}/*-pc/lnxboot.img
578%{_libexecdir}/*-pc/pxeboot.img
579%endif
580%endif
581
582%if %{with efi}
6d8475a4 583%files platform-efi
1536aaf2
JK
584%defattr(644,root,root,755)
585%dir %{_libexecdir}/*-efi
586%{_libexecdir}/*-efi/modinfo.sh
587%{_libexecdir}/*-efi/*.exec
588%{_libexecdir}/*-efi/*.lst
589%{_libexecdir}/*-efi/*.mod
590%{_libexecdir}/*-efi/*.module
591%{_libexecdir}/*-efi/config.h
592%{_libexecdir}/*-efi/gdb_grub
593%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
594%{_libexecdir}/*-efi/kernel.img
595%endif
596
7615a862
JK
597%files mkfont
598%defattr(644,root,root,755)
7615a862 599%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 600%{_mandir}/man1/grub-mkfont.1*
7615a862 601
8ac8605d
JK
602%files theme-starfield
603%defattr(644,root,root,755)
604%{_datadir}/grub/themes/starfield
605
565fe2e3
ER
606%files -n bash-completion-%{name}
607%defattr(644,root,root,755)
608/etc/bash_completion.d/grub
This page took 0.191555 seconds and 4 git commands to generate.