]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
Dropped the target_cpu macro (not needed here)
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
659f8cfc 9# - warning: Installed (but unpackaged) file(s) found:
1536aaf2
JK
10# /sbin/grub-sparc64-setup
11# /usr/share/man/man8/grub-sparc64-setup.8.gz
12
659f8cfc
ER
13# /boot/grub/config.h
14# /etc/bash_completion.d/grub
7615a862
JK
15# /sbin/grub-sparc64-setup
16# /boot/grub/gdb_grub
17# /boot/grub/gmodule.pl
18# /sbin/grub-sparc64-setup
f97cafb4 19#
90feddde 20# Conditional build:
1536aaf2 21%bcond_with grubemu # build grub-emu debugging utility
b06c130d 22%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
23%bcond_without pc # do not build for PC BIOS platform
24%bcond_without efi # do not build for EFI platform
b06c130d
ER
25
26%if "%{cc_version}" < "3.4"
27# cc does not support:
28# cc1: sorry, unimplemented: code model `large' not supported yet
29%undefine with_efiemu
30%endif
31
2d8da575
AM
32%ifnarch %{x8664}
33# non-x86_64 arch doesn't support this
34%undefine with_efiemu
35%endif
36
1536aaf2
JK
37# the 'most natural' platform should go last
38%define platforms %{?with_efi:efi} %{?with_pc:pc}
39
afe8504a 40Summary: GRand Unified Bootloader
c8155f7f 41Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 42Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
43Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
44Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 45Name: grub2
7615a862
JK
46Version: 2.00
47Release: 0.1
2e4bec6f 48License: GPL v2
afe8504a 49Group: Base
f951fcbe 50Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 51# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
52Source1: update-grub
53Source2: update-grub.8
b46589aa 54Source3: grub.sysconfig
e2964b87 55Source4: grub-custom.cfg
695ab3a5 56URL: http://www.gnu.org/software/grub/
5028d8c9 57Patch0: pld-initrd.patch
b46589aa 58Patch1: pld-sysconfdir.patch
872700b0 59Patch2: grub-garbage.patch
c9273ffc
JK
60Patch3: grub-lvmdevice.patch
61Patch4: pld-mkconfigdir.patch
62Patch5: grub-mkconfig-diagnostics.patch
63Patch6: ppc.patch
64Patch7: %{name}-awk.patch
65Patch8: posix.patch
66Patch9: %{name}-gets.patch
26996aed 67Patch10: %{name}-fonts_path.patch
27550907
ER
68BuildRequires: autoconf >= 2.53
69BuildRequires: automake >= 1:1.11.1-1
8b781299 70BuildRequires: bison
06df59fd 71BuildRequires: device-mapper-devel
26996aed 72BuildRequires: fonts-TTF-DejaVu
013b927c 73BuildRequires: freetype-devel
12fd19f5 74BuildRequires: gawk
63e45785 75BuildRequires: gettext-devel
1349ebb8 76BuildRequires: help2man
afe8504a 77BuildRequires: libtool
81a7e0ba 78BuildRequires: texinfo
c668211a
ER
79%ifarch %{x8664}
80BuildRequires: /usr/lib/libc.so
8905dae4
ER
81%if "%{pld_release}" == "ac"
82BuildRequires: libgcc32
83%else
797addca 84BuildRequires: gcc-multilib
c668211a 85%endif
dee0d6f5 86%endif
6b675158 87BuildRequires: glibc-static
565fe2e3 88BuildRequires: ncurses-devel
8905dae4 89BuildRequires: rpm >= 4.4.9-56
403e7b01 90BuildRequires: rpmbuild(macros) >= 1.213
565fe2e3 91BuildRequires: sed >= 4.0
dc6928bc 92Requires: which
190cc685 93Suggests: cdrkit-mkisofs
97ee543c 94Suggests: os-prober
afe8504a 95Provides: bootloader
fc835b5e 96Conflicts: grub
1536aaf2
JK
97Suggests: %{name}-pc
98Suggests: %{name}-efi
58a823d7 99ExclusiveArch: %{ix86} %{x8664} ppc sparc64
afe8504a
SP
100BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102%define _sbindir /sbin
4a00f3b7 103%define _bindir %{_sbindir}
1536aaf2 104%define _libdir /lib
e6fbd304 105%define _datadir %{_libdir}
26e757db 106%define _libexecdir %{_libdir}/grub
1536aaf2 107%define _grubdir /boot/grub
9d44d75e 108
0e2cbb94
JK
109# part of grub code is not relocable (these are not Linux libs)
110# stack protector also breaks non-Linux binaries
111%define filterout_c -fPIC -fstack-protector
112
afe8504a
SP
113%description
114GRUB is a GPLed bootloader intended to unify bootloading across x86
115operating systems. In addition to loading the Linux and *BSD kernels,
116it implements the Multiboot standard, which allows for flexible
117loading of multiple boot images (needed for modular kernels such as
118the GNU Hurd).
119
211df1ed
ER
120GRUB 2 is derived from PUPA which was a research project to
121investigate the next generation of GRUB. GRUB 2 has been rewritten
122from scratch to clean up everything for modularity and portability.
123
124GRUB 2 targets at the following goals:
125- Scripting support, such as conditionals, loops, variables and
126 functions.
127- Graphical interface.
128- Dynamic loading of modules in order to extend itself at the run time
129 rather than at the build time.
130- Portability for various architectures.
131- Internationalization. This includes support for non-ASCII character
132 code, message catalogs like gettext, fonts, graphics console, and so
133 on.
134- Real memory management, to make GNU GRUB more extensible.
135- Modular, hierarchical, object-oriented framework for file systems,
136 files, devices, drives, terminals, commands, partition tables and OS
137 loaders.
138- Cross-platform installation which allows for installing GRUB from a
139 different architecture.
140- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
141- Fix design mistakes in GRUB Legacy, which could not be solved for
142 backward-compatibility, such as the way of numbering partitions.
143
6b0aefbf 144%description -l de.UTF-8
afe8504a
SP
145GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
146Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 147läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
148
149GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
150und wird unter der GPL vertrieben. Aufgrund seiner höheren
151Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
152traditionellen Boot-Loader LILO.
153
f97cafb4
ZU
154%description -l hu.UTF-8
155GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
156betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
157teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
158GNU Hurd).
159
160GRUB2 céljai a következők:
161- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
162 függvények.
163- grafikus felület
164- modulok dinamikus betöltése futási időben
165- hordozhatóság több architektúrára
166- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
167 mint gettext, betűtípusok, grafikus konzolon, és így tovább
168- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
169- moduláris, hierarchikus, objektum-orientált keretrendszer
170 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
171 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
172
6b0aefbf
JR
173%description -l es.UTF-8
174Éste es GRUB - Grand Unified Boot Loader - un administrador de
175inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 176operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 177también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
178PC.
179
180El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
181usuarios conmás experiencia y que deseen obtener más recursos de su
182cargador de inicialización (boot loader).
afe8504a 183
6b0aefbf
JR
184%description -l pl.UTF-8
185GRUB jest bootloaderem na licencji GNU, mającym na celu unifikację
186procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
187Linuksa i *BSD: posiada również implementacje standardu Multiboot,
188który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
189(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 190
6b0aefbf
JR
191%description -l pt_BR.UTF-8
192Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
193capaz de entrar na maioria dos sistemas operacionais livres - Linux,
194FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
195operacionais comerciais para PC.
196
6b0aefbf
JR
197O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
198avançados e que querem mais recursos de seu boot loader.
afe8504a 199
565fe2e3
ER
200%package -n bash-completion-%{name}
201Summary: bash-completion for GRUB
202Summary(pl.UTF-8): bashowe uzupełnianie nazw dla GRUB
203Group: Applications/Shells
204Requires: bash-completion
205
206%description -n bash-completion-%{name}
207This package provides bash-completion for GRUB.
208
209%description -n bash-completion-%{name} -l pl.UTF-8
210Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB.
211
1536aaf2
JK
212%package pc
213Summary: PC BIOS platform support for GRUB
214Group: Base
215Requires: %{name} = %{version}-%{release}
216
217%description pc
218PC BIOS platform support for GRUB.
219
220%package efi
221Summary: (U)EFI platform support for GRUB
222Group: Base
223Requires: %{name} = %{version}-%{release}
224
225%description efi
226(U)EFI platform support for GRUB.
227
7615a862
JK
228%package mkfont
229Summary: GRUB font files converter
230Group: Base
231
232%description mkfont
233Converts common font file formats into PF2.
234
afe8504a 235%prep
f951fcbe 236%setup -q -n grub-%{version}
5028d8c9 237%patch0 -p1
b46589aa 238%patch1 -p1
872700b0 239%patch2 -p1
f951fcbe 240%patch3 -p1
aec70abd 241%patch4 -p1
f7ae30d0 242%patch5 -p1
e2964b87 243%patch6 -p1
449dde54 244%patch7 -p1
61d105fa 245%patch8 -p1
4c7bb96e 246%patch9 -p1
26996aed 247%patch10 -p1
afe8504a 248
71c933c0 249%if "%{cc_version}" < "3.4"
dea0c850
ER
250grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
251%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
252%endif
253
afe8504a 254%build
928eb9c1
AM
255# if gold is used then grub doesn't even boot
256install -d our-ld
257ln -s /usr/bin/ld.bfd our-ld/ld
258export PATH=$(pwd)/our-ld:$PATH
259
3ff87e8a 260cp -f /usr/share/automake/config.sub .
afe8504a 261%{__libtoolize}
e9d73181 262%{__aclocal} -I m4
afe8504a 263%{__autoheader}
b1a4846d 264echo timestamp > stamp-h.in
afe8504a 265%{__autoconf}
53c50f89 266export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 267
1536aaf2 268for platform in %{platforms} ; do
fc490c3e
JK
269 install -d build-${platform}
270 cd build-${platform}
0e2cbb94
JK
271
272 if [ "$platform" != "efi" ] ; then
273 platform_opts="--%{!?with_efiemu:dis}%{?with_efiemu:en}able-efiemu"
274 else
275 platform_opts=""
276 fi
277
1536aaf2
JK
278 ln -s ../configure .
279 # mawk stalls at ./genmoddep.awk, so force gawk
280 AWK=gawk \
281 %configure \
282 --with-platform=${platform} \
283 --disable-werror \
284 %if %{with grubemu}
285 --enable-grub-emu-usb \
286 --enable-grub-emu-sdl \
287 --enable-grub-emu-pci \
288 %endif
0e2cbb94 289 $platform_opts \
1536aaf2
JK
290 TARGET_LDFLAGS=-static
291
292 %{__make}
293 cd ..
294done
0fb8b1a5 295
afe8504a
SP
296%install
297rm -rf $RPM_BUILD_ROOT
afe8504a 298
1536aaf2 299for platform in %{platforms} ; do
fc490c3e 300 cd build-${platform}
1536aaf2
JK
301 %{__make} install \
302 pkgdatadir=%{_libexecdir} \
303 pkglibdir=%{_libexecdir} \
304 DESTDIR=$RPM_BUILD_ROOT
305 cd ..
306done
afe8504a 307
7615a862
JK
308# not in Th (?)
309%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
310%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
311
f951fcbe
AM
312%find_lang grub
313
bcd6a47e
ER
314# this must be after 'make install'
315install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
316
1536aaf2
JK
317install -d $RPM_BUILD_ROOT%{_grubdir}
318cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
319
7b6caae9 320# grub.d/41_custom
1536aaf2 321cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
322%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
323
22909ca1 324install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
325cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
326
327install -d $RPM_BUILD_ROOT/etc/sysconfig
328cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
329
330# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 331rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 332
cbd79801 333# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
334touch $RPM_BUILD_ROOT%{_grubdir}/core.img
335touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 336
8b5c394b
ER
337# needs to be exactly 1KiB
338# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 339dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 340
afe8504a
SP
341%clean
342rm -rf $RPM_BUILD_ROOT
343
5028d8c9 344%post -p %{_sbindir}/postshell
fc58858a 345-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 346
5028d8c9 347%postun -p %{_sbindir}/postshell
fc58858a 348-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 349
92904505 350%triggerpostun -- %{name} < %{version}-0
a7bef3b9 351# Note this trigger on version upgrade
92904505
ER
352# don't do anything on --downgrade
353if [ $1 -le 1 ]; then
354 exit 0
355fi
356echo "Grub was upgraded, trying to setup it to boot sector"
357/sbin/grub-install '(hd0)' || :
358
7b6caae9
ER
359%triggerpostun -- %{name} < 1.99-7.3
360# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
361if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
362 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
363 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
364fi
365
f951fcbe 366%files -f grub.lang
afe8504a 367%defattr(644,root,root,755)
2e4bec6f 368%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 369%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
7615a862 370%attr(755,root,root) %{_sbindir}/grub-bios-setup
71c933c0 371%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 372%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 373%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 374%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 375%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 376%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
377%attr(755,root,root) %{_sbindir}/grub-mklayout
378%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
379%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
380%attr(755,root,root) %{_sbindir}/grub-mkrelpath
381%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
382%attr(755,root,root) %{_sbindir}/grub-mkstandalone
383%attr(755,root,root) %{_sbindir}/grub-mount
384%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
385%attr(755,root,root) %{_sbindir}/grub-reboot
386%attr(755,root,root) %{_sbindir}/grub-script-check
387%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 388%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a
AM
389%ifarch %{ix86} %{x8664}
390%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 391%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
392%else
393%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 394%{_mandir}/man8/grub-probe.8*
76be4c4a 395%endif
71c933c0 396%{_mandir}/man1/grub-editenv.1*
3ea0c40e 397%{_mandir}/man1/grub-fstest.1*
7615a862 398%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 399%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 400%{_mandir}/man1/grub-mklayout.1*
71c933c0 401%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 402%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 403%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
404%{_mandir}/man1/grub-mkstandalone.1*
405%{_mandir}/man1/grub-mount.1*
71c933c0 406%{_mandir}/man1/grub-script-check.1*
7615a862 407%{_mandir}/man8/grub-bios-setup.8*
71c933c0 408%{_mandir}/man8/grub-install.8*
fc835b5e 409%{_mandir}/man8/grub-mkconfig.8*
e9d73181 410%{_mandir}/man8/grub-mknetdir.8*
7615a862 411%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
412%{_mandir}/man8/grub-reboot.8*
413%{_mandir}/man8/grub-set-default.8*
22909ca1 414%{_mandir}/man8/update-grub.8*
797addca 415%if %{with grubemu}
8fcee4aa
ER
416%attr(755,root,root) %{_sbindir}/grub-emu
417%{_mandir}/man8/grub-emu.8*
797addca 418%endif
e6fbd304 419%{_libexecdir}/grub-mkconfig_lib
aec70abd 420
1536aaf2 421%dir %{_grubdir}
26e757db 422%dir %{_libexecdir}
bcd6a47e 423# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 424
bcd6a47e 425%dir %{_libexecdir}/locale
1536aaf2
JK
426%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
427%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 428
cbd79801 429# generated by grub at runtime
1536aaf2
JK
430%ghost %{_grubdir}/device.map
431%ghost %{_grubdir}/core.img
432%ghost %{_grubdir}/grubenv
cbd79801 433
e2964b87
ER
434%dir /lib/grub.d
435%doc /lib/grub.d/README
436%attr(755,root,root) /lib/grub.d/00_header
437%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 438%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 439%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 440%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 441
1e58ef6c 442%ifarch %{ix86} %{x8664}
1ffaf1f6 443%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 444%{_mandir}/man8/grub-probe.8*
4a00f3b7 445%endif
aec70abd 446
f4604ef8 447%{_infodir}/grub*.info*
565fe2e3 448
1536aaf2
JK
449%if %{with pc}
450%files pc
451%defattr(644,root,root,755)
452%dir %{_libexecdir}/*-pc
453%{_libexecdir}/*-pc/modinfo.sh
454%{_libexecdir}/*-pc/*.exec
455%{_libexecdir}/*-pc/*.image
456%{_libexecdir}/*-pc/*.lst
457%{_libexecdir}/*-pc/*.mod
458%{_libexecdir}/*-pc/*.module
459%{_libexecdir}/*-pc/lzma_decompress.img
460%{_libexecdir}/*-pc/config.h
461%{_libexecdir}/*-pc/gdb_grub
462%{_libexecdir}/*-pc/gmodule.pl
463%if %{with efiemu}
464%ifarch %{x8664}
465%{_libexecdir}/*-pc/efiemu*.o
466%endif
467%endif
468%{_libexecdir}/*-pc/kernel.img
469%ifarch %{ix86} %{x8664} sparc sparc64
470%{_libexecdir}/*-pc/boot.img
471%{_libexecdir}/*-pc/cdboot.img
472%{_libexecdir}/*-pc/diskboot.img
473%{_libexecdir}/*-pc/lnxboot.img
474%{_libexecdir}/*-pc/pxeboot.img
475%endif
476%endif
477
478%if %{with efi}
479%files efi
480%defattr(644,root,root,755)
481%dir %{_libexecdir}/*-efi
482%{_libexecdir}/*-efi/modinfo.sh
483%{_libexecdir}/*-efi/*.exec
484%{_libexecdir}/*-efi/*.lst
485%{_libexecdir}/*-efi/*.mod
486%{_libexecdir}/*-efi/*.module
487%{_libexecdir}/*-efi/config.h
488%{_libexecdir}/*-efi/gdb_grub
489%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
490%{_libexecdir}/*-efi/kernel.img
491%endif
492
7615a862
JK
493%files mkfont
494%defattr(644,root,root,755)
495%{_mandir}/man1/grub-mkfont.1*
496%attr(755,root,root) %{_sbindir}/grub-mkfont
497
565fe2e3
ER
498%files -n bash-completion-%{name}
499%defattr(644,root,root,755)
500/etc/bash_completion.d/grub
This page took 0.134037 seconds and 4 git commands to generate.