]> git.pld-linux.org Git - packages/grpc.git/commitdiff
- added x32 patch (fix wrap_memcpy with x32 ABI) auto/th/grpc-1.30.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Jul 2020 19:07:20 +0000 (21:07 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Jul 2020 19:07:20 +0000 (21:07 +0200)
- added libdir patch
- updated protobuf version (for FEATURE_PROTO3_OPTIONAL)

grpc-libdir.patch [new file with mode: 0644]
grpc-x32.patch [new file with mode: 0644]
grpc.spec

diff --git a/grpc-libdir.patch b/grpc-libdir.patch
new file mode 100644 (file)
index 0000000..b77ed27
--- /dev/null
@@ -0,0 +1,11 @@
+--- grpc-1.30.0/CMakeLists.txt.orig    2020-06-22 23:04:32.000000000 +0200
++++ grpc-1.30.0/CMakeLists.txt 2020-07-04 20:25:44.272040524 +0200
+@@ -15111,7 +15111,7 @@
+     "${output_filepath}"
+     @ONLY)
+   install(FILES "${output_filepath}"
+-    DESTINATION "lib/pkgconfig/")
++    DESTINATION "lib${LIB_SUFFIX}/pkgconfig/")
+ endfunction()
+ # gpr .pc file
diff --git a/grpc-x32.patch b/grpc-x32.patch
new file mode 100644 (file)
index 0000000..596ed24
--- /dev/null
@@ -0,0 +1,11 @@
+--- grpc-1.30.0/src/core/lib/gpr/wrap_memcpy.cc.orig   2020-06-22 23:04:32.000000000 +0200
++++ grpc-1.30.0/src/core/lib/gpr/wrap_memcpy.cc        2020-07-04 18:41:46.960053131 +0200
+@@ -28,7 +28,7 @@
+ extern "C" {
+ #ifdef __linux__
+-#if defined(__x86_64__) && !defined(GPR_MUSL_LIBC_COMPAT)
++#if defined(__x86_64__) && !defined(__ILP32__) && !defined(GPR_MUSL_LIBC_COMPAT)
+ __asm__(".symver memcpy,memcpy@GLIBC_2.2.5");
+ void* __wrap_memcpy(void* destination, const void* source, size_t num) {
+   return memcpy(destination, source, num);
index 897a95e8b6f3af415a74c0faaa7e5bcea270f497..b7c32af4ce80092c95d0627ab5e2fb89a425e79e 100644 (file)
--- a/grpc.spec
+++ b/grpc.spec
@@ -19,13 +19,15 @@ Source0:    https://github.com/grpc/grpc/archive/v%{version}/%{name}-%{version}.tar
 # Source0-md5: 316b30c89b48b8ae0ad005bb12ac566a
 Patch0:                %{name}-system-absl.patch
 Patch1:                %{name}-sphinx.patch
+Patch2:                %{name}-x32.patch
+Patch3:                %{name}-libdir.patch
 URL:           https://grpc.io/
 BuildRequires: abseil-cpp-devel
 BuildRequires: c-ares-devel >= 1.13.0
 BuildRequires: cmake >= 3.5.1
 BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: openssl-devel
-BuildRequires: protobuf-devel
+BuildRequires: protobuf-devel >= 3.12
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: zlib-devel
@@ -136,6 +138,8 @@ Dokumentacja API biblioteki Pythona gRPC.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 install -d build
This page took 0.30951 seconds and 4 git commands to generate.