]> git.pld-linux.org Git - packages/grive.git/blob - grive.spec
dca66db4e518f42df0f9bf254d906a9d6f9ac32b
[packages/grive.git] / grive.spec
1 %define         commit          27817e835fe115ebbda5410ec904aa49a2ad01f1
2 # bash: %%(c=%{commit}; echo ${c:0:7})
3 %define         shortcommit     27817e8
4 %define         cdate           20130702
5 %define         rel             28
6 Summary:        An open source Linux client for Google Drive
7 Summary(pl.UTF-8):      Linuksowy, mające otwarte źródła klient Google Drive
8 Name:           grive
9 Version:        0.3.0
10 Release:        0.%{cdate}git%{shortcommit}.%{rel}
11 License:        GPL v2
12 Group:          Applications/Networking
13 Source0:        https://github.com/Grive/grive/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
14 # Source0-md5:  4f3c3411588f889801bd5b9297e6e2c9
15 # https://github.com/Grive/grive/issues/187
16 Patch0:         json-c.patch
17 Patch1:         %{name}-bgrive_cmake_fix.patch
18 Patch2:         build.patch
19 URL:            http://www.lbreda.com/grive/
20 BuildRequires:  QtCore-devel
21 BuildRequires:  QtGui-devel
22 BuildRequires:  binutils-devel
23 BuildRequires:  boost-devel
24 BuildRequires:  cmake
25 BuildRequires:  curl-devel
26 BuildRequires:  expat-devel
27 BuildRequires:  json-c-devel >= 0.11
28 BuildRequires:  libgcrypt-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  openssl-devel
31 BuildRequires:  yajl-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The purpose of this project is to provide an independent
36 implementation of Google Drive client. It uses the Google Document
37 List API to talk to the servers in Google.
38
39 %description -l pl.UTF-8
40 Celem tego projektu jest zapewnienie niezależnej implementacji klienta
41 Google Drive. Do komunikacji z serwerami Google'a wykorzystuje API
42 Google Document List.
43
44 %package -n bgrive
45 Summary:        Qt frontend for Grive
46 Summary(pl.UTF-8):      Interfejs Qt do Grive
47 Group:          Applications/Networking
48 Requires:       %{name} = %{version}-%{release}
49
50 %description -n bgrive
51 GUI frontend for Grive.
52
53 %description -n bgrive -l pl.UTF-8
54 Graficzny interfejs użytkownika do Grive.
55
56 %prep
57 %setup -q -n %{name}-%{commit}
58 %patch0 -p1
59 %patch1 -p1
60 %patch2 -p1
61
62 %build
63 install -d build
64 cd build
65 %cmake ..
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} -C build install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README
79 %attr(755,root,root) %{_bindir}/%{name}
80 %{_mandir}/man1/%{name}.1*
81
82 %files -n bgrive
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_bindir}/bgrive
This page took 0.199095 seconds and 2 git commands to generate.