]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- use bash for tests: mksh doesn't allow to unset COLUMNS
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # PCRE support
4 %bcond_without  tests   # don't perform "make check"
5 #
6 Summary:        GNU grep Utilities
7 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
8 Summary(es.UTF-8):      Utilitarios grep GNU
9 Summary(fr.UTF-8):      Utilitaires grep de GNU
10 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
11 Summary(pl.UTF-8):      GNU grep
12 Summary(pt_BR.UTF-8):   Utilitários grep GNU
13 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
14 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
15 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
16 Name:           grep
17 Version:        2.26
18 Release:        2
19 Epoch:          2
20 License:        GPL v3+
21 Group:          Applications/Text
22 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.xz
23 # Source0-md5:  afdd61c7221434722671baf002ac9267
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
26 Patch0:         %{name}-info.patch
27 Patch1:         %{name}-pl.po-update.patch
28 Patch2:         disable-unstable-test.patch
29 URL:            http://www.gnu.org/software/grep/grep.html
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake >= 1:1.11
32 BuildRequires:  gettext-tools >= 0.18.2
33 %{?with_pcre:BuildRequires:     pcre-devel}
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  texinfo
36 BuildRequires:  xz
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _bindir         /bin
40 %define         _exec_prefix    /
41
42 %description
43 The GNU versions of commonly used grep utilities. Grep searches one or
44 more input files for lines which contain a match to a specified
45 pattern and then prints the matching lines. GNU's grep utilities
46 include grep, egrep and fgrep.
47
48 %description -l de.UTF-8
49 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
50 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
51 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
52 enthält grep, egrep und fgrep.
53
54 %description -l es.UTF-8
55 Esta es la implementación GNU del popular utilitario grep. Permite la
56 localización rápida de strings en archivos texto.
57
58 %description -l fr.UTF-8
59 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
60 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
61 les fichiers.
62
63 %description -l ja.UTF-8
64 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
65 イトパッチ(mb1.04)によって日本語対応にしたものです.
66
67 %description -l pl.UTF-8
68 GNU grep jest implementacją popularnego programu uniksowego `grep'.
69 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
70 każdy skrypt shella.
71
72 %description -l pt_BR.UTF-8
73 Esta é a implementação GNU do popular utilitário grep. Permite a
74 localização rápida de strings em arquivos texto.
75
76 %description -l ru.UTF-8
77 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
78 по образцу в текстовых файлах.
79
80 %description -l tr.UTF-8
81 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
82 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
83 kullanılır.
84
85 %description -l uk.UTF-8
86 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
87 пошуку по шаблону в текстових файлах.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94
95 %{__rm} po/stamp-po
96
97 %build
98 %{__gettextize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         %{!?with_pcre:--disable-perl-regexp} \
105         --disable-silent-rules \
106         --without-included-regex
107 %{__make}
108
109 %if %{with tests}
110 # mksh fails "unset columns" check (bash and pdksh are OK)
111 %{__make} -j1 check-expensive \
112         SHELL=/bin/bash
113 %endif
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT/etc/shrc.d
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
123 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
124
125 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
126
127 cat << EOF >$RPM_BUILD_ROOT/etc/shrc.d/grep.sh
128 #alias grep='/bin/grep --devices=skip --directories=skip --color=auto'
129 EOF
130 cat << EOF >$RPM_BUILD_ROOT/etc/shrc.d/grep.csh
131 #alias grep '/bin/grep --devices=skip --directories=skip --color=auto'
132 EOF
133
134 %find_lang %{name}
135
136 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
137 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
138 %{__rm} $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post -p /sbin/postshell
144 -/usr/sbin/fix-info-dir -c %{_infodir}
145
146 %postun -p /sbin/postshell
147 -/usr/sbin/fix-info-dir -c %{_infodir}
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc NEWS README ChangeLog TODO
152 %config(noreplace) %verify(not md5 mtime size) /etc/shrc.d/grep.*sh
153 %attr(755,root,root) %{_bindir}/egrep
154 %attr(755,root,root) %{_bindir}/fgrep
155 %attr(755,root,root) %{_bindir}/grep
156 %{_mandir}/man1/egrep.1*
157 %{_mandir}/man1/fgrep.1*
158 %{_mandir}/man1/grep.1*
159 %lang(cs) %{_mandir}/cs/man1/*
160 %lang(de) %{_mandir}/de/man1/*
161 %lang(es) %{_mandir}/es/man1/*
162 %lang(fi) %{_mandir}/fi/man1/*
163 %lang(fr) %{_mandir}/fr/man1/*
164 %lang(hu) %{_mandir}/hu/man1/*
165 %lang(it) %{_mandir}/it/man1/*
166 %lang(ja) %{_mandir}/ja/man1/*
167 %lang(nl) %{_mandir}/nl/man1/*
168 %lang(pl) %{_mandir}/pl/man1/*
169 %{_infodir}/grep.info*
This page took 0.033011 seconds and 3 git commands to generate.