]> git.pld-linux.org Git - packages/graphviz.git/commitdiff
- updated to 1.8.9 RA-1_0 STABLE graphviz-1_8_9-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 10 Aug 2002 12:46:45 +0000 (12:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- split based on supplied .spec file
- fixed tcl extensions
- libtool 1.4d compatibility patch

Changed files:
    graphviz-lt14d.patch -> 1.1
    graphviz.spec -> 1.10

graphviz-lt14d.patch [new file with mode: 0644]
graphviz.spec

diff --git a/graphviz-lt14d.patch b/graphviz-lt14d.patch
new file mode 100644 (file)
index 0000000..7c14942
--- /dev/null
@@ -0,0 +1,20 @@
+--- graphviz-1.8.9/tclstubs/Makefile.am.orig   Thu Feb 21 23:16:54 2002
++++ graphviz-1.8.9/tclstubs/Makefile.am        Sat Aug 10 01:57:27 2002
+@@ -15,6 +15,6 @@
+ # override normal libtool rule
+ tclStubLib.lo : @TCL_STUB_LIB_PATH@
+       ar -x @TCL_STUB_LIB_PATH@
+-      mv tclStubLib.o tclStubLib.lo
++      echo -e "# Generated by libtool\npic_object='tclStubLib.o'" > tclStubLib.lo
+ EXTRA_DIST = nmakefile Makefile.old
+--- graphviz-1.8.9/tkstubs/Makefile.am.orig    Thu Feb 21 23:16:54 2002
++++ graphviz-1.8.9/tkstubs/Makefile.am Sat Aug 10 10:37:49 2002
+@@ -15,5 +15,5 @@
+ # override normal libtool rule
+ tkStubLib.lo tkStubImg.lo: @TK_STUB_LIB_PATH@
+       ar -x @TK_STUB_LIB_PATH@
+-      mv tkStubLib.o tkStubLib.lo
+-      mv tkStubImg.o tkStubImg.lo
++      echo -e "# Generated by libtool\npic_object='tkStubLib.o'" > tkStubLib.lo
++      echo -e "# Generated by libtool\npic_object='tkStubImg.o'" > tkStubImg.lo
index ffc22d3f1794bda3dd594cf02c4b3277ab84a7c6..accb042bef314e4ec33f553fca87684280ca31ad 100644 (file)
@@ -1,20 +1,32 @@
+#
+# Conditional build:
+# _with_dynagraph - with dynagraph program (they say it requires gcc 3.1;
+#      it builds with 2.95.4, but doesn't seem to work - fstream problems)
+#
 Summary:       Graph Visualization Tools
 Summary(pl):   Narzêdzie do wizualizacji w postaci grafów
 Name:          graphviz
-Version:       1.8.8
+Version:       1.8.9
 Release:       1
 License:       custom (AT&T)
 Group:         X11/Applications/Graphics
 Source0:       http://www.graphviz.org/pub/graphviz/%{name}-%{version}.tar.gz
+Patch0:                %{name}-lt14d.patch
+# must wait
+#Patch1:       %{name}-system-gd.patch
 URL:           http://www.graphviz.org/
 BuildRequires: XFree86-devel
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: bison
 BuildRequires: flex
 BuildRequires: freetype-devel >= 2.0.0
 BuildRequires: gawk
+#BuildRequires:        gd-devel(gif) >= 2.0.1
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
 BuildRequires: tcl-devel >= 8.3.0
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -30,8 +42,50 @@ of graphs (as in nodes and edges, not as in barcharts).
 Kolekcja narzêdzi oraz pakietów tcl s³u¿±cych do manipulacji i
 rozmieszczania grafów.
 
+%package graphs
+Summary:       Demo graphs for graphviz
+Summary(pl):   Przyk³adowe grafy dla graphviza
+Group:         X11/Applications/Graphics
+Requires:      %{name} = %{version}
+
+%description graphs
+This package provides some example graphs.
+
+%description graphs -l pl
+Ten pakiet zawiera trochê przyk³adowych grafów.
+
+%package tcl
+Summary:       Tcl extension tools for graphviz
+Summary(pl):   Rozszerzenia Tcl dla graphviza
+Group:         X11/Applications/Graphics
+Requires:      %{name} = %{version}
+
+%description tcl
+This package contains the various tcl packages (extensions) using
+graphviz.
+
+%description tcl -l pl
+Ten pakiet zawiera ró¿ne pakiety (rozszerzenia) tcl u¿ywaj±ce
+graphviza.
+
+%package devel
+Summary:       Header files for graphviz libraries
+Summary(pl):   Pliki nag³ówkowe do bibliotek graphviz
+Group:         X11/Development/Libraries
+Requires:      %{name} = %{version}
+
+%description devel
+This package contains the header files for graphviz libraries.
+
+%description devel -l pl
+Ten pakiet zawiera pliki nag³ówkowe do bibliotek graphviz.
 %prep
 %setup -q
+if grep -q '^VERSION=1\.4d$' /usr/bin/libtool ; then
+%patch0 -p1
+fi
+# requires gd with GIF support - must wait for patched gd...
+#%patch1 -p1
 
 %build
 rm -f missing
@@ -39,7 +93,9 @@ rm -f missing
 aclocal
 %{__autoconf}
 %{__automake}
-%configure 
+%configure \
+       %{?_with_dynagraph:--with-dynagraph}
+
 %{__make}
 
 %install
@@ -48,6 +104,11 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# tcl doesn't find pkgIndex.tcl outside /usr/lib...
+install -d $RPM_BUILD_ROOT/usr/lib/graphviz
+sed -e "s@\$dir @%{_libdir}/graphviz/@" $RPM_BUILD_ROOT%{_libdir}/graphviz/pkgIndex.tcl \
+       > $RPM_BUILD_ROOT/usr/lib/graphviz/pkgIndex.tcl
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -56,12 +117,37 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%doc AUTHORS COPYING ChangeLog FAQ.txt NEWS doc/*.pdf
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/%{name}/lib*.so.*.*
-%{_libdir}/%{name}/pkgIndex.tcl
-%attr(755,root,root) %{_datadir}/%{name}/*
-%doc AUTHORS COPYING ChangeLog FAQ.txt NEWS
-
+%dir %{_libdir}/graphviz
+# *.so links are needed here for tcl
+%attr(755,root,root) %{_libdir}/graphviz/lib*.so*
+%dir %{_datadir}/graphviz
+%{_datadir}/graphviz/lefty
 %{_mandir}/man1/*
-%{_mandir}/man3/*
+
+%files graphs
+%defattr(644,root,root,755)
+%{_datadir}/graphviz/graphs
+
+%files tcl
+%defattr(644,root,root,755)
+%dir /usr/lib/graphviz
+/usr/lib/graphviz/pkgIndex.tcl
 %{_mandir}/mann/*
+%dir %{_datadir}/graphviz/demo
+%{_datadir}/graphviz/demo/pathplan_data
+%{_datadir}/graphviz/demo/*.*
+%attr(755,root,root) %{_datadir}/graphviz/demo/dge
+%attr(755,root,root) %{_datadir}/graphviz/demo/doted
+%attr(755,root,root) %{_datadir}/graphviz/demo/entities
+%attr(755,root,root) %{_datadir}/graphviz/demo/gcat
+%attr(755,root,root) %{_datadir}/graphviz/demo/ihi
+%attr(755,root,root) %{_datadir}/graphviz/demo/pathplan
+%attr(755,root,root) %{_datadir}/graphviz/demo/spline
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/graphviz/lib*.la
+%{_includedir}/graphviz
+%{_mandir}/man3/*
This page took 0.054153 seconds and 4 git commands to generate.