]> git.pld-linux.org Git - packages/graphene.git/blob - graphene.spec
- new
[packages/graphene.git] / graphene.spec
1 # NOTE: despite some comments in configure, SSE2 is not selected at runtime;
2 # SSE2 option seems to change the ABI of library
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # static library
6 %bcond_with     introspection   # gobject introspection
7 %bcond_with     sse2            # x86 SSE2 fast paths
8 %bcond_without  armneon         # ARM NEON fast paths
9 #
10 %ifarch pentium4 %{x8664}
11 %define with_sse2
12 %endif
13 Summary:        Graphene - a thin layer of types for graphic libraries
14 Summary(pl.UTF-8):      Graphene - cienka warstwa typów dla bibliotek graficznych
15 Name:           graphene
16 Version:        0.99.2
17 Release:        1
18 License:        MIT
19 Group:          Libraries
20 Source0:        https://github.com/ebassi/graphene/archive/%{version}/%{name}-%{version}.tar.gz
21 # Source0-md5:  ccd4e4d991fb41ff163b1e27cfc41ea2
22 Patch0:         %{name}-bench.patch
23 Patch1:         %{name}-gcc.patch
24 URL:            https://github.com/ebassi/graphene
25 BuildRequires:  glib2-devel >= 1:2.40.0
26 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.41.0}
27 BuildRequires:  gtk-doc >= 1.20
28 BuildRequires:  autoconf >= 2.63
29 BuildRequires:  automake >= 1:1.11
30 BuildRequires:  libtool >= 2:2.2.6
31 BuildRequires:  pkgconfig
32 Requires:       glib2 >= 1:2.40.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Graphene provides a small set of mathematical types needed to
37 implement graphic libraries that deal with 2D and 3D transformations
38 and projections.
39
40 %description -l pl.UTF-8
41 Graphene udostępnia mały zestaw typów matematycznych potrzebnych przy
42 implementowaniu bibliotek graficznych wykonujących przekształcenia i
43 rzuty 2D oraz 3D.
44
45 %package devel
46 Summary:        Header files for Graphene library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Graphene
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       glib2-devel >= 1:2.40.0
51
52 %description devel
53 Header files for Graphene library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki Graphene.
57
58 %package static
59 Summary:        Static Graphene library
60 Summary(pl.UTF-8):      Statyczna biblioteka Graphene
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static Graphene library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka Graphene.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74
75 %build
76 %{__gtkdocize}
77 %{__libtoolize}
78 %{__aclocal} -I build/autotools
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         %{!?with_armneon:--disable-arm-neon} \
84         --disable-silent-rules \
85         %{!?with_sse2:--disable-sse2} \
86         %{?with_static_libs:--enable-static}
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # obsoleted by pkg-config
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgraphene-1.0.la
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc LICENSE README.md
107 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libgraphene-1.0.so.0
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so
113 %{_includedir}/graphene-1.0
114 %{_pkgconfigdir}/graphene-1.0.pc
115 %{_pkgconfigdir}/graphene-gobject-1.0.pc
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libgraphene-1.0.a
121 %endif
This page took 0.077795 seconds and 3 git commands to generate.