]> git.pld-linux.org Git - packages/graphene.git/blob - graphene.spec
e48ea2f9eb037a4adc0b02405c18717e2ef49b6a
[packages/graphene.git] / graphene.spec
1 # NOTE: despite some comments in configure, SSE2 is not selected at runtime;
2 # SSE2 option seems to change the ABI of library
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # gobject introspection
7 %bcond_with     sse2            # x86 SSE2 fast paths
8 %bcond_without  armneon         # ARM NEON fast paths
9
10 %ifarch pentium4 %{x8664}
11 %define with_sse2       1
12 %endif
13 Summary:        Graphene - a thin layer of types for graphic libraries
14 Summary(pl.UTF-8):      Graphene - cienka warstwa typów dla bibliotek graficznych
15 Name:           graphene
16 Version:        1.10.0
17 Release:        1
18 License:        MIT
19 Group:          Libraries
20 Source0:        http://ftp.gnome.org/pub/GNOME/sources/graphene/1.10/%{name}-%{version}.tar.xz
21 # Source0-md5:  07f72436bc7a85d12f5edd9fcedd0184
22 Patch0:         %{name}-gir.patch
23 URL:            https://github.com/ebassi/graphene
24 %if %{with sse2} || %{with armneon}
25 BuildRequires:  gcc >= 6:4.9
26 %else
27 BuildRequires:  gcc >= 5:3.2
28 %endif
29 BuildRequires:  glib2-devel >= 1:2.40.0
30 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.41.0}
31 BuildRequires:  gtk-doc >= 1.20
32 BuildRequires:  meson >= 0.50.1
33 BuildRequires:  ninja >= 1.5
34 BuildRequires:  pkgconfig
35 %{?with_introspection:BuildRequires:    python3 >= 1:3}
36 BuildRequires:  rpmbuild(macros) >= 1.736
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 Requires:       glib2 >= 1:2.40.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Graphene provides a small set of mathematical types needed to
44 implement graphic libraries that deal with 2D and 3D transformations
45 and projections.
46
47 %description -l pl.UTF-8
48 Graphene udostępnia mały zestaw typów matematycznych potrzebnych przy
49 implementowaniu bibliotek graficznych wykonujących przekształcenia i
50 rzuty 2D oraz 3D.
51
52 %package devel
53 Summary:        Header files for Graphene library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Graphene
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       glib2-devel >= 1:2.40.0
58
59 %description devel
60 Header files for Graphene library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki Graphene.
64
65 %package static
66 Summary:        Static Graphene library
67 Summary(pl.UTF-8):      Statyczna biblioteka Graphene
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static Graphene library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka Graphene.
76
77 %package apidocs
78 Summary:        API documentation for Graphene library
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki Graphene
80 Group:          Documentation
81 %if "%{_rpmversion}" >= "5"
82 BuildArch:      noarch
83 %endif
84
85 %description apidocs
86 API documentation for Graphene library.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki Graphene.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 %meson build \
97         %{!?with_armneon:-Darm_neon=false} \
98         -Dgtk_doc=true \
99         %{!?with_introspection:-Dintrospection=false} \
100         %{!?with_sse2:-Dsse2=false} \
101         -Dtests=false
102
103 %meson_build -C build
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %meson_install -C build
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc LICENSE.txt README.md
119 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libgraphene-1.0.so.0
121 %if %{with introspection}
122 %{_libdir}/girepository-1.0/Graphene-1.0.typelib
123 %endif
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so
128 %{_includedir}/graphene-1.0
129 %dir %{_libdir}/graphene-1.0
130 %{_libdir}/graphene-1.0/include
131 %if %{with introspection}
132 %{_datadir}/gir-1.0/Graphene-1.0.gir
133 %endif
134 %{_pkgconfigdir}/graphene-1.0.pc
135 %{_pkgconfigdir}/graphene-gobject-1.0.pc
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libgraphene-1.0.a
141 %endif
142
143 %files apidocs
144 %defattr(644,root,root,755)
145 %{_gtkdocdir}/graphene
This page took 0.194314 seconds and 2 git commands to generate.