]> git.pld-linux.org Git - packages/graphene.git/blob - graphene.spec
1291ca48da60f522684d0fad492b594431754dd6
[packages/graphene.git] / graphene.spec
1 # NOTE: despite some comments in configure, SSE2 is not selected at runtime;
2 # SSE2 option seems to change the ABI of library
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # gobject introspection
7 %bcond_with     sse2            # x86 SSE2 fast paths
8 %bcond_without  armneon         # ARM NEON fast paths
9
10 %ifarch pentium4 %{x8664}
11 %define with_sse2       1
12 %endif
13 Summary:        Graphene - a thin layer of types for graphic libraries
14 Summary(pl.UTF-8):      Graphene - cienka warstwa typów dla bibliotek graficznych
15 Name:           graphene
16 Version:        1.10.6
17 Release:        1
18 License:        MIT
19 Group:          Libraries
20 Source0:        https://download.gnome.org/sources/graphene/1.10/%{name}-%{version}.tar.xz
21 # Source0-md5:  390139e704772b915ff2b7cac56c24ae
22 URL:            https://github.com/ebassi/graphene
23 %if %{with sse2} || %{with armneon}
24 BuildRequires:  gcc >= 6:4.9
25 %else
26 BuildRequires:  gcc >= 5:3.2
27 %endif
28 BuildRequires:  glib2-devel >= 1:2.40.0
29 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.41.0}
30 BuildRequires:  gtk-doc >= 1.20
31 BuildRequires:  meson >= 0.50.1
32 BuildRequires:  ninja >= 1.5
33 BuildRequires:  pkgconfig
34 BuildRequires:  python3 >= 1:3
35 BuildRequires:  rpm-build >= 4.6
36 BuildRequires:  rpmbuild(macros) >= 1.736
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 Requires:       glib2 >= 1:2.40.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Graphene provides a small set of mathematical types needed to
44 implement graphic libraries that deal with 2D and 3D transformations
45 and projections.
46
47 %description -l pl.UTF-8
48 Graphene udostępnia mały zestaw typów matematycznych potrzebnych przy
49 implementowaniu bibliotek graficznych wykonujących przekształcenia i
50 rzuty 2D oraz 3D.
51
52 %package devel
53 Summary:        Header files for Graphene library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Graphene
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       glib2-devel >= 1:2.40.0
58
59 %description devel
60 Header files for Graphene library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki Graphene.
64
65 %package static
66 Summary:        Static Graphene library
67 Summary(pl.UTF-8):      Statyczna biblioteka Graphene
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static Graphene library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka Graphene.
76
77 %package apidocs
78 Summary:        API documentation for Graphene library
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki Graphene
80 Group:          Documentation
81 BuildArch:      noarch
82
83 %description apidocs
84 API documentation for Graphene library.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki Graphene.
88
89 %prep
90 %setup -q
91
92 %build
93 %meson build \
94         %{!?with_armneon:-Darm_neon=false} \
95         -Dgtk_doc=true \
96         %{!?with_introspection:-Dintrospection=false} \
97         %{!?with_sse2:-Dsse2=false} \
98         -Dtests=false
99
100 %meson_build -C build
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %meson_install -C build
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc LICENSE.txt README.md
116 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libgraphene-1.0.so.0
118 %if %{with introspection}
119 %{_libdir}/girepository-1.0/Graphene-1.0.typelib
120 %endif
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so
125 %{_includedir}/graphene-1.0
126 %dir %{_libdir}/graphene-1.0
127 %{_libdir}/graphene-1.0/include
128 %if %{with introspection}
129 %{_datadir}/gir-1.0/Graphene-1.0.gir
130 %endif
131 %{_pkgconfigdir}/graphene-1.0.pc
132 %{_pkgconfigdir}/graphene-gobject-1.0.pc
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libgraphene-1.0.a
138 %endif
139
140 %files apidocs
141 %defattr(644,root,root,755)
142 %{_gtkdocdir}/graphene
This page took 0.07579 seconds and 2 git commands to generate.