]> git.pld-linux.org Git - packages/graphene.git/blob - graphene.spec
04c364f167f4c4e533039ff84d4ecebb9b0a8cb0
[packages/graphene.git] / graphene.spec
1 # NOTE: despite some comments in configure, SSE2 is not selected at runtime;
2 # SSE2 option seems to change the ABI of library
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # gobject introspection
7 %bcond_with     sse2            # x86 SSE2 fast paths
8 %bcond_without  armneon         # ARM NEON fast paths
9
10 %ifarch pentium4 %{x8664}
11 %define with_sse2       1
12 %endif
13 Summary:        Graphene - a thin layer of types for graphic libraries
14 Summary(pl.UTF-8):      Graphene - cienka warstwa typów dla bibliotek graficznych
15 Name:           graphene
16 Version:        1.2.10
17 Release:        2
18 License:        MIT
19 Group:          Libraries
20 Source0:        http://ftp.gnome.org/pub/GNOME/sources/graphene/1.2/%{name}-%{version}.tar.xz
21 # Source0-md5:  07b2a7b84e993370fc8915a92a34d7e6
22 Patch0:         %{name}-gcc.patch
23 URL:            https://github.com/ebassi/graphene
24 BuildRequires:  autoconf >= 2.63
25 BuildRequires:  automake >= 1:1.11
26 BuildRequires:  glib2-devel >= 1:2.40.0
27 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.41.0}
28 BuildRequires:  gtk-doc >= 1.20
29 BuildRequires:  libtool >= 2:2.2.6
30 BuildRequires:  pkgconfig
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires:       glib2 >= 1:2.40.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Graphene provides a small set of mathematical types needed to
38 implement graphic libraries that deal with 2D and 3D transformations
39 and projections.
40
41 %description -l pl.UTF-8
42 Graphene udostępnia mały zestaw typów matematycznych potrzebnych przy
43 implementowaniu bibliotek graficznych wykonujących przekształcenia i
44 rzuty 2D oraz 3D.
45
46 %package devel
47 Summary:        Header files for Graphene library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Graphene
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       glib2-devel >= 1:2.40.0
52
53 %description devel
54 Header files for Graphene library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki Graphene.
58
59 %package static
60 Summary:        Static Graphene library
61 Summary(pl.UTF-8):      Statyczna biblioteka Graphene
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static Graphene library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka Graphene.
70
71 %package apidocs
72 Summary:        API documentation for Graphene library
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki Graphene
74 Group:          Documentation
75 %if "%{_rpmversion}" >= "5"
76 BuildArch:      noarch
77 %endif
78
79 %description apidocs
80 API documentation for Graphene library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki Graphene.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %{__gtkdocize}
91 %{__libtoolize}
92 %{__aclocal} -I build/autotools
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         %{!?with_armneon:--disable-arm-neon} \
98         %{!?with_introspection:--disable-introspection} \
99         --disable-silent-rules \
100         %{!?with_sse2:--disable-sse2} \
101         %{?with_static_libs:--enable-static} \
102         --with-html-dir=%{_gtkdocdir}
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 # obsoleted by pkg-config
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgraphene-1.0.la
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc ChangeLog
123 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libgraphene-1.0.so.0
125 %if %{with introspection}
126 %{_libdir}/girepository-1.0/Graphene-1.0.typelib
127 %endif
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so
132 %{_includedir}/graphene-1.0
133 %dir %{_libdir}/graphene-1.0
134 %{_libdir}/graphene-1.0/include
135 %if %{with introspection}
136 %{_datadir}/gir-1.0/Graphene-1.0.gir
137 %endif
138 %{_pkgconfigdir}/graphene-1.0.pc
139 %{_pkgconfigdir}/graphene-gobject-1.0.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libgraphene-1.0.a
145 %endif
146
147 %files apidocs
148 %defattr(644,root,root,755)
149 %{_gtkdocdir}/graphene
This page took 0.055205 seconds and 2 git commands to generate.