]> git.pld-linux.org Git - packages/grace.git/blob - grace.spec
- more %%{__make} macros.
[packages/grace.git] / grace.spec
1 Summary:        Numerical Data Processing and Visualization Tool (grace)
2 Name:           grace
3 Version:        5.1.0
4 Release:        1
5 License:        GPL
6 Group:          Applications/Math
7 Group(pl):      Aplikacje/Matematyczne
8 Source0:        ftp://plasma-gate.weizmann.ac.il/pub/grace/src/%{name}-%{version}.tar.gz
9 Source1:        xmgrace
10 Source2:        fftw.tar.gz
11 Patch0:         %{name}.perl.patch
12 Icon:           %{name}.gif
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Grace is a Motif application for two-dimensional data visualization.
17 Grace can transform the data using free equations, FFT, cross- and
18 auto-correlation, differences, integrals, histograms, and much more.
19 The generated figures are of high quality. Grace is a very convenient
20 tool for data inspection, data transformation, and and for making
21 figures for publications.
22
23 %description -l pl
24 Grace jest Motiffow± aplikacj± s³u¿±c± do dwuwymiarowej wizualizacji
25 danych. Mo¿e przejszta³caæ dane za pomoc± wolnych równañ, FFT,
26 autokorelacji, ró¿niczek, ca³ek, histogramów itd. Powsta³e wykresy
27 maj± wysok± jako¶æ. Grace jest bardzo u¿ytecznym narzêdziem je¶li
28 chodzi o monitorowanie i transformacjê danych oraz tworzenie wykresów
29 do publikacji.
30
31 %package dynamic
32 Group:          Applications/Math
33 Group(pl):      Aplikacje/Matematyczne
34 Summary:        Numerical Data Processing and Visualization Tool (grace)
35 Provides:       %{name}
36 Conflicts:      %{name}-semistatic
37
38 %description dynamic
39 Grace is a Motif application for two-dimensional data visualization.
40 Grace can transform the data using free equations, FFT, cross- and
41 auto-correlation, differences, integrals, histograms, and much more.
42 The generated figures are of high quality. Grace is a very convenient
43 tool for data inspection, data transformation, and and for making
44 figures for publications.
45
46 %package semistatic
47 Group:          Applications/Math
48 Group(pl):      Aplikacje/Matematyczne
49 Summary:        grace with statically linked Motif libraries
50 Provides:       %{name}
51 Conflicts:      %{name}-dynamic
52
53 %description semistatic
54 Grace is a Motif application for two-dimensional data visualization.
55 Grace can transform the data using free equations, FFT, cross- and
56 auto-correlation, differences, integrals, histograms, and much more.
57 The generated figures are of high quality. Grace is a very convenient
58 tool for data inspection, data transformation, and and for making
59 figures for publications.
60
61 In this package the Motif libraries are linked statically for users
62 who have no Motif runtime libraries.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 tar -xzf $RPM_SOURCE_DIR/fftw.tar.gz
68
69 %build
70 %configure
71
72 %{__make}
73
74 cd ..
75 rm -rf gd1.3 fftw-1.3
76 ./configure --prefix=/usr/X11R6 --enable-grace-home=/usr/X11R6/lib/X11/grace \
77         --enable-editres \
78         --enable-extra-incpath=$PKG_BUILD_DIR/include \
79         --enable-extra-ldpath=$PKG_BUILD_DIR/lib --enable-debug
80 %{__make}
81 cd src
82 rm xmgrace
83 `make -n xmgrace | grep '^gcc' | head -1 | \
84  sed -e 's/\([ \t]\|^\)-lnetcdf\b/\1-Wl,-Bstatic,-lnetcdf,-Bdynamic/g'`
85 mv xmgrace xmgrace.dynamic
86 `make -n xmgrace | grep '^gcc' | head -1 | \
87  sed -e 's/\([ \t]\|^\)-lXm\b/\1-Wl,-Bstatic,-lXm,-Bdynamic/g' \
88      -e 's/\([ \t]\|^\)-lXbae\b/\1-Wl,-Bstatic,-lXbae,-Bdynamic/g' \
89      -e 's/\([ \t]\|^\)-lnetcdf\b/\1-Wl,-Bstatic,-lnetcdf,-Bdynamic/g'`
90 cd ..
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 install -d $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
96 %{__make} PREFIX=$RPM_BUILD_ROOT%{_prefix}/X11R6 \
97 GRACE_HOME=$RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/grace \
98      install
99 strip $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/grace/bin/xmgrace
100 mv $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/grace/bin/xmgrace \
101 $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/grace/bin/xmgrace.semistatic
102 strip $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/grace/bin/grconvert
103 install -s src/xmgrace.dynamic $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/grace/bin
104 rm -f $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/xmgrace
105 rm -f $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/gracebat
106 install -m755 $RPM_SOURCE_DIR/xmgrace $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/xmgrace
107 ln -sf %{_prefix}/X11R6/bin/xmgrace $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/gracebat
108 install -d $RPM_BUILD_ROOT%{_includedir}
109 ln -sf %{_prefix}/X11R6/lib/X11/grace/include/grace_np.h \
110     $RPM_BUILD_ROOT%{_includedir}/grace_np.h
111 install -d $RPM_BUILD_ROOT%{_libdir}
112 ln -sf %{_prefix}/X11R6/lib/X11/grace/lib/libgrace_np.a \
113     $RPM_BUILD_ROOT%{_libdir}/libgrace_np.a
114
115 cd $RPM_BUILD_ROOT
116 find .%{_prefix}/X11R6/lib/X11/grace -type d \
117         | sed 's,^\.,\%attr(-\,root\,root) \%dir ,' \
118         > $RPM_BUILD_DIR/file.list.%{name}
119 find . -type f \
120         | egrep -v 'xmgrace\.(dynamic|semistatic)' \
121         | sed 's,^\.,\%attr(-\,root\,root) ,' \
122         >> $RPM_BUILD_DIR/file.list.%{name}
123 find . -type l \
124         | sed 's,^\.,\%attr(-\,root\,root) ,' \
125         >> $RPM_BUILD_DIR/file.list.%{name}
126
127 %clean
128 if [ "x$RPM_BUILD_ROOT" != "x/" ]; then
129     rm -rf $RPM_BUILD_ROOT
130 fi
131 rm -f $RPM_BUILD_DIR/file.list.%{name}
132
133 %files dynamic -f ../file.list.%{name}
134 %defattr(644,root,root,755)
135 %{_prefix}/X11R6/lib/X11/grace/bin/xmgrace.dynamic
136
137 %files semistatic -f ../file.list.%{name}
138 %defattr(644,root,root,755)
139 %{_prefix}/X11R6/lib/X11/grace/bin/xmgrace.semistatic
This page took 0.615309 seconds and 4 git commands to generate.