]> git.pld-linux.org Git - packages/golang.git/commitdiff
set arm target options more specifically
authorJan Palus <atler@pld-linux.org>
Mon, 27 Dec 2021 23:00:28 +0000 (00:00 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 27 Dec 2021 23:00:28 +0000 (00:00 +0100)
golang.spec

index cee45a07d28d02fceb2422c23d60a646ef33ac1c..9cb0924bbc7fad92f333469fd67948d5520eee46 100644 (file)
@@ -49,11 +49,12 @@ BuildRequires:      golang >= 1.4
 BuildRequires: glibc-static
 BuildRequires: hostname
 BuildRequires: pcre-devel
+BuildRequires: rpmbuild(macros) >= 2.007
 BuildRequires: tzdata
 %endif
 Requires:      ca-certificates
 Conflicts:     gcc-go
-ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
+ExclusiveArch: %{ix86} %{x8664} %{armv5} %{armv6} %{armv7} aarch64 mips64 mips64le ppc64 ppc64le s390x
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
@@ -69,8 +70,17 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %ifarch %{x8664}
 %define        GOARCH amd64
 %endif
-%ifarch %{arm}
+%ifarch %{armv5}
 %define        GOARCH arm
+%define        GOARM 5
+%endif
+%ifarch %{armv6}
+%define        GOARCH arm
+%define        GOARM 6
+%endif
+%ifarch %{armv7}
+%define        GOARCH arm
+%define        GOARM 7
 %endif
 %ifarch aarch64
 %define        GOARCH arm64
@@ -145,6 +155,7 @@ export GOHOSTARCH=%{GOARCH}
 
 export GOOS=linux
 export GOARCH=%{GOARCH}
+%{?GOARM:export GOARM=%{GOARM}}
 %if %{without external_linker}
 export GO_LDFLAGS="-linkmode internal"
 %endif
This page took 0.389691 seconds and 4 git commands to generate.