]> git.pld-linux.org Git - packages/golang.git/commitdiff
up to 1.16.3 auto/th/golang-1.16.3-1
authorJan Palus <atler@pld-linux.org>
Mon, 5 Apr 2021 16:54:23 +0000 (18:54 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 5 Apr 2021 16:54:23 +0000 (18:54 +0200)
ca-certs.patch
golang.spec

index 78ddd54ecc68547d81f74b67133375c6968a4729..6a723ba8f86dba5dba2f121b36a5cb7369f97e6d 100644 (file)
@@ -1,10 +1,10 @@
---- golang-1.6/src/crypto/x509/root_unix.go~   2016-02-17 22:35:21.000000000 +0200
-+++ golang-1.6/src/crypto/x509/root_unix.go    2016-04-05 13:04:44.231441583 +0300
+--- golang-1.6/src/crypto/x509/root_linux.go~  2016-02-17 22:35:21.000000000 +0200
++++ golang-1.6/src/crypto/x509/root_linux.go   2016-04-05 13:04:44.231441583 +0300
 @@ -11,6 +11,7 @@
  // Possible directories with certificate files; stop after successfully
  // reading at least one file from a directory.
  var certDirectories = []string{
 +      "/etc/openssl/certs",           // PLD Linux
        "/etc/ssl/certs",               // SLES10/SLES11, https://golang.org/issue/12139
+       "/etc/pki/tls/certs",           // Fedora/RHEL
        "/system/etc/security/cacerts", // Android
- }
index 23c9055519b1478e95f17c1eeda13d9bd70339af..0b56800f7e83adb1f714efeac7f74a36f1bdeb71 100644 (file)
 Summary:       Go compiler and tools
 Summary(pl.UTF-8):     Kompilator języka Go i narzędzia
 Name:          golang
-Version:       1.14.9
+Version:       1.16.3
 Release:       1
 # source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
 License:       BSD and Public Domain
 Group:         Development/Languages
 # Source0Download: https://golang.org/dl/
 Source0:       https://storage.googleapis.com/golang/go%{version}.src.tar.gz
-# Source0-md5: 6f6dd1377421d27ca4bb607283b31738
+# Source0-md5: 48183a40d6522f1ea59b7d63377b7072
 Patch0:                ca-certs.patch
 Patch1:                0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
 URL:           https://golang.org/
@@ -163,6 +163,10 @@ export CC="${CC#ccache }"
 export CC_FOR_TARGET="$CC"
 EOF
 
+grep -rl '#!.*env bash' . | xargs %{__sed} -i -e '1{
+       s,^#!.*bin/env bash,#!%{__bash},
+}'
+
 %if 0
 # optflags for go tools build
 nflags="\"$(echo '%{rpmcflags}' | sed -e 's/^[         ]*//;s/[        ]*$//;s/[       ]\+/ /g' -e 's/ /\",\"/g')\""
@@ -207,7 +211,7 @@ ln -sf %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/cgo $RPM_BUILD_ROOT%{_bindir}
 # FIXME: do we need whole sources, including build scripts?
 # for now, remove only non-Linux stuff
 %{__rm} \
-       $RPM_BUILD_ROOT%{_libdir}/%{name}/src/syscall/{mksyscall,mksysctl_openbsd,mksysnum_{darwin,dragonfly,freebsd,netbsd,openbsd}}.pl
+       $RPM_BUILD_ROOT%{_libdir}/%{name}/src/syscall/{mksyscall,mksysctl_openbsd,mksysnum_{dragonfly,freebsd,netbsd,openbsd}}.pl
 # ...and tests
 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/src/internal/trace \
           $RPM_BUILD_ROOT%{_libdir}/%{name}/misc/cgo/{errors,fortran,test*}
This page took 0.945299 seconds and 4 git commands to generate.