]> git.pld-linux.org Git - packages/gnuradio.git/blob - gnuradio.spec
37bbdb7238b82ae3ac5749d276fbf75a4767d0cb
[packages/gnuradio.git] / gnuradio.spec
1 # TODO:
2 # - fix volk, drop bcond and enable by default
3 # - fix uhd build
4 %bcond_with     uhd
5 %bcond_with     volk
6 #
7 %define snap    2012-03-26
8 %define snaps   %(echo %{snap} | tr -d "-")
9 Summary:        Software defined radio framework
10 Name:           gnuradio
11 Version:        3.5.3
12 Release:        0.%{snaps}.0.1
13 License:        GPL v3
14 Group:          Applications/Engineering
15 URL:            http://www.gnuradio.org
16 Source0:        http://gnuradio.org/files/builds/%{name}-%{version}-%{snap}.tar.gz
17 # Source0-md5:  597245618a773bad2ff6b973e83d5bcb
18 BuildRequires:  SDL-devel
19 BuildRequires:  alsa-lib-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  boost-devel >= 1.35
23 BuildRequires:  cppunit-devel
24 BuildRequires:  doxygen
25 BuildRequires:  fftw3-devel
26 BuildRequires:  graphviz
27 BuildRequires:  gsl-devel
28 BuildRequires:  guile-devel
29 BuildRequires:  libtool
30 BuildRequires:  libtool
31 BuildRequires:  libusb-devel
32 BuildRequires:  orc-devel
33 BuildRequires:  portaudio-devel
34 BuildRequires:  python-PyQt4-devel
35 BuildRequires:  python-PyQwt-devel
36 BuildRequires:  python-cheetah
37 BuildRequires:  python-devel
38 BuildRequires:  python-lxml
39 BuildRequires:  python-numpy
40 BuildRequires:  python-pygtk-devel
41 BuildRequires:  python-wxPython-devel
42 BuildRequires:  qwt-devel
43 BuildRequires:  sdcc
44 BuildRequires:  swig
45 BuildRequires:  texlive-latex
46 %{?with_uhd:BuildRequires:      uhd-devel}
47 BuildRequires:  xdg-utils
48 BuildRequires:  xmlto
49 Requires:       PyQt4
50 Requires:       portaudio
51 Requires:       python-cheetah
52 Requires:       python-lxml
53 Requires:       python-numpy
54 Requires:       python-pygtk-gtk
55 Requires:       python-wxPython
56 Requires:       scipy
57 Obsoletes:      grc < 0.80-1
58 Obsoletes:      usrp < 3.3.0-1
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 GNU Radio is a collection of software that when combined with minimal
63 hardware, allows the construction of radios where the actual waveforms
64 transmitted and received are defined by software. What this means is
65 that it turns the digital modulation schemes used in today's high
66 performance wireless devices into software problems.
67
68 %package devel
69 Summary:        GNU Radio
70 Group:          Applications/Engineering
71 Requires:       %{name} = %{version}-%{release}
72 Obsoletes:      usrp-devel < 3.3.0-1
73
74 %description devel
75 GNU Radio Headers
76
77 %package doc
78 Summary:        GNU Radio
79 Group:          Applications/Engineering
80 Requires:       %{name} = %{version}-%{release}
81
82 %description doc
83 GNU Radio Documentation
84
85 %package examples
86 Summary:        GNU Radio
87 Group:          Applications/Engineering
88 Requires:       %{name} = %{version}-%{release}
89
90 %description examples
91 GNU Radio examples
92
93 %prep
94 %setup -q -n %{name}
95
96 #force regeneration of cached moc output files
97 find . -name "*_moc.cc" -exec rm {} \;
98
99 %build
100 ./bootstrap
101 #enabling deps tracking is workaround to build
102 %configure \
103         --enable-dependency-tracking \
104         --enable-python \
105         --enable-doxygen \
106         --enable-dot \
107         --%{?with_volk:en}%{!?with_volk:dis}able-volk \
108         --enable-gruel \
109         --enable-gnuradio-core \
110         --enable-gr-msdd6000 \
111         --enable-gr-audio \
112         --enable-gr-atsc \
113         --enable-gr-cvsd-vocoder \
114         --enable-gr-gpio \
115         %{?with_uhd:--enable-gr-uhd} \
116         --enable-gr-gsm-fr-vocoder \
117         --enable-gr-noaa \
118         --enable-gr-pager \
119         --enable-gr-radar-pager \
120         --enable-gr-radar-mono \
121         --enable-gr-radio-astronomy \
122         --enable-gr-trellis \
123         --enable-gr-video-sdl \
124         --enable-gr-wxgui \
125         --enable-gr-sounder \
126         --enable-gr-utils \
127         --enable-gnuradio-examples \
128         --enable-grc \
129         --enable-docs \
130         --with-boost-libdir=%{_libdir}
131
132 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
133
134 %{__make} clean
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post -n gnuradio -p /sbin/ldconfig
147 %postun -n gnuradio -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %{py_sitedir}/*
152 %attr(755,root,root) %{_bindir}/*
153 %{_libdir}/lib*.so.*
154 %{_libexecdir}/*
155 %{_datadir}/gnuradio
156 %config(noreplace) %{_sysconfdir}/gnuradio/conf.d/*.conf
157 %exclude %{_datadir}/gnuradio/examples
158 %exclude %{py_sitedir}/gnuradio/*.la
159 %exclude %{_docdir}/%{name}-%{version}/html
160 %exclude %{_docdir}/%{name}-%{version}/xml
161 %doc ChangeLog NEWS INSTALL COPYING AUTHORS
162
163 %files devel
164 %defattr(644,root,root,755)
165 %{_includedir}/*
166 %{_libdir}/lib*.so
167 %{_pkgconfigdir}/*.pc
168 %exclude %{_libdir}/*.la
169
170 %files doc
171 %defattr(644,root,root,755)
172 %doc %{_docdir}/%{name}-%{version}/html
173 %doc %{_docdir}/%{name}-%{version}/xml
174
175 %files examples
176 %defattr(644,root,root,755)
177 %{_datadir}/gnuradio/examples
This page took 0.062921 seconds and 2 git commands to generate.