]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
- updated to 1.9.93
[packages/gnupg2.git] / gnupg2.spec
1 # TODO:
2 # - separate keys plugins (see gnupg.spec)
3 # - update pl.po (just a note for myself  --q)
4 #
5 # Conditional build:
6 %bcond_without  pth     # without pth-based based version of gnupg
7 %bcond_with     tests   # run testsuite ( currently it smashes stack on x86-64 and SEGVs )
8 #
9 Summary:        GNU Privacy Guard - tool for secure communication and data storage - development version
10 Summary(pl):    GnuPG - narzêdzie do bezpiecznej komunikacji i bezpiecznego przechowywania danych - wersja rozwojowa
11 Name:           gnupg2
12 Version:        1.9.93
13 Release:        1
14 License:        GPL
15 Group:          Applications/File
16 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.bz2
17 # Source0-md5:  84b1af5b6c489fcbbbbf4f219aaf2526
18 Source1:        gnupg-agent.sh
19 Patch0:         %{name}-info.patch
20 Patch1:         %{name}-pth.patch
21 Patch2:         %{name}-disable_tests.patch
22 URL:            http://www.gnupg.org/
23 BuildRequires:  automake
24 BuildRequires:  bzip2-devel
25 BuildRequires:  curl-devel
26 BuildRequires:  gettext-devel >= 0.14.1
27 BuildRequires:  libassuan-devel >= 1:0.9.3
28 BuildRequires:  libgcrypt-devel >= 1.2.0
29 BuildRequires:  libgpg-error-devel >= 1.4
30 BuildRequires:  libksba-devel >= 1.0.0
31 BuildRequires:  libusb-devel
32 BuildRequires:  openldap-devel
33 BuildRequires:  pcsc-lite-devel
34 %{?with_pth:BuildRequires:      pth-devel >= 2.0.0}
35 BuildRequires:  rpmbuild(macros) >= 1.177
36 BuildRequires:  texinfo
37 BuildRequires:  zlib-devel
38 Requires:       gnupg2-common = %{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _libexecdir     %{_libdir}/gnupg2
42
43 %description
44 GnuPG is GNU's tool for secure communication and data storage. It can
45 be used to encrypt data and to create digital signatures. It includes
46 an advanced key management facility and is compliant with the proposed
47 OpenPGP Internet standard as described in RFC2440.
48
49 This is development version. Don't use it with production keys.
50
51 %description -l pl
52 GnuPG (GNU Privacy Guard) jest narzêdziem do bezpiecznej komunikacji i
53 bezpiecznego przechowywania danych. Mo¿e byæ u¿ywany do szyfrowania
54 oraz podpisywania danych. Umo¿liwia zaawansowane zarz±dzanie kluczami
55 i spe³nia normy zdefiniowane w standardzie OpenPGP, który jest opisany
56 w RFC2440.
57
58 Wersja rozwojowa. Nie do u¿ytku z kluczami produkcyjnymi.
59
60 %package common
61 Summary:        GnuPG - common files
62 Summary(pl):    GnuPG - pliki wspólne
63 Group:          Applications/File
64 Requires:       libassuan >= 1:0.9.3
65 Requires:       libgpg-error >= 1.4
66 Conflicts:      gnupg-agent < 1.9.14-2
67
68 %description common
69 Common files used by tools from GnuPG project.
70
71 %description common -l pl
72 Pliki wspólne u¿ywane przez ró¿ne narzêdzia z projektu GnuPG.
73
74 %package -n gnupg-agent
75 Summary:        GnuPG extension - agent
76 Summary(pl):    Rozszerzenie GnuPG - agent
77 Group:          Applications/File
78 Requires:       gnupg2-common = %{version}-%{release}
79 Requires:       pinentry
80 Obsoletes:      newpg
81
82 %description -n gnupg-agent
83 GnuPG extension - agent.
84
85 %description -n gnupg-agent -l pl
86 Rozszerzenie GnuPG - agent.
87
88 %package -n gnupg-agent-profile_d
89 Summary:        gnupg-agent start script for text mode
90 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu tekstowego
91 Group:          Applications/File
92 Requires:       gnupg-agent = %{version}-%{release}
93
94 %description -n gnupg-agent-profile_d
95 gnupg-agent start script for text mode.
96
97 %description -n gnupg-agent-profile_d -l pl
98 Skrypt startowy gnupg-agenta dla trybu tekstowego.
99
100 %package -n gnupg-agent-xinitrc
101 Summary:        gnupg-agent start script for X-Window mode
102 Summary(pl):    Skrypt startowy gnupg-agenta dla trybu X-Window
103 Group:          Applications/File
104 Requires:       gnupg-agent = %{version}-%{release}
105 Requires:       xinitrc
106
107 %description -n gnupg-agent-xinitrc
108 gnupg-agent start script for X-Window mode.
109
110 %description -n gnupg-agent-xinitrc -l pl
111 Skrypt startowy gnupg-agenta dla trybu X-Window.
112
113 %package -n gnupg-smime
114 Summary:        GnuPG extension - S/MIME support
115 Summary(pl):    Rozszerzenie GnuPG - obs³uga S/MIME
116 Group:          Applications/File
117 Requires:       gnupg2-common = %{version}-%{release}
118 Conflicts:      gnupg-agent < 1.9.14-2
119
120 %description -n gnupg-smime
121 GnuPG extension - S/MIME support.
122
123 %description -n gnupg-smime -l pl
124 Rozszerzenie GnuPG - obs³uga S/MIME.
125
126 %prep
127 %setup -q -n gnupg-%{version}
128 %patch0 -p1
129 %patch1 -p1
130 %{!?with_tests:%patch2 -p1}
131
132 %build
133 cp -f /usr/share/automake/config.* scripts
134 %{__automake}
135
136 %configure \
137         --with-capabilities \
138         %{!?with_pth:--disable-threads} \
139         --enable-gpg \
140 %ifarch sparc sparc64
141         --disable-m-guard \
142 %else
143         --enable-m-guard \
144 %endif
145         --without-included-gettext \
146         --disable-m-debug \
147         --with-mailprog=/usr/lib/sendmail
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT \
156         pkglibdir=%{_libexecdir}
157
158 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/gnupg-agent.sh
159 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gnupg-agent.sh
160
161 mv ChangeLog main-ChangeLog || :
162 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
163
164 %find_lang gnupg2
165 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post
171 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
172
173 %postun
174 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
175
176 %triggerpostun -n gnupg-agent -- gnupg-agent < 1.9.16-2
177 %banner gnupg-agent-1.9.16-2 << EOF
178 Scripts for starting gnupg-agent have been moved to separate
179 subpackages: gnupg-agent-profile_d and gnupg-agent-xinitrc.
180 EOF
181
182 %files
183 %defattr(644,root,root,755)
184 %doc g10-ChangeLog g10/options.skel
185 %attr(755,root,root) %{_bindir}/gpg2
186 %attr(755,root,root) %{_bindir}/gpgv2
187 %attr(755,root,root) %{_libexecdir}/gpg2keys_curl
188 %attr(755,root,root) %{_libexecdir}/gpg2keys_finger
189 %attr(755,root,root) %{_libexecdir}/gpg2keys_hkp
190 %attr(755,root,root) %{_libexecdir}/gpg2keys_ldap
191 %{_mandir}/man1/gpg2.1*
192 %{_mandir}/man1/gpgv2.1*
193 # conflicts with gnupg 1.4.x
194 #%attr(755,root,root) %{_bindir}/gpg-zip
195 #%attr(755,root,root) %{_bindir}/gpgsplit
196 #%{_mandir}/man7/gnupg.7*
197 # program not built by default
198 #%{_mandir}/man1/symcryptrun.1*
199
200 %files common -f gnupg2.lang
201 %defattr(644,root,root,755)
202 %doc AUTHORS main-ChangeLog NEWS README THANKS TODO
203 %doc intl-ChangeLog jnlib-ChangeLog m4-ChangeLog po-ChangeLog scripts-ChangeLog common-ChangeLog kbx-ChangeLog tools-ChangeLog doc-ChangeLog
204 %attr(755,root,root) %{_bindir}/gpg-connect-agent
205 %attr(755,root,root) %{_bindir}/gpgconf
206 %attr(755,root,root) %{_bindir}/gpgkey2ssh
207 %attr(755,root,root) %{_bindir}/gpgparsemail
208 %attr(755,root,root) %{_bindir}/kbxutil
209 %attr(755,root,root) %{_bindir}/watchgnupg
210 %attr(755,root,root) %{_sbindir}/addgnupghome
211 %dir %{_libexecdir}
212 %{_datadir}/gnupg
213 %{_mandir}/man1/gpg-connect-agent.1*
214 %{_mandir}/man1/gpgconf.1*
215 %{_mandir}/man1/gpgparsemail.1*
216 %{_mandir}/man1/watchgnupg.1*
217 %{_mandir}/man8/addgnupghome.8*
218 %{_infodir}/*.info*
219
220 %files -n gnupg-smime
221 %defattr(644,root,root,755)
222 %doc sm-ChangeLog
223 %attr(755,root,root) %{_bindir}/gpgsm
224 %attr(755,root,root) %{_bindir}/gpgsm-gencert.sh
225 %{_mandir}/man1/gpgsm.1*
226 %{_mandir}/man1/gpgsm-gencert.sh.1*
227
228 %files -n gnupg-agent
229 %defattr(644,root,root,755)
230 %doc agent-ChangeLog scd-ChangeLog
231 %attr(755,root,root) %{_bindir}/gpg-agent
232 %attr(755,root,root) %{_bindir}/scdaemon
233 %attr(755,root,root) %{_libexecdir}/gpg-protect-tool
234 %attr(755,root,root) %{_libexecdir}/gpg-preset-passphrase
235 %attr(755,root,root) %{_libexecdir}/pcsc-wrapper
236 %{_mandir}/man1/gpg-agent.1*
237 %{_mandir}/man1/gpg-preset-passphrase.1*
238 %{_mandir}/man1/scdaemon.1*
239
240 %files -n gnupg-agent-profile_d
241 %defattr(644,root,root,755)
242 %attr(755,root,root) /etc/profile.d/gnupg-agent.sh
243
244 %files -n gnupg-agent-xinitrc
245 %defattr(644,root,root,755)
246 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/gnupg-agent.sh
This page took 0.38755 seconds and 4 git commands to generate.