]> git.pld-linux.org Git - packages/gnupg2.git/blob - gnupg2.spec
- already in sources
[packages/gnupg2.git] / gnupg2.spec
1 #
2 # Conditional build:
3 %bcond_with     max_cache_ttl # add max-cache-ttl option (for tests) 
4 %bcond_without  xinitrc # don't use xinitrc's directory
5 #
6 Summary:        GnuPG extension - agent
7 Summary(pl):    Rozszerzenie GnuPG - agent
8 Name:           gnupg-agent
9 Version:        1.9.11
10 Release:        1
11 License:        GPL
12 Group:          Applications/File
13 Source0:        ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.gz
14 # Source0-md5:  33134af66b983c29984eeab8681a9f10
15 Source1:        gnupg-agent.sh
16 # Patch0 based on http://marc.theaimsgroup.com/?l=gnupg-devel&m=109300087831144&w=2
17 # taken from gnupg cvs.
18 Patch0:         %{name}-max_cache_ttl.patch     
19 Icon:           gnupg.gif
20 URL:            http://www.gnupg.org/
21 BuildRequires:  automake
22 BuildRequires:  gettext-devel >= 0.12.1
23 BuildRequires:  libassuan-devel >= 1:0.6.6
24 BuildRequires:  libgcrypt-devel >= 1.1.93
25 BuildRequires:  libgpg-error-devel >= 0.6
26 BuildRequires:  libksba-devel >= 0.9.7
27 BuildRequires:  pcsc-lite-devel
28 BuildRequires:  opensc-devel >= 0.8.0
29 BuildRequires:  pth-devel >= 2.0.0
30 BuildRequires:  texinfo
31 BuildRequires:  zlib-devel
32 Requires:       gnupg
33 Requires:       pinentry
34 %{?with_xinitrc:Requires: xinitrc}
35 Obsoletes:      newpg
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _libexecdir     %{_libdir}/gnupg
39
40 %description
41 GnuPG extension - agent.
42
43 %description -l pl
44 Rozszerzenie GnuPG - agent.
45
46 %prep
47 %setup -q -n gnupg-%{version}
48 %{?with_max_cache_ttl:%patch0 -p1}
49
50 %build
51 cp -f /usr/share/automake/config.* scripts
52 %configure \
53         --disable-gpg \
54         --with-capabilities \
55 %ifarch sparc sparc64
56         --disable-m-guard \
57 %else
58         --enable-m-guard \
59 %endif
60         --without-included-gettext \
61         --disable-m-debug \
62         --with-mailprog=/usr/lib/sendmail
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT/etc/profile.d
69 %{?with_xinitrc:install -d $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d}
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 ln -sf gpg2 $RPM_BUILD_ROOT%{_bindir}/gpg
75 install %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
76 %{?with_xinitrc:ln -sf /etc/profile.d/%{name}.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/%{name}.sh}
77
78 %find_lang gnupg2
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post
84 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
85
86 %postun
87 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
88
89 %files -f gnupg2.lang
90 %defattr(644,root,root,755)
91 %doc agent/ChangeLog
92 %attr(755,root,root) %{_bindir}/gpg-agent
93 %attr(755,root,root) %{_bindir}/gpgconf
94 %attr(755,root,root) %{_bindir}/gpgsm
95 %attr(755,root,root) %{_bindir}/kbxutil
96 %attr(755,root,root) %{_bindir}/sc-copykeys
97 %attr(755,root,root) %{_bindir}/sc-investigate
98 %attr(755,root,root) %{_bindir}/scdaemon
99 %attr(755,root,root) %{_bindir}/watchgnupg
100 %attr(755,root,root) %{_sbindir}/addgnupghome
101 %attr(755,root,root) %{_libdir}/gnupg/gpg-protect-tool
102 %attr(755,root,root) %{_libdir}/gnupg/pcsc-wrapper
103 %attr(755,root,root) /etc/profile.d/%{name}.sh
104 %{?with_xinitrc:%attr(755,root,root) /etc/X11/xinit/xinitrc.d/%{name}.sh}
This page took 0.07644 seconds and 3 git commands to generate.