]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
- updated to 0.16 (new soname)
[packages/gnuastro.git] / gnuastro.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        GNU Astronomy Utilities
6 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
7 Name:           gnuastro
8 Version:        0.16
9 Release:        1
10 License:        GPL v3+
11 Group:          Applications/Science
12 Source0:        https://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
13 # Source0-md5:  2685beb70cd4fddfe7ddc903d8ed661a
14 Patch0:         %{name}-info.patch
15 Patch1:         ac.patch
16 URL:            http://www.gnu.org/software/gnuastro/
17 BuildRequires:  autoconf >= 2.69
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 BuildRequires:  cfitsio-devel
21 BuildRequires:  curl-devel
22 BuildRequires:  ghostscript >= 9.10
23 BuildRequires:  gsl-devel >= 2.0
24 BuildRequires:  help2man
25 BuildRequires:  libgit2-devel
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libtiff-devel
28 BuildRequires:  libtool >= 2:2
29 BuildRequires:  lzip
30 BuildRequires:  rpm-build >= 4.6
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  wcslib-devel
33 BuildRequires:  xz-devel
34 BuildRequires:  zlib-devel
35 Suggests:       ghostscript >= 9.10
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
40 programs and a library functions for astronomical data manipulation
41 and analysis. The programs are run on the operating system's
42 command-line enabling easy and efficient operation combined with other
43 installed programs in shell scripts or Makefiles. The libraries are
44 also usable in C and C++ programs.
45
46 %description -l pl.UTF-8
47 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
48 programy i funkcje biblioteczne do obróbki i analiz danych
49 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
50 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
51 innymi zainstalowanymi programami lub z poziomu plików Makefile.
52 Biblioteki mogą być używane w programach w C i C++.
53
54 %package devel
55 Summary:        Header files for Gnuastro library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       cfitsio-devel
60 Requires:       gsl-devel
61 Requires:       libgit2-devel
62 Requires:       libjpeg-devel
63 Requires:       libtiff-devel >= 4
64 Requires:       wcslib-devel
65 Requires:       xz-devel
66
67 %description devel
68 Header files for Gnuastro library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki Gnuastro.
72
73 %package static
74 Summary:        Static Gnuastro library
75 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static Gnuastro library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka Gnuastro.
84
85 %package -n bash-completion-gnuastro
86 Summary:        Bash completion for gnuastro commands
87 Summary(pl.UTF-8):      Bashowe uzupełnianie składni poleceń gnuastro
88 Group:          Applications/Shells
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       bash-completion >= 2.0
91 BuildArch:      noarch
92
93 %description -n bash-completion-gnuastro
94 Bash completion for gnuastro commands.
95
96 %description -n bash-completion-gnuastro -l pl.UTF-8
97 Bashowe uzupełnianie składni poleceń gnuastro.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 # regenerate for as-needed to work
106 %{__libtoolize}
107 %{__aclocal} -I bootstrapped/m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --sysconfdir=%{_sysconfdir}/gnuastro \
113         %{!?with_static_libs:--disable-static}
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 # obsoleted by pkg-config
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
124 # packaged as %doc
125 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
126
127 install -d $RPM_BUILD_ROOT%{bash_compdir}
128 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gnuastro/completion.bash $RPM_BUILD_ROOT%{bash_compdir}/gnuastro
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/postshell
134 -/sbin/ldconfig
135 -/usr/sbin/fix-info-dir -c %{_infodir}
136
137 %postun -p /sbin/postshell
138 -/sbin/ldconfig
139 -/usr/sbin/fix-info-dir -c %{_infodir}
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README THANKS
144 %attr(755,root,root) %{_bindir}/astarithmetic
145 %attr(755,root,root) %{_bindir}/astbuildprog
146 %attr(755,root,root) %{_bindir}/astconvertt
147 %attr(755,root,root) %{_bindir}/astconvolve
148 %attr(755,root,root) %{_bindir}/astcosmiccal
149 %attr(755,root,root) %{_bindir}/astcrop
150 %attr(755,root,root) %{_bindir}/astfits
151 %attr(755,root,root) %{_bindir}/astmatch
152 %attr(755,root,root) %{_bindir}/astmkcatalog
153 %attr(755,root,root) %{_bindir}/astmknoise
154 %attr(755,root,root) %{_bindir}/astmkprof
155 %attr(755,root,root) %{_bindir}/astnoisechisel
156 %attr(755,root,root) %{_bindir}/astquery
157 %attr(755,root,root) %{_bindir}/astscript-ds9-region
158 %attr(755,root,root) %{_bindir}/astscript-radial-profile
159 %attr(755,root,root) %{_bindir}/astscript-sort-by-night
160 %attr(755,root,root) %{_bindir}/astsegment
161 %attr(755,root,root) %{_bindir}/aststatistics
162 %attr(755,root,root) %{_bindir}/asttable
163 %attr(755,root,root) %{_bindir}/astwarp
164 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.14
166 %dir %{_sysconfdir}/gnuastro
167 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
168 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
169 %{_infodir}/gnuastro.info*
170 %{_infodir}/gnuastro-figures
171 %{_mandir}/man1/astarithmetic.1*
172 %{_mandir}/man1/astbuildprog.1*
173 %{_mandir}/man1/astconvertt.1*
174 %{_mandir}/man1/astconvolve.1*
175 %{_mandir}/man1/astcosmiccal.1*
176 %{_mandir}/man1/astcrop.1*
177 %{_mandir}/man1/astfits.1*
178 %{_mandir}/man1/astmatch.1*
179 %{_mandir}/man1/astmkcatalog.1*
180 %{_mandir}/man1/astmknoise.1*
181 %{_mandir}/man1/astmkprof.1*
182 %{_mandir}/man1/astnoisechisel.1*
183 %{_mandir}/man1/astquery.1*
184 %{_mandir}/man1/astscript-ds9-region.1*
185 %{_mandir}/man1/astscript-radial-profile.1*
186 %{_mandir}/man1/astscript-sort-by-night.1*
187 %{_mandir}/man1/astsegment.1*
188 %{_mandir}/man1/aststatistics.1*
189 %{_mandir}/man1/asttable.1*
190 %{_mandir}/man1/astwarp.1*
191
192 %files devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libgnuastro.so
195 %{_includedir}/gnuastro
196 %{_pkgconfigdir}/gnuastro.pc
197
198 %if %{with static_libs}
199 %files static
200 %defattr(644,root,root,755)
201 %{_libdir}/libgnuastro.a
202 %endif
203
204 %files -n bash-completion-gnuastro
205 %defattr(644,root,root,755)
206 %{bash_compdir}/gnuastro
This page took 0.099817 seconds and 3 git commands to generate.