]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
libgit2 1.6 rebuild
[packages/gnuastro.git] / gnuastro.spec
1 # TODO: ds9, topcat (for Suggests)
2 #       https://sites.google.com/cfa.harvard.edu/saoimageds9
3 #       http://www.star.bris.ac.uk/~mbt/topcat/
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # static library
7
8 Summary:        GNU Astronomy Utilities
9 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
10 Name:           gnuastro
11 Version:        0.19
12 Release:        2
13 License:        GPL v3+
14 Group:          Applications/Science
15 Source0:        https://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
16 # Source0-md5:  8b65b9bfd1541a7f47e039e5ba62af21
17 Patch0:         %{name}-info.patch
18 Patch1:         ac.patch
19 Patch2:         %{name}-link.patch
20 Patch3:         %{name}-numpy.patch
21 URL:            http://www.gnu.org/software/gnuastro/
22 BuildRequires:  autoconf >= 2.69
23 BuildRequires:  automake
24 BuildRequires:  bzip2-devel
25 BuildRequires:  cfitsio-devel
26 BuildRequires:  curl-devel
27 BuildRequires:  ghostscript >= 9.10
28 BuildRequires:  gsl-devel >= 2.0
29 BuildRequires:  help2man
30 BuildRequires:  libgit2-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libtiff-devel
33 BuildRequires:  libtool >= 2:2
34 BuildRequires:  lzip
35 BuildRequires:  python3 >= 1:3.2
36 BuildRequires:  python3-numpy-devel
37 BuildRequires:  rpm-build >= 4.6
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  wcslib-devel
40 BuildRequires:  xz-devel
41 BuildRequires:  zlib-devel
42 Suggests:       ghostscript >= 9.10
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
47 programs and a library functions for astronomical data manipulation
48 and analysis. The programs are run on the operating system's
49 command-line enabling easy and efficient operation combined with other
50 installed programs in shell scripts or Makefiles. The libraries are
51 also usable in C and C++ programs.
52
53 %description -l pl.UTF-8
54 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
55 programy i funkcje biblioteczne do obróbki i analiz danych
56 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
57 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
58 innymi zainstalowanymi programami lub z poziomu plików Makefile.
59 Biblioteki mogą być używane w programach w C i C++.
60
61 %package devel
62 Summary:        Header files for Gnuastro library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       cfitsio-devel
67 Requires:       gsl-devel
68 Requires:       libgit2-devel
69 Requires:       libjpeg-devel
70 Requires:       libtiff-devel >= 4
71 Requires:       wcslib-devel
72 Requires:       xz-devel
73
74 %description devel
75 Header files for Gnuastro library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki Gnuastro.
79
80 %package static
81 Summary:        Static Gnuastro library
82 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static Gnuastro library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka Gnuastro.
91
92 %package -n bash-completion-gnuastro
93 Summary:        Bash completion for gnuastro commands
94 Summary(pl.UTF-8):      Bashowe uzupełnianie składni poleceń gnuastro
95 Group:          Applications/Shells
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       bash-completion >= 2.0
98 BuildArch:      noarch
99
100 %description -n bash-completion-gnuastro
101 Bash completion for gnuastro commands.
102
103 %description -n bash-completion-gnuastro -l pl.UTF-8
104 Bashowe uzupełnianie składni poleceń gnuastro.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111 %patch3 -p1
112
113 %build
114 # regenerate for as-needed to work
115 %{__libtoolize}
116 %{__aclocal} -I bootstrapped/m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --sysconfdir=%{_sysconfdir}/gnuastro \
122         %{!?with_static_libs:--disable-static}
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
133 # packaged as %doc
134 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
135
136 install -d $RPM_BUILD_ROOT%{bash_compdir}
137 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gnuastro/completion.bash $RPM_BUILD_ROOT%{bash_compdir}/gnuastro
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/postshell
143 -/sbin/ldconfig
144 -/usr/sbin/fix-info-dir -c %{_infodir}
145
146 %postun -p /sbin/postshell
147 -/sbin/ldconfig
148 -/usr/sbin/fix-info-dir -c %{_infodir}
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README THANKS
153 %attr(755,root,root) %{_bindir}/astarithmetic
154 %attr(755,root,root) %{_bindir}/astbuildprog
155 %attr(755,root,root) %{_bindir}/astconvertt
156 %attr(755,root,root) %{_bindir}/astconvolve
157 %attr(755,root,root) %{_bindir}/astcosmiccal
158 %attr(755,root,root) %{_bindir}/astcrop
159 %attr(755,root,root) %{_bindir}/astfits
160 %attr(755,root,root) %{_bindir}/astmatch
161 %attr(755,root,root) %{_bindir}/astmkcatalog
162 %attr(755,root,root) %{_bindir}/astmknoise
163 %attr(755,root,root) %{_bindir}/astmkprof
164 %attr(755,root,root) %{_bindir}/astnoisechisel
165 %attr(755,root,root) %{_bindir}/astquery
166 %attr(755,root,root) %{_bindir}/astscript-ds9-region
167 %attr(755,root,root) %{_bindir}/astscript-fits-view
168 %attr(755,root,root) %{_bindir}/astscript-psf-scale-factor
169 %attr(755,root,root) %{_bindir}/astscript-psf-select-stars
170 %attr(755,root,root) %{_bindir}/astscript-psf-stamp
171 %attr(755,root,root) %{_bindir}/astscript-psf-subtract
172 %attr(755,root,root) %{_bindir}/astscript-psf-unite
173 %attr(755,root,root) %{_bindir}/astscript-radial-profile
174 %attr(755,root,root) %{_bindir}/astscript-sort-by-night
175 %attr(755,root,root) %{_bindir}/astsegment
176 %attr(755,root,root) %{_bindir}/aststatistics
177 %attr(755,root,root) %{_bindir}/asttable
178 %attr(755,root,root) %{_bindir}/astwarp
179 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.17
181 %dir %{_sysconfdir}/gnuastro
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
184 %{_datadir}/gnuastro
185 %{_infodir}/gnuastro.info*
186 %{_infodir}/gnuastro-figures
187 %{_mandir}/man1/astarithmetic.1*
188 %{_mandir}/man1/astbuildprog.1*
189 %{_mandir}/man1/astconvertt.1*
190 %{_mandir}/man1/astconvolve.1*
191 %{_mandir}/man1/astcosmiccal.1*
192 %{_mandir}/man1/astcrop.1*
193 %{_mandir}/man1/astfits.1*
194 %{_mandir}/man1/astmatch.1*
195 %{_mandir}/man1/astmkcatalog.1*
196 %{_mandir}/man1/astmknoise.1*
197 %{_mandir}/man1/astmkprof.1*
198 %{_mandir}/man1/astnoisechisel.1*
199 %{_mandir}/man1/astquery.1*
200 %{_mandir}/man1/astscript-ds9-region.1*
201 %{_mandir}/man1/astscript-fits-view.1*
202 %{_mandir}/man1/astscript-psf-scale-factor.1*
203 %{_mandir}/man1/astscript-psf-select-stars.1*
204 %{_mandir}/man1/astscript-psf-stamp.1*
205 %{_mandir}/man1/astscript-psf-subtract.1*
206 %{_mandir}/man1/astscript-psf-unite.1*
207 %{_mandir}/man1/astscript-radial-profile.1*
208 %{_mandir}/man1/astscript-sort-by-night.1*
209 %{_mandir}/man1/astsegment.1*
210 %{_mandir}/man1/aststatistics.1*
211 %{_mandir}/man1/asttable.1*
212 %{_mandir}/man1/astwarp.1*
213
214 %files devel
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/libgnuastro.so
217 %{_includedir}/gnuastro
218 %{_pkgconfigdir}/gnuastro.pc
219
220 %if %{with static_libs}
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/libgnuastro.a
224 %endif
225
226 %files -n bash-completion-gnuastro
227 %defattr(644,root,root,755)
228 %{bash_compdir}/gnuastro
This page took 0.126082 seconds and 3 git commands to generate.