]> git.pld-linux.org Git - packages/gnome-terminal.git/blob - gnome-terminal.spec
- release 2
[packages/gnome-terminal.git] / gnome-terminal.spec
1 #
2 # This causes <prev-tab> key do nothing on the first tab (instead of 
3 # passing the keypress to the application running in the terminal). Ditto 
4 # for the last tab. This is kinda annoying.
5 %bcond_with     disable_prev_next_tab_sensitivity_changes
6 # This is specific to PLD and causes an "unknown term type" on most other
7 # hosts I have to work on (the rest of the world uses xterm for g-t)
8 %bcond_with     term_voodoo
9 #
10 Summary:        GNOME Terminal
11 Summary(pl):    Terminal dla GNOME
12 Name:           gnome-terminal
13 Version:        2.14.1
14 Release:        2
15 License:        GPL
16 Group:          X11/Applications
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-terminal/2.14/%{name}-%{version}.tar.bz2
18 # Source0-md5:  7abe60db5359c88392d2b4f0d5587ef5
19 Patch0:         %{name}-TERM.patch
20 Patch1:         %{name}-disable-prev_next-tab-sensitivity-changes.patch
21 Patch2:         %{name}-desktop.patch
22 URL:            http://www.gnome.org/
23 BuildRequires:  GConf2-devel >= 2.14.0
24 BuildRequires:  autoconf >= 2.53
25 BuildRequires:  automake
26 BuildRequires:  gtk+2-devel >= 2:2.8.0
27 BuildRequires:  gnome-common >= 2.12.0
28 BuildRequires:  gnome-vfs2-devel >= 2.14.0
29 BuildRequires:  intltool
30 BuildRequires:  libglade2-devel >= 1:2.5.1
31 BuildRequires:  libgnomeui-devel >= 2.14.0
32 BuildRequires:  libtool
33 BuildRequires:  pkgconfig >= 1:0.12.0
34 BuildRequires:  rpmbuild(macros) >= 1.197
35 BuildRequires:  scrollkeeper
36 BuildRequires:  startup-notification-devel >= 0.8
37 BuildRequires:  vte-devel >= 0.12.1
38 BuildRequires:  xft-devel >= 2.1-2
39 Requires(post,preun):   GConf2
40 Requires(post,postun):  scrollkeeper
41 Requires:       libgnomeui >= 2.14.0
42 Requires:       startup-notification >= 0.8
43 Requires:       vte >= 0.12.1
44 Requires:       terminfo
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 This is a terminal thing that isn't finished at all.
49
50 %description -l pl
51 To jest terminal, na razie ca³kowicie nie dokoñczony.
52
53 %prep
54 %setup -q
55 %if %{with term_voodoo}
56 %patch0 -p1
57 %endif
58 %if %{with disable_prev_next_tab_sensitivity_changes}
59 %patch1 -p1
60 %endif
61 %patch2 -p1
62
63 %build
64 %{__intltoolize}
65 %{__gnome_doc_common}
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__automake}
70 %configure
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT \
78         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
79         localedir=%{_localedir}
80
81 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
82 rm -rf $RPM_BUILD_ROOT%{_datadir}/application-registry
83
84 %find_lang %{name} --with-gnome --all-name
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 %gconf_schema_install gnome-terminal.schemas
91 %scrollkeeper_update_post
92
93 %preun
94 %gconf_schema_uninstall gnome-terminal.schemas
95
96 %postun
97 %scrollkeeper_update_postun
98
99 %files -f %{name}.lang
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog NEWS README
102 %doc %{_omf_dest_dir}/%{name}
103 %attr(755,root,root) %{_bindir}/*
104 %{_libdir}/bonobo/servers/*
105 %{_datadir}/%{name}
106 %{_desktopdir}/*
107 %{_pixmapsdir}/*
108 %{_sysconfdir}/gconf/schemas/gnome-terminal.schemas
This page took 0.033832 seconds and 3 git commands to generate.