]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- updated to 3.4.2
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  systemd # by default use systemd for session tracking instead of ConsoleKit (fallback to ConsoleKit on runtime)
4 #
5 Summary:        Window manager and application launcher for GNOME
6 Name:           gnome-shell
7 Version:        3.4.2
8 Release:        1
9 License:        GPL v2+
10 Group:          X11/Window Managers
11 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.4/%{name}-%{version}.tar.xz
12 # Source0-md5:  d1125998a0a89d625eef5e16bd774ef5
13 URL:            http://live.gnome.org/GnomeShell
14 BuildRequires:  NetworkManager-devel >= 0.8.999
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  clutter-devel >= 1.9.16
18 BuildRequires:  dbus-glib-devel
19 BuildRequires:  evolution-data-server-devel >= 3.1.90
20 BuildRequires:  folks-devel >= 0.6.1
21 BuildRequires:  gcr-devel >= 3.3.90
22 BuildRequires:  gettext-devel >= 0.17
23 BuildRequires:  gjs-devel >= 1.31.10
24 BuildRequires:  glib2-devel >= 1:2.31.6
25 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
26 BuildRequires:  gnome-desktop-devel >= 3.1.90
27 BuildRequires:  gnome-menus-devel >= 3.1.90
28 BuildRequires:  gobject-introspection-devel >= 0.10.1
29 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
30 BuildRequires:  gstreamer-devel >= 0.10.21
31 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
32 BuildRequires:  gtk+3-devel >= 3.3.9
33 BuildRequires:  gtk-doc >= 1.15
34 BuildRequires:  intltool >= 0.40
35 BuildRequires:  json-glib-devel >= 0.13.90
36 BuildRequires:  libcanberra-devel
37 BuildRequires:  libcroco-devel >= 0.6.2
38 BuildRequires:  libgnome-keyring-devel
39 BuildRequires:  libsoup-devel
40 BuildRequires:  libtool >= 2:2.2.6
41 BuildRequires:  libxml2-devel
42 BuildRequires:  mutter-devel >= 3.4.0
43 BuildRequires:  pkgconfig >= 1:0.22
44 BuildRequires:  polkit-devel >= 0.100
45 BuildRequires:  pulseaudio-devel
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.601
48 BuildRequires:  startup-notification-devel >= 0.11
49 %{?with_systemd:BuildRequires:  systemd-devel}
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  telepathy-glib-devel >= 0.17.5
52 BuildRequires:  telepathy-logger-devel >= 0.2.4
53 BuildRequires:  xorg-lib-libXfixes-devel
54 BuildRequires:  xz
55 Requires(post,postun):  glib2 >= 1:2.26.0
56 Requires:       at-spi2-atk >= 2.4.0
57 Requires:       caribou >= 0.3.5
58 Requires:       evolution-data-server >= 3.1.90
59 Requires:       gjs >= 1.31.10
60 Requires:       glib2 >= 1:2.31.6
61 Requires:       gnome-bluetooth-libs >= 3.1.0
62 Requires:       gnome-menus >= 3.1.90
63 Requires:       gnome-settings-daemon >= 3.1.90
64 Requires:       gsettings-desktop-schemas >= 3.1.90
65 Requires:       gtk+3 >= 3.3.9
66 Requires:       mutter >= 3.4.0
67 Requires:       nautilus >= 3.2.0
68 Requires:       telepathy-logger >= 0.2.4
69 Requires:       telepathy-mission-control
70 Suggests:       gnome-contacts >= 3.2.0
71 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
72 Provides:       gdm-wm = 3.4.0
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 GNOME Shell is the defining technology of the GNOME 3 desktop user
77 experience. It provides core interface functions like switching to
78 windows and launching applications. GNOME Shell takes advantage of the
79 capabilities of modern graphics hardware and introduces innovative
80 user interface concepts to provide a delightful and easy to use
81 experience.
82
83 %package apidocs
84 Summary:        GNOME Shell API documentation
85 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
86 Group:          Documentation
87 Requires:       gtk-doc-common
88
89 %description apidocs
90 This package provides GNOME Shell API documentation.
91
92 %description apidocs -l pl.UTF-8
93 Ten pakiet dostarcza dokumentację API GNOME Shell.
94
95 %package -n browser-plugin-%{name}
96 Summary:        gnome-shell plugin for WWW browsers
97 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglądarek WWW
98 Group:          X11/Libraries
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       browser-plugins >= 2.0
101 Requires:       browser-plugins(%{_target_base_arch})
102 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
103 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
104 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
105 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
106
107 %description -n browser-plugin-%{name}
108 gnome-shell plugin for WWW browsers.
109
110 %description -n browser-plugin-%{name} -l pl.UTF-8
111 Wtyczka gnome-shell do przeglądarek WWW.
112
113 %prep
114 %setup -q
115
116 %build
117 %{__intltoolize}
118 %{__libtoolize}
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --with-ca-certificates=/etc/certs/ca-certificates.crt \
125         --enable-gtk-doc \
126         --disable-silent-rules \
127         --disable-static \
128         %{__enable_disable systemd systemd} \
129         --with-html-dir=%{_gtkdocdir}
130 %{__make} -j1
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
135
136 %{__make} install \
137         INSTALL="install -p" \
138         install_sh="install -p" \
139         DESTDIR=$RPM_BUILD_ROOT \
140         mozillalibdir=%{_browserpluginsdir}
141
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/*.la \
143         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
144
145 %find_lang %{name}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 %glib_compile_schemas
152
153 %postun
154 if [ "$1" = "0" ]; then
155         %glib_compile_schemas
156 fi
157
158 %post -n browser-plugin-%{name}
159 %update_browser_plugins
160
161 %postun -n browser-plugin-%{name}
162 if [ "$1" = 0 ]; then
163         %update_browser_plugins
164 fi
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_bindir}/gnome-shell
169 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
170 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
171 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
172 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
173 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
174 %dir %{_libdir}/gnome-shell
175 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
176 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-js.so
177 %{_libdir}/gnome-shell/Gvc-1.0.typelib
178 %{_libdir}/gnome-shell/Shell-0.1.typelib
179 %{_libdir}/gnome-shell/ShellJS-0.1.typelib
180 %{_libdir}/gnome-shell/St-1.0.typelib
181 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
182 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
183 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
184 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
185 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
186 %{_datadir}/glib-2.0/schemas/org.gnome.shell.evolution.calendar.gschema.xml
187 %{_datadir}/gnome-shell
188 %{_desktopdir}/gnome-shell.desktop
189 %{_desktopdir}/gnome-shell-extension-prefs.desktop
190 %{_mandir}/man1/gnome-shell.1*
191
192 %files apidocs
193 %defattr(644,root,root,755)
194 %{_gtkdocdir}/shell
195 %{_gtkdocdir}/st
196
197 %files -n browser-plugin-%{name}
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.068798 seconds and 3 git commands to generate.