]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
0f651a3c208204c754e95069ae627593794ed7fc
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         clutter_ver                     1.21.5
6 # max(ecal_req, eds_req)
7 %define         evolution_data_server_ver       3.33.1
8 %define         gcr_ver                         3.7.5
9 %define         gjs_ver                         1.65.1
10 %define         glib_ver                        1:2.57.2
11 %define         gnome_bluetooth_ver             3.9.0
12 %define         gnome_desktop_ver               3.36.0
13 %define         gsettings_desktop_schemas_ver   3.33.1
14 %define         gtk_ver                         3.15.0
15 %define         json_glib_ver                   0.13.90
16 %define         libcroco_ver                    0.6.8
17 %define         libsecret_ver                   0.18
18 %define         mutter_ver                      3.38.0
19 %define         NetworkManager_ver              1.10.4
20 %define         polkit_ver                      0.100
21 %define         pulseaudio_ver                  2.0
22 %define         startup_notification_ver        0.11
23
24 Summary:        Window manager and application launcher for GNOME
25 Summary(pl.UTF-8):      Zarządca okien i uruchamiania aplikacji dla GNOME
26 Name:           gnome-shell
27 Version:        3.38.1
28 Release:        1
29 License:        GPL v2+
30 Group:          X11/Window Managers
31 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.38/%{name}-%{version}.tar.xz
32 # Source0-md5:  a12f98e36f4cfc4b4f968c35edc6f778
33 URL:            https://wiki.gnome.org/Projects/GnomeShell
34 BuildRequires:  NetworkManager-devel >= %{NetworkManager_ver}
35 BuildRequires:  at-spi2-atk-devel
36 BuildRequires:  clutter-devel >= %{clutter_ver}
37 BuildRequires:  evolution-data-server-devel >= %{evolution_data_server_ver}
38 BuildRequires:  gcr-devel >= %{gcr_ver}
39 BuildRequires:  gdk-pixbuf2-devel >= 2.0
40 BuildRequires:  gettext-tools >= 0.19.6
41 BuildRequires:  gjs-devel >= %{gjs_ver}
42 BuildRequires:  glib2-devel >= %{glib_ver}
43 BuildRequires:  gnome-autoar-devel
44 BuildRequires:  gnome-bluetooth-devel >= %{gnome_bluetooth_ver}
45 BuildRequires:  gnome-control-center-devel
46 # for cldr2json.py (through pygobject->gi)
47 BuildRequires:  gnome-desktop >= %{gnome_desktop_ver}
48 BuildRequires:  gobject-introspection-devel >= 1.50.0
49 BuildRequires:  gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
50 BuildRequires:  gstreamer-devel >= 1.0.0
51 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
52 BuildRequires:  gtk+3-devel >= %{gtk_ver}
53 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.15}
54 BuildRequires:  ibus-devel >= 1.5.2
55 BuildRequires:  json-glib-devel >= %{json_glib_ver}
56 BuildRequires:  libcanberra-devel
57 BuildRequires:  libcanberra-gtk3-devel
58 BuildRequires:  libcroco-devel >= %{libcroco_ver}
59 BuildRequires:  libsecret-devel >= %{libsecret_ver}
60 BuildRequires:  libsoup-devel
61 BuildRequires:  libxml2-devel >= 2.0
62 BuildRequires:  libxslt-progs
63 BuildRequires:  meson >= 0.53.0
64 BuildRequires:  mutter-devel >= %{mutter_ver}
65 BuildRequires:  ninja >= 1.5
66 BuildRequires:  pipewire-devel >= 0.3
67 BuildRequires:  pkgconfig >= 1:0.22
68 BuildRequires:  polkit-devel >= %{polkit_ver}
69 BuildRequires:  pulseaudio-devel >= %{pulseaudio_ver}
70 BuildRequires:  python3 >= 1:3
71 BuildRequires:  python3-pygobject3 >= 3
72 BuildRequires:  rpm-pythonprov
73 BuildRequires:  rpmbuild(macros) >= 1.752
74 BuildRequires:  sassc
75 BuildRequires:  sed >= 4.0
76 BuildRequires:  startup-notification-devel >= %{startup_notification_ver}
77 BuildRequires:  systemd-devel
78 BuildRequires:  systemd-units
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  xorg-lib-libX11-devel
81 BuildRequires:  xorg-lib-libXfixes-devel
82 BuildRequires:  xz
83 Requires(post,postun):  glib2 >= %{glib_ver}
84 # gjs->gi->NMA.gir
85 Requires:       NetworkManager-libs >= %{NetworkManager_ver}
86 Requires:       adwaita-icon-theme
87 Requires:       at-spi2-atk >= 2.4.0
88 Requires:       clutter >= %{clutter_ver}
89 Requires:       evolution-data-server >= %{evolution_data_server_ver}
90 Requires:       gcr >= %{gcr_ver}
91 Requires:       gjs >= %{gjs_ver}
92 Requires:       glib2 >= %{glib_ver}
93 Requires:       gnome-bluetooth-libs >= %{gnome_bluetooth_ver}
94 Requires:       gnome-desktop >= %{gnome_desktop_ver}
95 Requires:       gnome-settings-daemon >= 3.8.0
96 Requires:       gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
97 Requires:       gtk+3 >= %{gtk_ver}
98 Requires:       ibus >= 1.5.2
99 Requires:       json-glib >= %{json_glib_ver}
100 Requires:       libcroco >= %{libcroco_ver}
101 Requires:       libsecret >= %{libsecret_ver}
102 Requires:       mutter >= %{mutter_ver}
103 Requires:       nautilus >= 3.8.0
104 Requires:       polkit >= %{polkit_ver}
105 Requires:       pulseaudio-libs >= %{pulseaudio_ver}
106 Requires:       startup-notification >= %{startup_notification_ver}
107 # gjs->gir->TelepathyGLib
108 Requires:       telepathy-glib >= 0.17.5
109 # gjs->gir->TelepathyLogger
110 Requires:       telepathy-logger-libs >= 0.2
111 Requires:       telepathy-mission-control
112 Suggests:       gnome-contacts >= 3.2.0
113 Suggests:       gnome-icon-theme-symbolic >= 3.8.0
114 Provides:       gdm-wm = 3.8.0
115 Obsoletes:      browser-plugin-gnome-shell < 3.32.2-1
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %description
119 GNOME Shell is the defining technology of the GNOME 3 desktop user
120 experience. It provides core interface functions like switching to
121 windows and launching applications. GNOME Shell takes advantage of the
122 capabilities of modern graphics hardware and introduces innovative
123 user interface concepts to provide a delightful and easy to use
124 experience.
125
126 %description -l pl.UTF-8
127 GNOME Shell to technologia definiująca doznania użytkownika środowiska
128 graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
129 przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
130 wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
131 innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
132 doznania i łatwość użycia.
133
134 %package devel
135 Summary:        Development files for GNOME Shell
136 Summary(pl.UTF-8):      Pliki programistyczne dla GNOME Shell
137 Group:          Development/Libraries
138
139 %description devel
140 This package provides development files for GNOME Shell.
141
142 %description devel -l pl.UTF-8
143 Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
144
145 %package apidocs
146 Summary:        GNOME Shell API documentation
147 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
148 Group:          Documentation
149 Requires:       gtk-doc-common
150 %{?noarchpackage}
151
152 %description apidocs
153 This package provides GNOME Shell API documentation.
154
155 %description apidocs -l pl.UTF-8
156 Ten pakiet dostarcza dokumentację API GNOME Shell.
157
158 %prep
159 %setup -q
160
161 %{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
162
163 %build
164 %meson build \
165         %{?with_apidocs:-Dgtk_doc=true}
166
167 %meson_build -C build
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
172
173 %meson_install -C build
174
175 # evolution already ships this file
176 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/evolution-calendar.desktop
177
178 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell*.a
179
180 %find_lang %{name}
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post
186 %glib_compile_schemas
187
188 %postun
189 if [ "$1" = "0" ]; then
190         %glib_compile_schemas
191 fi
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc NEWS README.md
196 %attr(755,root,root) %{_bindir}/gnome-extensions
197 %attr(755,root,root) %{_bindir}/gnome-extensions-app
198 %attr(755,root,root) %{_bindir}/gnome-shell
199 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
200 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
201 %attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
202 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
203 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
204 %attr(755,root,root) %{_libexecdir}/gnome-shell-overrides-migration.sh
205 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
206 %attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
207 %dir %{_libdir}/gnome-shell
208 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
209 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
210 %attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
211 %attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
212 %attr(755,root,root) %{_libdir}/gnome-shell/libst-1.0.so
213 %{_libdir}/gnome-shell/Gvc-1.0.typelib
214 %{_libdir}/gnome-shell/Shell-0.1.typelib
215 %{_libdir}/gnome-shell/St-1.0.typelib
216 %dir %{_libdir}/gnome-shell/girepository-1.0
217 %{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
218 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
219 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
220 %{_datadir}/dbus-1/services/org.gnome.Extensions.service
221 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
222 %{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
223 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
224 %{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
225 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
226 %{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
227 %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
228 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
229 %{_datadir}/gnome-control-center/keybindings/*.xml
230 %{_datadir}/gnome-shell
231 %{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
232 %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
233 %{_desktopdir}/org.gnome.Extensions.desktop
234 %{_desktopdir}/org.gnome.Shell.desktop
235 %{_desktopdir}/org.gnome.Shell.Extensions.desktop
236 %{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
237 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
238 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
239 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
240 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
241 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
242 %{_mandir}/man1/gnome-extensions.1*
243 %{_mandir}/man1/gnome-shell.1*
244 %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
245 %{systemduserunitdir}/org.gnome.Shell.target
246 %{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
247 %{systemduserunitdir}/org.gnome.Shell@wayland.service
248 %{systemduserunitdir}/org.gnome.Shell@x11.service
249
250 %files devel
251 %defattr(644,root,root,755)
252 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
253 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
254 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
255 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
256 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
257 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
258
259 %if %{with apidocs}
260 %files apidocs
261 %defattr(644,root,root,755)
262 %{_gtkdocdir}/shell
263 %{_gtkdocdir}/st
264 %endif
This page took 0.074104 seconds and 2 git commands to generate.