]> git.pld-linux.org Git - packages/gnome-keyring.git/blob - gnome-keyring.spec
a07660125b260523d77bc01ddb4163fcc25c99a2
[packages/gnome-keyring.git] / gnome-keyring.spec
1 # TODO
2 #  Aug 14 13:19:00 haarber gnome-keyring-daemon[6524]: couldn't list keyrings at: /etc/certs: Error opening directory '/etc/certs': Permission denied
3 #
4 # Conditional build:
5 %bcond_with     p11_tests       # PKCS#11 tests
6 #
7 Summary:        Keep passwords and other user's secrets
8 Summary(pl.UTF-8):      Przechowywanie haseł i innych tajnych danych użytkowników
9 Name:           gnome-keyring
10 Version:        3.28.0
11 Release:        1
12 License:        LGPL v2+ (library), GPL v2+ (programs)
13 Group:          X11/Applications
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-keyring/3.28/%{name}-%{version}.tar.xz
15 # Source0-md5:  b7481514065872bd1845609a2ef576c6
16 URL:            http://live.gnome.org/GnomeKeyring
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.12
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gcr-devel >= 3.28.0
21 BuildRequires:  gettext-tools >= 0.19.8
22 BuildRequires:  glib2-devel >= 1:2.44.0
23 BuildRequires:  libcap-ng-devel
24 BuildRequires:  libgcrypt-devel >= 1.2.2
25 BuildRequires:  libselinux-devel
26 # for some test only
27 BuildRequires:  libtasn1-devel >= 0.3.4
28 BuildRequires:  libtool
29 BuildRequires:  p11-kit-devel >= 0.16
30 %{?with_p11_tests:BuildRequires:        p11-tests-devel >= 0.1}
31 BuildRequires:  pam-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpmbuild(macros) >= 1.592
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 Requires(post,postun):  glib2 >= 1:2.38.0
37 Requires:       filesystem >= 4.0-28
38 Requires:       gcr >= 3.28.0
39 Requires:       glib2 >= 1:2.44.0
40 Requires:       hicolor-icon-theme
41 Requires:       p11-kit >= 0.16
42 Conflicts:      rpm < 4.4.2-0.2
43 # sr@Latn vs. sr@latin
44 Conflicts:      glibc-misc < 6:2.7
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _libexecdir     %{_libdir}/%{name}
48
49 %description
50 GNOME Keyring is a program that keeps password and other secrets for
51 users. It is run as a daemon in the session, similar to ssh-agent, and
52 other applications can locate it by an environment variable.
53
54 %description -l pl.UTF-8
55 GNOME Keyring to program do przechowywania haseł i innych tajnych
56 danych użytkowników. Działa jako demon w sesji, podobnie do
57 ssh-agenta, a inne aplikacje mogą znaleźć go poprzez zmienną
58 środowiskową.
59
60 %package -n pam-pam_gnome_keyring
61 Summary:        A PAM module for unlocking keyrings at login time
62 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów kluczy w czasie logowania
63 License:        LGPL v2+
64 Group:          Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Obsoletes:      gnome-keyring-pam
67
68 %description -n pam-pam_gnome_keyring
69 A PAM module that can automatically unlock the "login" keyring when
70 the user logs in and start the keyring daemon.
71
72 %description -n pam-pam_gnome_keyring -l pl.UTF-8
73 Moduł PAM, który może automatycznie odblokowywać zbiór kluczy "login"
74 w czasie logowania użytkownika i uruchamiania demona keyring.
75
76 %prep
77 %setup -q
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --disable-silent-rules \
87         %{!?with_p11_tests:--disable-p11-tests} \
88         --with-pam-dir=/%{_lib}/security
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install install-pam \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_gnome_keyring.la
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pkcs11/gnome-keyring-pkcs11.la
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/devel/*.la
100
101 %find_lang %{name}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 %glib_compile_schemas
108
109 %postun
110 %glib_compile_schemas
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README
115 %attr(755,root,root) %{_bindir}/gnome-keyring
116 %attr(755,root,root) %{_bindir}/gnome-keyring-3
117 %attr(755,root,root) %{_bindir}/gnome-keyring-daemon
118 %attr(755,root,root) %{_libdir}/pkcs11/gnome-keyring-pkcs11.so
119 %dir %{_libdir}/%{name}
120 %dir %{_libdir}/%{name}/devel
121 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-gnome2-store-standalone.so
122 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-secret-store-standalone.so
123 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-ssh-store-standalone.so
124 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-xdg-store-standalone.so
125 %{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
126 %{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
127 %{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
128 %{_datadir}/GConf/gsettings/org.gnome.crypto.cache.convert
129 %{_datadir}/dbus-1/services/org.freedesktop.secrets.service
130 %{_datadir}/dbus-1/services/org.gnome.keyring.service
131 %{_datadir}/glib-2.0/schemas/org.gnome.crypto.cache.gschema.xml
132 %{_mandir}/man1/gnome-keyring.1*
133 %{_mandir}/man1/gnome-keyring-3.1*
134 %{_mandir}/man1/gnome-keyring-daemon.1*
135
136 %files -n pam-pam_gnome_keyring
137 %defattr(644,root,root,755)
138 %attr(755,root,root) /%{_lib}/security/pam_gnome_keyring.so
This page took 0.023964 seconds and 2 git commands to generate.