]> git.pld-linux.org Git - packages/gnome-games.git/blob - gnome-games.spec
- more %%{__make} macros.
[packages/gnome-games.git] / gnome-games.spec
1 Summary:        GNOME games
2 Summary(es):    Juegos de GNOME
3 Summary(fr):    Jeux pour GNOME
4 Summary(pl):    GNOME - Gry
5 Summary(wa):    Djeus po GNOME
6 Name:           gnome-games
7 Version:        1.2.0
8 Release:        1
9 License:        LGPL
10 Group:          X11/GNOME
11 Group(pl):      X11/GNOME
12 Source0:        ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-games/%{name}-%{version}.tar.gz
13 Patch0:         gnome-games-DESTDIR.patch
14 Icon:           gnome-games.gif
15 BuildRequires:  ORBit >= 0.4.3
16 BuildRequires:  audiofile-devel >= 0.1.5
17 BuildRequires:  automake
18 BuildRequires:  esound-devel >= 0.2.7
19 BuildRequires:  gnome-libs-devel >= 1.0.0
20 BuildRequires:  gtk+-devel >= 1.2.0
21 BuildRequires:  guile-devel >= 1.3
22 BuildRequires:  ncurses-devel >= 5.0
23 BuildRequires:  readline-devel
24 URL:            http://www.gnome.org/
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      gnome
27
28 %define         _prefix         /usr/X11R6
29 %define         _sysconfdir     /etc/X11/GNOME
30 %define         _localstatedir  /var
31
32 %description
33 GNOME games.
34
35 GNOME is the GNU Network Object Model Environment. That's a fancy name
36 but really GNOME is a nice GUI desktop environment. It makes using
37 your computer easy, powerful, and easy to configure.
38
39 %description -l pl
40 Gry pod GNOME.
41
42 %package devel
43 Summary:        GNOME games libraries - header files
44 Summary(pl):    Pliki nag³ówkowedo tworzenia programów opartych o GNOME games
45 Group:          X11/GNOME/Development/Libraries
46 Group(pl):      X11/GNOME/Programowanie/Biblioteki
47 Requires:       %{name} = %{version}
48 Requires:       gtk+-devel
49
50 %description devel
51 GNOME games libraries - header files.
52
53 Right now this is just stuff to develop care games. I think.
54
55 %description -l pl devel
56 Pliki nag³ówkowedo tworzenia programów opartych o GNOME games.
57
58 %package static
59 Summary:        GNOME games static libraries
60 Summary(pl):    Biblioteki statyczne do GNOME games
61 Group:          X11/GNOME/Development/Libraries
62 Group(pl):      X11/GNOME/Programowanie/Biblioteki
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 GNOME games static libraries.
67
68 %description static
69 Biblioteki statyczne do GNOME games
70
71 %prep
72 %setup -q
73 %patch -p1
74
75 %build
76 gettextize --copy --force
77 automake
78 LDFLAGS="-s"; export LDFLAGS
79 %configure 
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         Gamesdir=%{_applnkdir}/Games
89
90 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*so.*.* \
91         $RPM_BUILD_ROOT%{_libdir}/gnome-stones/objects/lib*.so*
92
93 gzip -9nf AUTHORS ChangeLog NEWS README
94
95 %find_lang %{name} --with-gnome --all-name
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc AUTHORS.gz ChangeLog.gz NEWS.gz README.gz
106 %config %{_sysconfdir}/sound/events/*
107
108 %attr(755,root,root) %{_bindir}/GnomeScott
109 %attr(755,root,root) %{_bindir}/ctali
110 %attr(755,root,root) %{_bindir}/freecell
111 %attr(755,root,root) %{_bindir}/gataxx
112 %attr(755,root,root) %{_bindir}/sol
113 %attr(2755,root,games) %{_bindir}/glines
114 %attr(2755,root,games) %{_bindir}/gnibbles
115 %attr(2755,root,games) %{_bindir}/gnobots2
116 %attr(2755,root,games) %{_bindir}/gnome-stones
117 %attr(2755,root,games) %{_bindir}/gnome-xbill
118 %attr(2755,root,games) %{_bindir}/gnometris
119 %attr(2755,root,games) %{_bindir}/gnomine
120 %attr(2755,root,games) %{_bindir}/gnotravex
121 %attr(2755,root,games) %{_bindir}/gnotski
122 %attr(2755,root,games) %{_bindir}/gtali
123 %attr(2755,root,games) %{_bindir}/gturing
124 %attr(2755,root,games) %{_bindir}/iagno
125 %attr(2755,root,games) %{_bindir}/mahjongg
126 %attr(2755,root,games) %{_bindir}/same-gnome
127
128
129 %attr(755,root,root) %{_libdir}/lib*.so.*.*
130 %dir %{_libdir}/gnome-stones
131 %dir %{_libdir}/gnome-stones/objects
132 %attr(755,root,root) %{_libdir}/gnome-stones/objects/lib*.so*
133 %attr(755,root,root) %{_libdir}/gnome-stones/objects/lib*.la
134
135 %{_datadir}/gnibbles
136 %{_datadir}/gnobots2
137 %{_datadir}/gnome-stones
138 %{_datadir}/gturing
139 %{_datadir}/sol-games
140 %{_datadir}/xbill
141
142 %{_datadir}/gnome-stonesrc
143 %lang(ko) %{_datadir}/gnome-stonesrc.ko
144
145 %{_datadir}/mime-info/*
146 %{_datadir}/pixmaps/*
147 %{_datadir}/sounds/*
148
149 %{_applnkdir}/Games/*.desktop
150
151 %attr(664,root,games) %{_localstatedir}/games/*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/lib*.so
156 %attr(755,root,root) %{_libdir}/lib*.la
157 %{_includedir}/*
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/lib*.a
162 %{_libdir}/gnome-stones/objects/lib*.a
This page took 0.046599 seconds and 4 git commands to generate.