]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
679c0d82db3dc7e285e29f8ab435295a5d2ca34f
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4 #
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        0.2.10
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  9cdb88de911163980add38fad1e3df72
14 Patch0:         %{name}-pylint.patch
15 URL:            https://fedorahosted.org/abrt/
16 BuildRequires:  asciidoc
17 BuildRequires:  gettext-devel >= 0.17
18 BuildRequires:  gtk+3-devel >= 3.0
19 BuildRequires:  intltool >= 0.35.0
20 BuildRequires:  libreport-gtk-devel >= 2.0.19
21 %{?with_tests:BuildRequires:    libreport-python}
22 BuildRequires:  pkgconfig
23 %{?with_tests:BuildRequires:    pylint}
24 BuildRequires:  python-devel >= 1:2.7
25 BuildRequires:  python-pygobject3 >= 3.0
26 BuildRequires:  rpmbuild(macros) >= 1.596
27 BuildRequires:  xmlto
28 Requires(post,postun):  gtk-update-icon-cache
29 Requires:       hicolor-icon-theme
30 Requires:       libreport-python
31 Requires:       python-dbus
32 Requires:       python-inotify
33 Requires:       python-pygobject3
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 A GNOME application allows users to browse through detected problems
38 and provides them with convenient way for managing these problems.
39
40 %description -l pl.UTF-8
41 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
42 zapewniająca wygodny sposób zarządzania tymi problemami.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %build
49 %configure \
50         %{!?with_tests:PYLINT=/bin/true} \
51         --disable-silent-rules
52
53 %{__make}
54
55 %{?with_tests:%{__make} check}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gnome_abrt/wrappers/*.la
63 %py_postclean
64
65 # just a copy of cs
66 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/cs_CZ
67
68 %find_lang %{name}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 %update_icon_cache hicolor
75
76 %postun
77 %update_icon_cache hicolor
78
79 %files -f %{name}.lang
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_bindir}/gnome-abrt
82 %dir %{py_sitedir}/gnome_abrt
83 %{py_sitedir}/gnome_abrt/*.py[co]
84 %dir %{py_sitedir}/gnome_abrt/wrappers
85 %{py_sitedir}/gnome_abrt/wrappers/__init__.py[co]
86 %attr(755,root,root) %{py_sitedir}/gnome_abrt/wrappers/_wrappers.so
87 %{_datadir}/gnome-abrt
88 %{_desktopdir}/gnome-abrt.desktop
89 %{_iconsdir}/hicolor/*/apps/gnome-abrt.png
90 %{_iconsdir}/hicolor/*/status/gnome-abrt.png
91 %{_mandir}/man6/gnome-abrt.6*
This page took 0.053028 seconds and 3 git commands to generate.