]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- up to 2.13 (our own tarball until upstream generates one) auto/th/glibc-2_13-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 18 Jan 2011 07:33:29 +0000 (07:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    glibc-bug-12343.patch -> 1.2
    glibc-posix-sh.patch -> 1.3
    glibc.spec -> 1.890

glibc-bug-12343.patch [deleted file]
glibc-posix-sh.patch
glibc.spec

diff --git a/glibc-bug-12343.patch b/glibc-bug-12343.patch
deleted file mode 100644 (file)
index 3b443a9..0000000
+++ /dev/null
@@ -1,152 +0,0 @@
-From 4a531bb0b3b582cb693de9f76d2d97d970f9a5d5 Mon Sep 17 00:00:00 2001
-From: H.J. Lu <hongjiu.lu@intel.com>
-Date: Fri, 24 Dec 2010 20:14:37 -0500
-Subject: [PATCH 1/1] Remove `.ctors' and `.dtors' output sections
-
----
- ChangeLog                              |   15 ++
- config.h.in                            |    3 +
- configure                              |  334 +++++++++++++++++---------------
- configure.in                           |    2 +
- elf/sofini.c                           |    2 +
- elf/soinit.c                           |    2 +
- sysdeps/i386/init-first.c              |    2 +
- sysdeps/mach/hurd/i386/init-first.c    |    2 +-
- sysdeps/mach/hurd/powerpc/init-first.c |    2 +-
- sysdeps/sh/init-first.c                |    2 +
- sysdeps/unix/sysv/linux/init-first.c   |    2 +-
- 11 files changed, 209 insertions(+), 159 deletions(-)
-
-diff --git a/config.h.in b/config.h.in
-index 18bf01a..9e797eb 100644
---- a/config.h.in
-+++ b/config.h.in
-@@ -201,6 +201,9 @@
- /* Define if multi-arch DSOs should be generated.  */
- #undef USE_MULTIARCH
-+/* Define if `.ctors' and `.dtors' sections shouldn't be used.  */
-+#undef        NO_CTORS_DTORS_SECTIONS
-+
- /*
\f */
-diff --git a/configure.in b/configure.in
-index d8cd5f1..ad25b9b 100644
---- a/configure.in
-+++ b/configure.in
-@@ -1497,6 +1497,8 @@ EOF
-   rm -f conftest*])
-   if test $libc_cv_initfini_array != yes; then
-     AC_MSG_ERROR([Need linker with .init_array/.fini_array support.])
-+  elif AC_TRY_COMMAND([${CC-cc} -Wl,--verbose 2>&1|grep SORT_BY_INIT_PRIORITY 1>&AS_MESSAGE_LOG_FD]); then
-+    AC_DEFINE(NO_CTORS_DTORS_SECTIONS)
-   fi
-   AC_CACHE_CHECK(for libunwind-support in compiler,
-diff --git a/elf/sofini.c b/elf/sofini.c
-index 5e06f0c..13e74b7 100644
---- a/elf/sofini.c
-+++ b/elf/sofini.c
-@@ -1,12 +1,14 @@
- /* Finalizer module for ELF shared C library.  This provides terminating
-    null pointer words in the `.ctors' and `.dtors' sections.  */
-+#ifndef NO_CTORS_DTORS_SECTIONS
- static void (*const __CTOR_END__[1]) (void)
-      __attribute__ ((used, section (".ctors")))
-      = { 0 };
- static void (*const __DTOR_END__[1]) (void)
-      __attribute__ ((used, section (".dtors")))
-      = { 0 };
-+#endif
- /* Terminate the frame unwind info section with a 4byte 0 as a sentinel;
-    this would be the 'length' field in a real FDE.  */
-diff --git a/elf/soinit.c b/elf/soinit.c
-index 6fecbb5..1db676a 100644
---- a/elf/soinit.c
-+++ b/elf/soinit.c
-@@ -3,6 +3,7 @@
-    the `.ctors' and `.dtors' sections so the lists are terminated, and
-    calling those lists of functions.  */
-+#ifndef NO_CTORS_DTORS_SECTIONS
- #include <libc-internal.h>
- #include <stdlib.h>
-@@ -40,3 +41,4 @@ __libc_fini (void)
- void (*_fini_ptr) (void) __attribute__ ((section (".fini_array")))
-      = &__libc_fini;
-+#endif
-diff --git a/sysdeps/i386/init-first.c b/sysdeps/i386/init-first.c
-index c6355a8..2af042f 100644
---- a/sysdeps/i386/init-first.c
-+++ b/sysdeps/i386/init-first.c
-@@ -59,7 +59,9 @@ _init (int argc, ...)
- {
-   init (&argc);
-+#ifndef NO_CTORS_DTORS_SECTIONS
-   __libc_global_ctors ();
-+#endif
- }
- #endif
-diff --git a/sysdeps/mach/hurd/i386/init-first.c b/sysdeps/mach/hurd/i386/init-first.c
-index f9a7a58..60823bd 100644
---- a/sysdeps/mach/hurd/i386/init-first.c
-+++ b/sysdeps/mach/hurd/i386/init-first.c
-@@ -92,7 +92,7 @@ posixland_init (int argc, char **argv, char **envp)
-   __getopt_clean_environment (envp);
- #endif
--#ifdef SHARED
-+#if defined SHARED && !defined NO_CTORS_DTORS_SECTIONS
-   __libc_global_ctors ();
- #endif
- }
-diff --git a/sysdeps/mach/hurd/powerpc/init-first.c b/sysdeps/mach/hurd/powerpc/init-first.c
-index 20fa1d4..21b5054 100644
---- a/sysdeps/mach/hurd/powerpc/init-first.c
-+++ b/sysdeps/mach/hurd/powerpc/init-first.c
-@@ -82,7 +82,7 @@ posixland_init (int argc, char **argv, char **envp)
-   __getopt_clean_environment (__environ);
- #endif
--#ifdef SHARED
-+#if defined SHARED && !defined NO_CTORS_DTORS_SECTIONS
-   __libc_global_ctors ();
- #endif
- }
-diff --git a/sysdeps/sh/init-first.c b/sysdeps/sh/init-first.c
-index d816625..1f3a821 100644
---- a/sysdeps/sh/init-first.c
-+++ b/sysdeps/sh/init-first.c
-@@ -59,7 +59,9 @@ _init (int argc, ...)
- {
-   init (&argc);
-+#ifndef NO_CTORS_DTORS_SECTIONS
-   __libc_global_ctors ();
-+#endif
- }
- #endif
-diff --git a/sysdeps/unix/sysv/linux/init-first.c b/sysdeps/unix/sysv/linux/init-first.c
-index 7b2333d..a60212f 100644
---- a/sysdeps/unix/sysv/linux/init-first.c
-+++ b/sysdeps/unix/sysv/linux/init-first.c
-@@ -93,7 +93,7 @@ _init (int argc, char **argv, char **envp)
-   __getopt_clean_environment (envp);
- #endif
--#ifdef SHARED
-+#if defined SHARED && !defined NO_CTORS_DTORS_SECTIONS
-   __libc_global_ctors ();
- #endif
- }
--- 
-1.7.3.4
-
index ecdc314d428ff9dc74a002a51949e9f96c1ba7bc..ccf578225edc9e18503923fa878a9436ac864854 100644 (file)
@@ -3,7 +3,7 @@
 @@ -1,4 +1,4 @@
 -#! @BASH@
 +#! /bin/sh
- # Copyright (C) 1996-2008, 2009, 2010 Free Software Foundation, Inc.
+ # Copyright (C) 1996-2008, 2009, 2010, 2011 Free Software Foundation, Inc.
  # This file is part of the GNU C Library.
  
 @@ -36,16 +36,16 @@
@@ -14,7 +14,7 @@
 +    printf "Copyright (C) %s Free Software Foundation, Inc.
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- " "2010"
+ " "2011"
 -    printf $"Written by %s and %s.
 +    printf "Written by %s and %s.
  " "Roland McGrath" "Ulrich Drepper"
index 23b9ae09eec75d968ac39f8ad8ff307d26cd66b8..98ac0690653f663bbe57249e51cd21ae5b513033 100644 (file)
@@ -33,13 +33,14 @@ Summary(ru.UTF-8):  GNU libc версии
 Summary(tr.UTF-8):     GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
-Version:       2.12.2
+Version:       2.13
 Release:       1
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: e0043f4f8e1aa61acc62fdf0f4d6133d
+#Source0:      http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
+Source0:       %{name}-%{version}.tar.bz2
+# Source0-md5: 290b14e5ea57bafe19a637037519027c
 Source1:       http://ftp.gnu.org/gnu/glibc/%{name}-ports-%{ports_version}.tar.bz2
 # Source1-md5: cb01ab976180e98287cef5079e35359e
 Source2:       nscd.init
@@ -76,7 +77,6 @@ Patch27:      %{name}-i686.patch
 Patch29:       %{name}-arm-alignment-fix.patch
 Patch30:       %{name}-static-glro-init.patch
 Patch31:       %{name}-origin.patch
-Patch32:       %{name}-bug-12343.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf
@@ -924,7 +924,6 @@ mv %{name}-ports-%{ports_version} ports
 %patch29 -p1
 %patch30 -p1
 %patch31 -p1
-%patch32 -p1
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
This page took 1.480096 seconds and 4 git commands to generate.