]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- up to 2.30 auto/th/glibc-2.30-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 2 Aug 2019 10:20:03 +0000 (12:20 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 2 Aug 2019 10:20:03 +0000 (12:20 +0200)
branch.sh
glibc-locale_fixes.patch
glibc-resolv.patch [deleted file]
glibc.spec

index 59527550618d98dd7f38e38eb065272a406ec18a..5850c0a6c80a876397a2e535bc570b59cb871dba 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,8 +2,8 @@
 set -e
 url=git://sourceware.org/git/glibc.git
 package=glibc
-tag=glibc-2.29
-branch=release/2.29/master
+tag=glibc-2.30
+branch=release/2.30/master
 out=$package-git.patch
 repo=$package.git
 
index 0d991e41a6164b6535939b4e03fb7c01e60261bd..74c347a861fce714904371feb7ac88d9eb89ebbc 100644 (file)
  
  % Language name in Tsonga - "Xitsonga"
  lang_name "<U0058><U0069><U0074><U0073><U006F><U006E><U0067><U0061>"
---- glibc-2.27/localedata/locales/tt_RU.orig   2018-02-01 17:17:18.000000000 +0100
-+++ glibc-2.27/localedata/locales/tt_RU        2018-02-04 09:38:17.091084235 +0100
-@@ -317,14 +317,15 @@
+--- glibc-2.30/localedata/locales/tt_RU~       2019-08-01 06:29:31.000000000 +0200
++++ glibc-2.30/localedata/locales/tt_RU        2019-08-02 10:56:47.618233090 +0200
+@@ -253,14 +253,14 @@ name_fmt "???"
  END LC_NAME
  
  LC_ADDRESS
 -% FIXME
 -postal_fmt "???"
-+postal_fmt   "%f%N%a%N%d%N%b%N%s %h %e %r%N%z %T%N%c%N"
++postal_fmt "%f%N%a%N%d%N%b%N%s %h %e %r%N%z %T%N%c%N"
  % https://tt.wikipedia.org/wiki/%D0%A0%D1%83%D1%81%D0%B8%D1%8F : Русия
  country_name "<U0420><U0443><U0441><U0438><U044F>"
  country_ab2 "RU"
  country_ab3 "RUS"
  country_num 643
--country_car    "RUS"
-+country_car  "RUS"
+ country_car    "RUS"
 +country_isbn "5"
-+lang_name    "<U0422><U0430><U0442><U0430><U0440><U0447><U0430>"
+ lang_name    "<U0442><U0430><U0442><U0430><U0440>"
  lang_ab      "tt"
  lang_term    "tat"
- lang_lib    "tat"
 --- glibc-2.27/localedata/locales/tt_RU@iqtelif.orig   2018-02-02 19:23:56.302656077 +0100
 +++ glibc-2.27/localedata/locales/tt_RU@iqtelif        2018-02-04 09:39:34.111083357 +0100
 @@ -168,7 +168,12 @@
diff --git a/glibc-resolv.patch b/glibc-resolv.patch
deleted file mode 100644 (file)
index 73939d9..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
-commit 08504de71813ddbd447bfbca4a325cbe8ce8bcda
-Author: Florian Weimer <fweimer@redhat.com>
-Date:   Tue Mar 12 11:40:47 2019 +0100
-
-    resolv: Enable full ICMP errors for UDP DNS sockets [BZ #24047]
-    
-    The Linux kernel suppresses some ICMP error messages by default for
-    UDP sockets.  This commit enables full ICMP error reporting,
-    hopefully resulting in faster failover to working name servers.
-
-diff --git a/resolv/Makefile b/resolv/Makefile
-index 8f22e6a154..ebe1b733f2 100644
---- a/resolv/Makefile
-+++ b/resolv/Makefile
-@@ -105,7 +105,7 @@ libresolv-routines := res_comp res_debug \
-                     res_data res_mkquery res_query res_send           \
-                     inet_net_ntop inet_net_pton inet_neta base64      \
-                     ns_parse ns_name ns_netint ns_ttl ns_print        \
--                    ns_samedomain ns_date \
-+                    ns_samedomain ns_date res_enable_icmp \
-                     compat-hooks compat-gethnamaddr
- libanl-routines := gai_cancel gai_error gai_misc gai_notify gai_suspend \
-diff --git a/resolv/res_enable_icmp.c b/resolv/res_enable_icmp.c
-new file mode 100644
-index 0000000000..bdc9220f08
---- /dev/null
-+++ b/resolv/res_enable_icmp.c
-@@ -0,0 +1,37 @@
-+/* Enable full ICMP errors on a socket.
-+   Copyright (C) 2019 Free Software Foundation, Inc.
-+   This file is part of the GNU C Library.
-+
-+   The GNU C Library is free software; you can redistribute it and/or
-+   modify it under the terms of the GNU Lesser General Public
-+   License as published by the Free Software Foundation; either
-+   version 2.1 of the License, or (at your option) any later version.
-+
-+   The GNU C Library is distributed in the hope that it will be useful,
-+   but WITHOUT ANY WARRANTY; without even the implied warranty of
-+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-+   Lesser General Public License for more details.
-+
-+   You should have received a copy of the GNU Lesser General Public
-+   License along with the GNU C Library; if not, see
-+   <http://www.gnu.org/licenses/>.  */
-+
-+#include <errno.h>
-+#include <netinet/in.h>
-+#include <sys/socket.h>
-+
-+int
-+__res_enable_icmp (int family, int fd)
-+{
-+  int one = 1;
-+  switch (family)
-+    {
-+    case AF_INET:
-+      return setsockopt (fd, SOL_IP, IP_RECVERR, &one, sizeof (one));
-+    case AF_INET6:
-+      return setsockopt (fd, SOL_IPV6, IPV6_RECVERR, &one, sizeof (one));
-+    default:
-+      __set_errno (EAFNOSUPPORT);
-+      return -1;
-+    }
-+}
-diff --git a/resolv/res_send.c b/resolv/res_send.c
-index fa040c1198..0f6ec83a7b 100644
---- a/resolv/res_send.c
-+++ b/resolv/res_send.c
-@@ -943,6 +943,18 @@ reopen (res_state statp, int *terrno, int ns)
-                       return (-1);
-               }
-+              /* Enable full ICMP error reporting for this
-+                 socket.  */
-+              if (__res_enable_icmp (nsap->sa_family,
-+                                     EXT (statp).nssocks[ns]) < 0)
-+                {
-+                  int saved_errno = errno;
-+                  __res_iclose (statp, false);
-+                  __set_errno (saved_errno);
-+                  *terrno = saved_errno;
-+                  return -1;
-+                }
-+
-               /*
-                * On a 4.3BSD+ machine (client and server,
-                * actually), sending to a nameserver datagram
-diff --git a/resolv/resolv-internal.h b/resolv/resolv-internal.h
-index 6ab8f2af09..1500adc607 100644
---- a/resolv/resolv-internal.h
-+++ b/resolv/resolv-internal.h
-@@ -100,4 +100,10 @@ libc_hidden_proto (__inet_pton_length)
- /* Called as part of the thread shutdown sequence.  */
- void __res_thread_freeres (void) attribute_hidden;
-+/* The Linux kernel does not enable all ICMP messages on a UDP socket
-+   by default.  A call this function enables full error reporting for
-+   the socket FD.  FAMILY must be AF_INET or AF_INET6.  Returns 0 on
-+   success, -1 on failure.  */
-+int __res_enable_icmp (int family, int fd) attribute_hidden;
-+
- #endif  /* _RESOLV_INTERNAL_H */
index 90c082b1abb948d5080d6c29d9aca84039462a75..d1bc92878c23ec26a72d12753bd0d14cc7a7fd2c 100644 (file)
@@ -31,7 +31,7 @@
 %undefine      with_cet
 %endif
 
-%define                core_version    2.29
+%define                core_version    2.30
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -45,12 +45,12 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       9
+Release:       1
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: e6c279d5b2f0736f740216f152acf974
+# Source0-md5: 2b1dbdf27b28620752956c061d62f60c
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -62,7 +62,7 @@ Source7:      %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
 Patch0:                glibc-git.patch
-# Patch0-md5:  0a7e1929c62d74e1b45576b570c7528b
+# Patch0-md5:  631851a21a95b83264681ad801bf34fd
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -86,7 +86,6 @@ Patch18:      %{name}-locale_fixes.patch
 Patch19:       %{name}-ZA_collate.patch
 
 Patch23:       %{name}-pt_pax.patch
-Patch24:       %{name}-resolv.patch
 
 # http://pkgs.fedoraproject.org/cgit/rpms/glibc.git/plain/glibc-c-utf8-locale.patch
 Patch27:       %{name}-c-utf8-locale.patch
@@ -968,7 +967,6 @@ exit 1
 %patch19 -p1
 
 %patch23 -p0
-%patch24 -p1
 
 %patch27 -p1
 
This page took 0.068873 seconds and 4 git commands to generate.