]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- partial 2.15 update (own tarball since no upstream tarball available)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 26 Dec 2011 19:08:10 +0000 (19:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    glibc-git.patch -> 1.11
    glibc-paths.patch -> 1.4
    glibc-pr12892.patch -> 1.2
    glibc.spec -> 1.941

glibc-git.patch [deleted file]
glibc-paths.patch
glibc-pr12892.patch [deleted file]
glibc.spec

diff --git a/glibc-git.patch b/glibc-git.patch
deleted file mode 100644 (file)
index c3b0876..0000000
+++ /dev/null
@@ -1,450 +0,0 @@
-commit 6e502e19455c6110dd4487d91b7b7d6d8121f9ba
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Wed Jun 22 08:32:55 2011 -0400
-
-    Clean up after kernel sigcontext header mess
-
-diff --git a/sysdeps/unix/sysv/linux/bits/sigcontext.h b/sysdeps/unix/sysv/linux/bits/sigcontext.h
-index 67dcf94..0f5b607 100644
---- a/sysdeps/unix/sysv/linux/bits/sigcontext.h
-+++ b/sysdeps/unix/sysv/linux/bits/sigcontext.h
-@@ -1,4 +1,4 @@
--/* Copyright (C) 1996, 1997, 1998 Free Software Foundation, Inc.
-+/* Copyright (C) 1996, 1997, 1998, 2011 Free Software Foundation, Inc.
-    This file is part of the GNU C Library.
-    The GNU C Library is free software; you can redistribute it and/or
-@@ -26,4 +26,8 @@
- # define sigcontext_struct sigcontext
- # include <asm/sigcontext.h>
-+
-+/* The Linux kernel headers redefine NULL wrongly, so cleanup afterwards.  */
-+# define __need_NULL
-+# include <stddef.h>
- #endif
-commit 852eb34d5c56bc75bdd82327fcf310d98655f6b0
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Wed Jun 22 09:50:39 2011 -0400
-
-    Rate limit expensive _SC_NPROCESSORS_ONLN computation
-
-diff --git a/sysdeps/unix/sysv/linux/getsysstats.c b/sysdeps/unix/sysv/linux/getsysstats.c
-index af454b6..a13b6e3 100644
---- a/sysdeps/unix/sysv/linux/getsysstats.c
-+++ b/sysdeps/unix/sysv/linux/getsysstats.c
-@@ -1,5 +1,5 @@
- /* Determine various system internal values, Linux version.
--   Copyright (C) 1996-2003,2006,2007,2009,2010 Free Software Foundation, Inc.
-+   Copyright (C) 1996-2003,2006,2007,2009,2010,2011 Free Software Foundation, Inc.
-    This file is part of the GNU C Library.
-    Contributed by Ulrich Drepper <drepper@cygnus.com>, 1996.
-@@ -35,6 +35,16 @@
- #include <atomic.h>
- #include <not-cancel.h>
-+#include <kernel-features.h>
-+
-+#ifndef HAVE_CLOCK_GETTIME_VSYSCALL
-+# undef INTERNAL_VSYSCALL
-+# define INTERNAL_VSYSCALL INTERNAL_SYSCALL
-+# undef INLINE_VSYSCALL
-+# define INLINE_VSYSCALL INLINE_SYSCALL
-+#else
-+# include <bits/libc-vdso.h>
-+#endif
- /* How we can determine the number of available processors depends on
-@@ -128,6 +138,22 @@ next_line (int fd, char *const buffer, char **cp, char **re,
- int
- __get_nprocs ()
- {
-+  static int cached_result;
-+  static time_t timestamp;
-+
-+#ifdef __ASSUME_POSIX_TIMERS
-+  struct timespec ts;
-+  INTERNAL_SYSCALL_DECL (err);
-+  INTERNAL_VSYSCALL (clock_gettime, err, 2, CLOCK_REALTIME, &ts);
-+#else
-+  struct timeval ts;
-+  gettimeofday (&ts, NULL);
-+#endif
-+  time_t prev = timestamp;
-+  atomic_read_barrier ();
-+  if (ts.tv_sec == prev)
-+    return cached_result;
-+
-   /* XXX Here will come a test for the new system call.  */
-   const size_t buffer_size = __libc_use_alloca (8192) ? 8192 : 512;
-@@ -169,6 +195,10 @@ __get_nprocs ()
-       }
-     }
-+  cached_result = result;
-+  atomic_write_barrier ();
-+  timestamp = ts.tv_sec;
-+
-   return result;
- }
- weak_alias (__get_nprocs, get_nprocs)
-commit 84e2a551a72c79b020694bb327e33b6d71b09b63
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Wed Jun 22 10:32:07 2011 -0400
-
-    Use a /sys/devices/system/cpu/online for _SC_NPROCESSORS_ONLN implementation
-
-diff --git a/sysdeps/unix/sysv/linux/getsysstats.c b/sysdeps/unix/sysv/linux/getsysstats.c
-index a13b6e3..b74774f 100644
---- a/sysdeps/unix/sysv/linux/getsysstats.c
-+++ b/sysdeps/unix/sysv/linux/getsysstats.c
-@@ -161,20 +161,65 @@ __get_nprocs ()
-   char *buffer_end = buffer + buffer_size;
-   char *cp = buffer_end;
-   char *re = buffer_end;
--  int result = 1;
- #ifdef O_CLOEXEC
-   const int flags = O_RDONLY | O_CLOEXEC;
- #else
-   const int flags = O_RDONLY;
- #endif
-+  int fd = open_not_cancel_2 ("/sys/devices/system/cpu/online", flags);
-+  char *l;
-+  int result = 0;
-+  if (fd != -1)
-+    {
-+      l = next_line (fd, buffer, &cp, &re, buffer_end);
-+      if (l != NULL)
-+      do
-+        {
-+          char *endp;
-+          unsigned long int n = strtoul (l, &endp, 10);
-+          if (l == endp)
-+            {
-+              result = 0;
-+              break;
-+            }
-+
-+          unsigned long int m = n;
-+          if (*endp == '-')
-+            {
-+              l = endp + 1;
-+              m = strtoul (l, &endp, 10);
-+              if (l == endp)
-+                {
-+                  result = 0;
-+                  break;
-+                }
-+            }
-+
-+          result += m - n + 1;
-+
-+          l = endp;
-+          while (l < re && isspace (*l))
-+            ++l;
-+        }
-+      while (l < re);
-+
-+      close_not_cancel_no_status (fd);
-+
-+      if (result > 0)
-+      goto out;
-+    }
-+
-+  cp = buffer_end;
-+  re = buffer_end;
-+  result = 1;
-+
-   /* The /proc/stat format is more uniform, use it by default.  */
--  int fd = open_not_cancel_2 ("/proc/stat", flags);
-+  fd = open_not_cancel_2 ("/proc/stat", flags);
-   if (fd != -1)
-     {
-       result = 0;
--      char *l;
-       while ((l = next_line (fd, buffer, &cp, &re, buffer_end)) != NULL)
-       /* The current format of /proc/stat has all the cpu* entries
-          at the front.  We assume here that stays this way.  */
-@@ -195,6 +240,7 @@ __get_nprocs ()
-       }
-     }
-+ out:
-   cached_result = result;
-   atomic_write_barrier ();
-   timestamp = ts.tv_sec;
-commit 2d4fa81e11abc464b5b1f6417525285e84ff787c
-Author: Roland McGrath <roland@hack.frob.com>
-Date:   Sat Jun 11 03:41:23 2011 -0700
-
-    Consolidate shlib.lds references in new variables.
-
-diff --git a/Makerules b/Makerules
-index 6b4b0e1..d3cb4cc 100644
---- a/Makerules
-+++ b/Makerules
-@@ -514,8 +514,11 @@ $(common-objpfx)shlib.lds: $(common-objpfx)config.make $(..)Makerules
-       mv -f $@T $@
- common-generated += shlib.lds
-+shlib-lds = $(common-objpfx)shlib.lds
-+shlib-lds-flags = -T $(shlib-lds)
-+
- define build-shlib
--$(build-shlib-helper) -o $@ -T $(common-objpfx)shlib.lds \
-+$(build-shlib-helper) -o $@ $(shlib-lds-flags) \
-         $(csu-objpfx)abi-note.o $(build-shlib-objlist)
- endef
- else
-@@ -557,11 +560,11 @@ ifeq (yes,$(elf))
- # binutils only position loadable notes into the first page for binaries,
- # not for shared objects
- define build-module
--$(build-module-helper) -o $@ -T $(common-objpfx)shlib.lds \
-+$(build-module-helper) -o $@ $(shlib-lds-flags) \
-         $(csu-objpfx)abi-note.o $(build-module-objlist)
- endef
- define build-module-asneeded
--$(build-module-helper) -o $@ -T $(common-objpfx)shlib.lds \
-+$(build-module-helper) -o $@ $(shlib-lds-flags) \
-         $(csu-objpfx)abi-note.o \
-         -Wl,--as-needed $(build-module-objlist) -Wl,--no-as-needed
- endef
-@@ -618,7 +621,7 @@ $(common-objpfx)libc.so: $(elfobjdir)/soinit.os \
-                        $(common-objpfx)libc_pic.os \
-                        $(elfobjdir)/sofini.os \
-                        $(elfobjdir)/interp.os $(elfobjdir)/ld.so \
--                       $(common-objpfx)shlib.lds
-+                       $(shlib-lds)
-       $(build-shlib)
- ifeq ($(versioning),yes)
- $(common-objpfx)libc.so: $(common-objpfx)libc.map
-@@ -689,7 +692,7 @@ include $(patsubst %,$(..)extra-modules.mk,$(modules-names))
- extra-modules-build := $(filter-out $(modules-names-nobuild),$(modules-names))
- $(extra-modules-build:%=$(objpfx)%.so): $(objpfx)%.so: \
--              $(objpfx)%.os $(common-objpfx)shlib.lds \
-+              $(objpfx)%.os $(shlib-lds) \
-               $(common-objpfx)libc.so $(common-objpfx)libc_nonshared.a
-       $(build-module)
- endif
-diff --git a/iconvdata/extra-module.mk b/iconvdata/extra-module.mk
-index 163074f..43f4e12 100644
---- a/iconvdata/extra-module.mk
-+++ b/iconvdata/extra-module.mk
-@@ -4,7 +4,7 @@ extra-modules-left := $(strip $(filter-out $(mod),$(extra-modules-left)))
- extra-objs := $(extra-objs) $(patsubst %,%.os,$($(mod)-routines))
- $(objpfx)$(mod).so: $(addprefix $(objpfx),$(addsuffix .os,$($(mod)-routines)))\
--                  $(common-objpfx)shlib.lds
-+                  $(shlib-lds)
-       $(build-module-asneeded)
- # Depend on libc.so so a DT_NEEDED is generated in the shared objects.
-commit f781ef4015504e8a1da649c266584976238aa079
-Author: Roland McGrath <roland@hack.frob.com>
-Date:   Sat Jun 11 04:16:49 2011 -0700
-
-    Add --with-default-link configure option.
-
-diff --git a/Makerules b/Makerules
-index d3cb4cc..23d9f1c 100644
---- a/Makerules
-+++ b/Makerules
-@@ -479,6 +479,11 @@ endif
- endif
- ifeq (yes,$(elf))
-+ifeq (yes,$(use-default-link))
-+# If the linker is good enough, we can let it use its default linker script.
-+shlib-lds =
-+shlib-lds-flags =
-+else
- # binutils only position loadable notes into the first page for binaries,
- # not for shared objects
- $(common-objpfx)shlib.lds: $(common-objpfx)config.make $(..)Makerules
-@@ -516,6 +521,7 @@ common-generated += shlib.lds
- shlib-lds = $(common-objpfx)shlib.lds
- shlib-lds-flags = -T $(shlib-lds)
-+endif
- define build-shlib
- $(build-shlib-helper) -o $@ $(shlib-lds-flags) \
-diff --git a/config.make.in b/config.make.in
-index 0656b1b..34842bf 100644
---- a/config.make.in
-+++ b/config.make.in
-@@ -69,6 +69,7 @@ have-cc-with-libunwind = @libc_cv_cc_with_libunwind@
- fno-unit-at-a-time = @fno_unit_at_a_time@
- bind-now = @bindnow@
- have-hash-style = @libc_cv_hashstyle@
-+use-default-link = @use_default_link@
- static-libgcc = @libc_cv_gcc_static_libgcc@
-diff --git a/configure b/configure
-index 20e7340..e8ad775 100755
---- a/configure
-+++ b/configure
-@@ -696,6 +696,7 @@ force_install
- bindnow
- oldest_abi
- enable_check_abi
-+use_default_link
- with_cvs
- with_fp
- ac_ct_CXX
-@@ -770,6 +771,7 @@ with_selinux
- with_xcoff
- with_cvs
- with_headers
-+with_default_link
- enable_sanity_checks
- enable_check_abi
- enable_shared
-@@ -1464,6 +1466,7 @@ Optional Packages:
-   --without-cvs           if CVS should not be used
-   --with-headers=PATH     location of system headers to use (for example
-                           /usr/src/linux/include) [default=compiler default]
-+  --with-default-link     do not use explicit linker scripts [default=no]
-   --with-tls              enable support for TLS
-   --without-__thread      do not use TLS features even when supporting them
-   --with-cpu=CPU          select code for CPU variant
-@@ -3581,6 +3584,16 @@ else
- fi
-+
-+
-+# Check whether --with-default-link was given.
-+if test "${with_default_link+set}" = set; then :
-+  withval=$with_default_link; use_default_link=$withval
-+else
-+  use_default_link=no
-+fi
-+
-+
- # Check whether --enable-sanity-checks was given.
- if test "${enable_sanity_checks+set}" = set; then :
-   enableval=$enable_sanity_checks; enable_sanity=$enableval
-diff --git a/configure.in b/configure.in
-index f2b3921..f34aab3 100644
---- a/configure.in
-+++ b/configure.in
-@@ -114,6 +114,14 @@ AC_ARG_WITH([headers],
-           [sysheaders=$withval],
-           [sysheaders=''])
-+AC_SUBST(use_default_link)
-+AC_ARG_WITH([default-link],
-+          AC_HELP_STRING([--with-default-link],
-+                         [do not use explicit linker scripts
-+                          @<:@default=no@:>@]),
-+          [use_default_link=$withval],
-+          [use_default_link=no])
-+
- AC_ARG_ENABLE([sanity-checks],
-             AC_HELP_STRING([--disable-sanity-checks],
-                            [really do not use threads (should not be used except in special situations) @<:@default=yes@:>@]),
-commit 5c55070081c27168d27145afdf6a92cd56c9abb3
-Author: Roland McGrath <roland@hack.frob.com>
-Date:   Sat Jun 11 00:45:12 2011 -0700
-
-    Use linker --print-output-format option if available.
-
-diff --git a/Makerules b/Makerules
-index d70a196..a8b575c 100644
---- a/Makerules
-+++ b/Makerules
-@@ -990,10 +990,14 @@ install: $(inst_slibdir)/libc.so$(libc.so-version)
- $(common-objpfx)format.lds: $(..)scripts/output-format.sed \
-                           $(common-objpfx)config.make \
-                           $(common-objpfx)config.h $(..)Makerules
-+ifneq (unknown,$(output-format))
-+      echo > $@.new 'OUTPUT_FORMAT($(output-format))'
-+else
-       $(LINK.o) -shared $(sysdep-LDFLAGS) $(config-LDFLAGS) $(LDFLAGS.so) \
-                 -x c /dev/null -o $@.so -Wl,--verbose -v 2>&1 \
-       | sed -n -f $< > $@.new
-       rm -f $@.so
-+endif
-       mv -f $@.new $@
- common-generated += format.lds
-diff --git a/config.make.in b/config.make.in
-index b73b21e..407ebc1 100644
---- a/config.make.in
-+++ b/config.make.in
-@@ -70,6 +70,7 @@ fno-unit-at-a-time = @fno_unit_at_a_time@
- bind-now = @bindnow@
- have-hash-style = @libc_cv_hashstyle@
- use-default-link = @use_default_link@
-+output-format = @libc_cv_output_format@
- static-libgcc = @libc_cv_gcc_static_libgcc@
-diff --git a/configure b/configure
-index 2568345..55a4b30 100755
---- a/configure
-+++ b/configure
-@@ -647,6 +647,7 @@ libc_cv_have_initfini
- gnu89_inline
- libc_cv_ssp
- fno_unit_at_a_time
-+libc_cv_output_format
- libc_cv_hashstyle
- libc_cv_fpie
- libc_cv_z_execstack
-@@ -6703,6 +6704,24 @@ $as_echo "$libc_cv_hashstyle" >&6; }
- fi
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linker output format" >&5
-+$as_echo_n "checking linker output format... " >&6; }
-+if ${libc_cv_output_format+:} false; then :
-+  $as_echo_n "(cached) " >&6
-+else
-+  if libc_cv_output_format=`
-+${CC-cc} -nostartfiles -nostdlib -Wl,--print-output-format 2>&5`
-+then
-+  :
-+else
-+  libc_cv_output_format=
-+fi
-+test -n "$libc_cv_output_format" || libc_cv_output_format=unknown
-+fi
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_output_format" >&5
-+$as_echo "$libc_cv_output_format" >&6; }
-+
-+
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for -fno-toplevel-reorder -fno-section-anchors" >&5
- $as_echo_n "checking for -fno-toplevel-reorder -fno-section-anchors... " >&6; }
- if ${libc_cv_fno_toplevel_reorder+:} false; then :
-diff --git a/configure.in b/configure.in
-index 55e5649..a28cd70 100644
---- a/configure.in
-+++ b/configure.in
-@@ -1803,6 +1803,17 @@ EOF
-   AC_SUBST(libc_cv_hashstyle)
- fi
-+AC_CACHE_CHECK(linker output format, libc_cv_output_format, [dnl
-+if libc_cv_output_format=`
-+${CC-cc} -nostartfiles -nostdlib -Wl,--print-output-format 2>&AS_MESSAGE_LOG_FD`
-+then
-+  :
-+else
-+  libc_cv_output_format=
-+fi
-+test -n "$libc_cv_output_format" || libc_cv_output_format=unknown])
-+AC_SUBST(libc_cv_output_format)
-+
- AC_CACHE_CHECK(for -fno-toplevel-reorder -fno-section-anchors, libc_cv_fno_toplevel_reorder, [dnl
- cat > conftest.c <<EOF
- int foo;
index 9ab3c3dad92c97f745b3607d53492ae674cad9c3..101c553b520efebd8c995648ff72fa08ab09abd0 100644 (file)
@@ -19,7 +19,7 @@ diff -Naur glibc-2.2.3/sysdeps/unix/sysv/linux/paths.h glibc-2.2.3-p/sysdeps/uni
  /* Provide trailing slash, since mostly used for building pathnames. */
 --- glibc-2.3.4/nscd/nscd.h.orig       2004-10-15 23:13:19.000000000 +0200
 +++ glibc-2.3.4/nscd/nscd.h    2005-02-20 16:26:37.755491792 +0100
-@@ -91,10 +91,10 @@
+@@ -113,11 +113,11 @@ struct database_dyn
  
  
  /* Paths of the file for the persistent storage.  */
@@ -27,10 +27,12 @@ diff -Naur glibc-2.2.3/sysdeps/unix/sysv/linux/paths.h glibc-2.2.3-p/sysdeps/uni
 -#define _PATH_NSCD_GROUP_DB   "/var/db/nscd/group"
 -#define _PATH_NSCD_HOSTS_DB   "/var/db/nscd/hosts"
 -#define _PATH_NSCD_SERVICES_DB        "/var/db/nscd/services"
+-#define _PATH_NSCD_NETGROUP_DB        "/var/db/nscd/netgroup"
 +#define _PATH_NSCD_PASSWD_DB  "/var/lib/nscd/passwd"
 +#define _PATH_NSCD_GROUP_DB   "/var/lib/nscd/group"
 +#define _PATH_NSCD_HOSTS_DB   "/var/lib/nscd/hosts"
 +#define _PATH_NSCD_SERVICES_DB        "/var/lib/nscd/services"
++#define _PATH_NSCD_NETGROUP_DB        "/var/lib/nscd/netgroup"
  
  /* Path used when not using persistent storage.  */
  #define _PATH_NSCD_XYZ_DB_TMP "/var/run/nscd/dbXXXXXX"
diff --git a/glibc-pr12892.patch b/glibc-pr12892.patch
deleted file mode 100644 (file)
index a943bd7..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From d45c60c2feb38d95e7ad95af6edb39a6d5afba81 Mon Sep 17 00:00:00 2001
-From: Andreas Schwab <schwab@redhat.com>
-Date: Wed, 19 Oct 2011 17:13:56 +0200
-Subject: [PATCH] Preserve link time dependencies over relocation dependencies
-
---- a/elf/dl-fini.c
-+++ b/elf/dl-fini.c
-@@ -100,7 +100,17 @@ _dl_sort_fini (struct link_map **maps, size_t nmaps, char *used, Lmid_t ns)
-             /* Look through the relocation dependencies of the object.  */
-             while (m-- > 0)
-               if (__builtin_expect (relmaps[m] == thisp, 0))
--                goto move;
-+                {
-+                  /* If a cycle exists with a link time dependency,
-+                     preserve the latter.  */
-+                  struct link_map **runp = thisp->l_initfini;
-+                  if (runp != NULL)
-+                    while (*runp != NULL)
-+                      if (__builtin_expect (*runp++ == maps[k], 0))
-+                        goto ignore;
-+                  goto move;
-+                }
-+          ignore:;
-           }
-         --k;
-
index 08819737a7a4c978826c39676abe2efff00c78cf..3398fd3e3a1ba9aecbd5bd957b19d7ac78654cf0 100644 (file)
@@ -32,13 +32,14 @@ Summary(ru.UTF-8):  GNU libc версии
 Summary(tr.UTF-8):     GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
-Version:       2.14.1
-Release:       4
+Version:       2.15
+Release:       0.1
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 55501b8d037a4f1d330312b30fd6d4bc
+# Source0:     http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
+Source0:       %{name}-%{version}.tar.bz2
+# Source0-md5: 25e3a1f3722fbb7ac0d9dccfe4bdfefa
 Source1:       http://ftp.gnu.org/gnu/glibc/%{name}-ports-%{ports_version}.tar.xz
 # Source1-md5: 3b3afcb6b99fea9e3a2474cc4778ec88
 Source2:       nscd.init
@@ -83,9 +84,7 @@ Patch33:      0020_all_glibc-tweak-rfc1918-lookup.patch
 Patch35:       0055_all_glibc-2.12-static-shared-getpagesize.patch
 Patch37:       0061_all_glibc-2.13-static-memset.patch
 Patch38:       1055_all_glibc-resolv-dynamic.patch
-Patch39:       %{name}-git.patch
 Patch40:       %{name}-bad-fix.patch
-Patch41:       %{name}-pr12892.patch
 Patch42:       %{name}-pr13013.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
@@ -949,9 +948,9 @@ mv %{name}-ports-%{ports_version} ports
 
 %patch37 -p1
 %patch38 -p1
-%patch39 -p1
+
 %patch40 -p1
-%patch41 -p1
+
 %patch42 -p1
 
 # cleanup backups after patching
This page took 0.176196 seconds and 4 git commands to generate.