]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- added patch to force all nss required include dirs (both nss and nspr)
authorJan Palus <atler@pld-linux.org>
Sat, 27 Sep 2014 11:14:21 +0000 (13:14 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 27 Sep 2014 11:14:21 +0000 (13:14 +0200)
  instead of relying on nss-config (not sure though why pkg-config is
  not used in glibc)

glibc-nss_include_dirs.patch [new file with mode: 0644]
glibc.spec

diff --git a/glibc-nss_include_dirs.patch b/glibc-nss_include_dirs.patch
new file mode 100644 (file)
index 0000000..5e602f1
--- /dev/null
@@ -0,0 +1,29 @@
+--- configure.ac.orig  2014-09-27 12:55:02.445395745 +0200
++++ configure.ac       2014-09-27 12:55:39.848729357 +0200
+@@ -277,10 +277,7 @@
+             [nss_crypt=$enableval],
+             [nss_crypt=no])
+ if test x$nss_crypt = xyes; then
+-  nss_includes=-I$(nss-config --includedir 2>/dev/null)
+-  if test $? -ne 0; then
+-    AC_MSG_ERROR([cannot find include directory with nss-config])
+-  fi
++  nss_includes='-I/usr/include/nss -I/usr/include/nspr'
+   old_CFLAGS="$CFLAGS"
+   CFLAGS="$CFLAGS $nss_includes"
+   AC_COMPILE_IFELSE([AC_LANG_PROGRAM([typedef int PRBool;
+--- crypt/Makefile.orig        2014-09-27 13:04:28.422466311 +0200
++++ crypt/Makefile     2014-09-27 13:05:00.672466567 +0200
+@@ -37,9 +37,9 @@
+ endif
+ ifeq ($(nss-crypt),yes)
+-CPPFLAGS-sha256-crypt.c = -DUSE_NSS -I$(shell nss-config --includedir)
+-CPPFLAGS-sha512-crypt.c = -DUSE_NSS -I$(shell nss-config --includedir)
+-CPPFLAGS-md5-crypt.c = -DUSE_NSS -I$(shell nss-config --includedir)
++CPPFLAGS-sha256-crypt.c = -DUSE_NSS -I/usr/include/nss -I/usr/include/nspr
++CPPFLAGS-sha512-crypt.c = -DUSE_NSS -I/usr/include/nss -I/usr/include/nspr
++CPPFLAGS-md5-crypt.c = -DUSE_NSS -I/usr/include/nss -I/usr/include/nspr
+ LDLIBS-crypt.so = -lfreebl3
+ else
+ libcrypt-routines += md5 sha256 sha512
index 4cde171d67a0968ce548ca5fa7001d39e48650d3..5cdeb425bc6c6fab701059c593eef7fe0aa58819 100644 (file)
@@ -61,7 +61,7 @@ Patch5:               %{name}-sparc-softfp-gcc.patch
 Patch6:                %{name}-paths.patch
 Patch7:                1070_all_glibc-fadvise64_64.patch
 Patch8:                %{name}-missing-nls.patch
-
+Patch9:                %{name}-nss_include_dirs.patch
 Patch10:       %{name}-info.patch
 Patch11:       %{name}-autoconf.patch
 Patch12:       %{name}-format.patch
@@ -949,6 +949,7 @@ exit 1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p0
 
 %patch10 -p1
 %patch11 -p1
This page took 0.157621 seconds and 4 git commands to generate.