]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- rel 4; fix fpu performance hit auto/th/glibc-2.17-4 auto/ti/glibc-2.17-4
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 19 Mar 2013 17:48:09 +0000 (18:48 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 19 Mar 2013 17:48:09 +0000 (18:48 +0100)
glibc-git.patch [new file with mode: 0644]
glibc.spec

diff --git a/glibc-git.patch b/glibc-git.patch
new file mode 100644 (file)
index 0000000..ab801b0
--- /dev/null
@@ -0,0 +1,21 @@
+commit 0b57daebab36f59af1d2a02616ee636a7b13ba12
+Author: Siddhesh Poyarekar <siddhesh@redhat.com>
+Date:   Fri Jan 18 14:16:25 2013 +0530
+
+    Fix application of the exception mask
+    
+    Fixes BZ #14496.
+
+diff --git a/sysdeps/i386/fpu/fenv_private.h b/sysdeps/i386/fpu/fenv_private.h
+index 03f4c97..1f8336c 100644
+--- a/sysdeps/i386/fpu/fenv_private.h
++++ b/sysdeps/i386/fpu/fenv_private.h
+@@ -176,7 +176,7 @@ libc_feupdateenv_test_sse (fenv_t *e, int ex)
+   /* Raise SIGFPE for any new exceptions since the hold.  Expect that
+      the normal environment has all exceptions masked.  */
+-  if (__builtin_expect ((old_mxcsr >> 7) & cur_ex, 0))
++  if (__glibc_unlikely (~(old_mxcsr >> 7) & cur_ex))
+     __feraiseexcept (cur_ex);
+   /* Test for exceptions raised since the hold.  */
index 8b19ccbf56ef5866873dc3346b163142b780ea12..cdadb6de648f0a0e0a52886546c9730a6bb356b2 100644 (file)
@@ -35,7 +35,7 @@ Summary(tr.UTF-8):    GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       3
+Release:       4
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
@@ -64,7 +64,7 @@ Patch9:               %{name}-java-libc-wait.patch
 Patch10:       %{name}-info.patch
 Patch11:       %{name}-autoconf.patch
 Patch12:       %{name}-format.patch
-
+Patch13:       %{name}-git.patch
 Patch14:       %{name}-sparc-errno_fix.patch
 Patch15:       %{name}-new-charsets.patch
 Patch16:       %{name}-tzfile-noassert.patch
@@ -946,7 +946,7 @@ exit 1
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
-
+%patch13 -p1
 %patch14 -p0
 %patch15 -p1
 %patch16 -p1
This page took 0.184211 seconds and 4 git commands to generate.