]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- up to 2.14.1 (dso breakage patch needs some decision)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 Oct 2011 17:30:52 +0000 (17:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    glibc-bad-fix.patch -> 1.3
    glibc-bug-12684.patch -> 1.2
    glibc-git.patch -> 1.10
    glibc.spec -> 1.932

glibc-bad-fix.patch
glibc-bug-12684.patch [deleted file]
glibc-git.patch
glibc.spec

index 1f67b780eb361c8f9d7c14159fb7eeda3f064407..4b58ccfad82ab6280d55e301ba2a6b6d8f8703f5 100644 (file)
@@ -60,7 +60,7 @@ index 9e30594..3890d00 100644
    if (old_l_initfini != NULL)
 -      map->l_orig_initfini = old_l_initfini;
 +    _dl_scope_free (old_l_initfini);
- }
 diff --git a/elf/dl-libc.c b/elf/dl-libc.c
 index 7be9483..a13fce3 100644
 --- a/elf/dl-libc.c
diff --git a/glibc-bug-12684.patch b/glibc-bug-12684.patch
deleted file mode 100644 (file)
index 63c5b80..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-commit 4769ae77fc6c8dacea6476addb015c8797848cdd
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Mon May 30 22:48:47 2011 -0400
-
-    Handle DNS server failures in case of AF_UNSPEC lookups correctly
-
-diff --git a/ChangeLog b/ChangeLog
-index 31719ab..dd4ad9e 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -1,5 +1,10 @@
- 2011-05-30  Ulrich Drepper  <drepper@gmail.com>
-+      [BZ #12684]
-+      * resolv/res_send.c (__libc_res_nsend): Only go to the next name server
-+      if both request failed.
-+      (send_dg): In case of server errors clear resplen or *resplen2.
-+
-       [BZ #12454]
-       * elf/dl-deps.c (_dl_map_object_deps): Run initializer sorting only
-       when there are multiple maps.
-diff --git a/resolv/res_send.c b/resolv/res_send.c
-index 845b658..97142b7 100644
---- a/resolv/res_send.c
-+++ b/resolv/res_send.c
-@@ -549,7 +549,7 @@ __libc_res_nsend(res_state statp, const u_char *buf, int buflen,
-                                   ns, ansp, ansp2, nansp2, resplen2);
-                       if (n < 0)
-                               return (-1);
--                      if (n == 0)
-+                      if (n == 0 && (buf2 == NULL || resplen2 == 0))
-                               goto next_ns;
-               } else {
-                       /* Use datagrams. */
-@@ -559,7 +559,7 @@ __libc_res_nsend(res_state statp, const u_char *buf, int buflen,
-                                   ansp2, nansp2, resplen2);
-                       if (n < 0)
-                               return (-1);
--                      if (n == 0)
-+                      if (n == 0 && (buf2 == NULL || resplen2 == 0))
-                               goto next_ns;
-                       if (v_circuit)
-                         // XXX Check whether both requests failed or
-@@ -1275,10 +1275,14 @@ send_dg(res_state statp,
-                               (*thisresplenp > *thisanssizp)
-                               ? *thisanssizp : *thisresplenp);
--                      if (recvresp1 || (buf2 != NULL && recvresp2))
-+                      if (recvresp1 || (buf2 != NULL && recvresp2)) {
-+                        *resplen2 = 0;
-                         return resplen;
-+                      }
-                       if (buf2 != NULL)
-                         {
-+                          /* No data from the first reply.  */
-+                          resplen = 0;
-                           /* We are waiting for a possible second reply.  */
-                           if (hp->id == anhp->id)
-                             recvresp1 = 1;
-@@ -1344,7 +1348,7 @@ send_dg(res_state statp,
-               goto err_out;
-       }
-       else {
--              /* poll should not have returned > 0 in this case.  */
-+              /* poll should not have returned > 0 in this case.  */
-               abort ();
-       }
- }
index 7c0ddbcc9fb233bd9b071e304404124b8c58a040..c3b08765ee7e3772dcae9e12a91119ece1e79a51 100644 (file)
@@ -1,278 +1,3 @@
-commit c8fc0c91695b1c7003c7170861274161f9224817
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Tue May 31 08:45:44 2011 -0400
-
-    Don't free non-malloced memory and fix memory leak
-
-diff --git a/nscd/nscd_getserv_r.c b/nscd/nscd_getserv_r.c
-index de96a57..f9ef056 100644
---- a/nscd/nscd_getserv_r.c
-+++ b/nscd/nscd_getserv_r.c
-@@ -124,6 +124,7 @@ nscd_getserv_r (const char *crit, size_t critlen, const char *proto,
-         s_name = (char *) (&found->data[0].servdata + 1);
-         serv_resp = found->data[0].servdata;
-         s_proto = s_name + serv_resp.s_name_len;
-+        alloca_aliases_len = 1;
-         aliases_len = (uint32_t *) (s_proto + serv_resp.s_proto_len);
-         aliases_list = ((char *) aliases_len
-                         + serv_resp.s_aliases_cnt * sizeof (uint32_t));
-@@ -154,7 +155,9 @@ nscd_getserv_r (const char *crit, size_t critlen, const char *proto,
-                                    + (serv_resp.s_aliases_cnt
-                                       * sizeof (uint32_t)));
-             if (alloca_aliases_len)
--              tmp = __alloca (serv_resp.s_aliases_cnt * sizeof (uint32_t));
-+              tmp = alloca_account (serv_resp.s_aliases_cnt
-+                                    * sizeof (uint32_t),
-+                                    alloca_used);
-             else
-               {
-                 tmp = malloc (serv_resp.s_aliases_cnt * sizeof (uint32_t));
-@@ -249,8 +252,9 @@ nscd_getserv_r (const char *crit, size_t critlen, const char *proto,
-                                    + (serv_resp.s_aliases_cnt
-                                       * sizeof (uint32_t)));
-             if (alloca_aliases_len)
--              aliases_len = alloca (serv_resp.s_aliases_cnt
--                                    * sizeof (uint32_t));
-+              aliases_len = alloca_account (serv_resp.s_aliases_cnt
-+                                            * sizeof (uint32_t),
-+                                            alloca_used);
-             else
-               {
-                 aliases_len = malloc (serv_resp.s_aliases_cnt
-@@ -368,7 +372,11 @@ nscd_getserv_r (const char *crit, size_t critlen, const char *proto,
-       }
-       if (retval != -1)
--      goto retry;
-+      {
-+        if (!alloca_aliases_len)
-+          free (aliases_len);
-+        goto retry;
-+      }
-     }
-   if (!alloca_aliases_len)
-commit 8c29731192565b9c917d6b97db78dcd302283df8
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Tue May 31 14:23:01 2011 -0400
-
-    Fix typo in  stack guard setup code for old kernels
-
-diff --git a/sysdeps/unix/sysv/linux/dl-osinfo.h b/sysdeps/unix/sysv/linux/dl-osinfo.h
-index eb7fedc..28fce4f 100644
---- a/sysdeps/unix/sysv/linux/dl-osinfo.h
-+++ b/sysdeps/unix/sysv/linux/dl-osinfo.h
-@@ -81,7 +81,7 @@ _dl_setup_stack_chk_guard (void *dl_random)
-       {
-         ssize_t reslen = read_not_cancel (fd, ret.bytes + 1, filllen);
-         close_not_cancel_no_status (fd);
--        if (reslen == (ssize_) filllen)
-+        if (reslen == (ssize_t) filllen)
-           return ret.num;
-       }
- # endif
-;2011-06-10  Andreas Schwab  <schwab@redhat.com>
-;
-;      * sysdeps/posix/getaddrinfo.c (gaih_inet): Fix logic allocating
-;      tmpbuf.
-;
-diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
-index 1e017b2..469abe2 100644
---- a/sysdeps/posix/getaddrinfo.c
-+++ b/sysdeps/posix/getaddrinfo.c
-@@ -821,7 +821,7 @@ gaih_inet (const char *name, const struct gaih_service *service,
-         size_t tmpbuflen = 1024;
-         malloc_tmpbuf = !__libc_use_alloca (alloca_used + tmpbuflen);
-         assert (tmpbuf == NULL);
--        if (malloc_tmpbuf)
-+        if (!malloc_tmpbuf)
-           tmpbuf = alloca_account (tmpbuflen, alloca_used);
-         else
-           {
-commit 3d29045b5e8329d97693eda8d98f1d1e60b99c8f
-Author: H.J. Lu <hongjiu.lu@intel.com>
-Date:   Fri Jun 3 07:01:25 2011 -0400
-
-    Assume Intel Core i3/i5/i7 processor if AVX is available
-
-diff --git a/sysdeps/x86_64/multiarch/init-arch.c b/sysdeps/x86_64/multiarch/init-arch.c
-index 34ec2df..809d105 100644
---- a/sysdeps/x86_64/multiarch/init-arch.c
-+++ b/sysdeps/x86_64/multiarch/init-arch.c
-@@ -74,6 +74,7 @@ __init_cpu_features (void)
-       }
-       else if (family == 0x06)
-       {
-+        ecx = __cpu_features.cpuid[COMMON_CPUID_INDEX_1].ecx;
-         model += extended_model;
-         switch (model)
-           {
-@@ -83,6 +84,12 @@ __init_cpu_features (void)
-             __cpu_features.feature[index_Slow_BSF] |= bit_Slow_BSF;
-             break;
-+          default:
-+            /* Unknown family 0x06 processors.  Assuming this is one
-+               of Core i3/i5/i7 processors if AVX is available.  */
-+            if ((ecx & bit_AVX) == 0)
-+              break;
-+
-           case 0x1a:
-           case 0x1e:
-           case 0x1f:
-commit c71ca1f89c6e89d8c4145e4c2fdcce2fc78812bd
-Author: Andreas Jaeger <aj@suse.de>
-Date:   Tue Jun 14 13:11:39 2011 -0700
-
-    Quash two memset undeclared warnings.
-
-diff --git a/nptl/pthread_rwlock_init.c b/nptl/pthread_rwlock_init.c
-index c0aa194..9ecd48c 100644
---- a/nptl/pthread_rwlock_init.c
-+++ b/nptl/pthread_rwlock_init.c
-@@ -1,4 +1,4 @@
--/* Copyright (C) 2002, 2007, 2009 Free Software Foundation, Inc.
-+/* Copyright (C) 2002,2007,2009,2011 Free Software Foundation, Inc.
-    This file is part of the GNU C Library.
-    Contributed by Ulrich Drepper <drepper@redhat.com>, 2002.
-@@ -18,6 +18,7 @@
-    02111-1307 USA.  */
- #include "pthreadP.h"
-+#include <string.h>
- #include <kernel-features.h>
-diff --git a/sysdeps/unix/sysv/linux/check_native.c b/sysdeps/unix/sysv/linux/check_native.c
-index 6e6624a..dedce34 100644
---- a/sysdeps/unix/sysv/linux/check_native.c
-+++ b/sysdeps/unix/sysv/linux/check_native.c
-@@ -1,5 +1,5 @@
- /* Determine whether interfaces use native transport.  Linux version.
--   Copyright (C) 2007 Free Software Foundation, Inc.
-+   Copyright (C) 2007,2011 Free Software Foundation, Inc.
-    This file is part of the GNU C Library.
-    The GNU C Library is free software; you can redistribute it and/or
-@@ -23,6 +23,7 @@
- #include <stddef.h>
- #include <stdint.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <time.h>
- #include <unistd.h>
- #include <net/if.h>
-commit c5e3c2ae59cc8c5d3ad5e1adfd099c726baad862
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Tue Jun 21 13:06:42 2011 -0400
-
-    Minor optimization of getaddrinfo after recent patch
-
-diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
-index 469abe2..d68ac83 100644
---- a/sysdeps/posix/getaddrinfo.c
-+++ b/sysdeps/posix/getaddrinfo.c
-@@ -565,7 +565,6 @@ gaih_inet (const char *name, const struct gaih_service *service,
-            IPv6 scope ids. */
-         if (req->ai_family == AF_INET)
-           {
--            int family = req->ai_family;
-             size_t tmpbuflen = 512;
-             assert (tmpbuf == NULL);
-             tmpbuf = alloca_account (tmpbuflen, alloca_used);
-@@ -576,7 +575,7 @@ gaih_inet (const char *name, const struct gaih_service *service,
-             while (1)
-               {
--                rc = __gethostbyname2_r (name, family, &th, tmpbuf,
-+                rc = __gethostbyname2_r (name, AF_INET, &th, tmpbuf,
-                                          tmpbuflen, &h, &herrno);
-                 if (rc != ERANGE || herrno != NETDB_INTERNAL)
-                   break;
-@@ -638,18 +637,9 @@ gaih_inet (const char *name, const struct gaih_service *service,
-                             (*pat)->scopeid = 0;
-                           }
-                         (*pat)->next = NULL;
--                        (*pat)->family = req->ai_family;
--                        if (family == req->ai_family)
--                          memcpy ((*pat)->addr, h->h_addr_list[i],
--                                  h->h_length);
--                        else
--                          {
--                            uint32_t *addr = (uint32_t *) (*pat)->addr;
--                            addr[3] = *(uint32_t *) h->h_addr_list[i];
--                            addr[2] = htonl (0xffff);
--                            addr[1] = 0;
--                            addr[0] = 0;
--                          }
-+                        (*pat)->family = AF_INET;
-+                        memcpy ((*pat)->addr, h->h_addr_list[i],
-+                                h->h_length);
-                         pat = &((*pat)->next);
-                       }
-                   }
-commit c0244a9dedce43a4b950d91451b16a7cf5408476
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Tue Jun 21 17:03:38 2011 -0400
-
-    Fix IPv6-only lookups through getaddrinfo
-    
-    A recent patch introduced a problem where IPv6 lookups happily returned
-    IPv4 addresses.
-
-diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
-index d68ac83..3a2737e 100644
---- a/sysdeps/posix/getaddrinfo.c
-+++ b/sysdeps/posix/getaddrinfo.c
-@@ -871,16 +871,44 @@ gaih_inet (const char *name, const struct gaih_service *service,
-                       }
-                   }
--                no_inet6_data = no_data;
--
-                 if (status == NSS_STATUS_SUCCESS)
-                   {
-+                    assert (!no_data);
-+                    no_data = 1;
-+
-                     if ((req->ai_flags & AI_CANONNAME) != 0 && canon == NULL)
-                       canon = (*pat)->name;
-                     while (*pat != NULL)
--                      pat = &((*pat)->next);
-+                      {
-+                        if ((*pat)->family == AF_INET
-+                            && req->ai_family == AF_INET6
-+                            && (req->ai_flags & AI_V4MAPPED) != 0)
-+                          {
-+                            uint32_t *pataddr = (*pat)->addr;
-+                            (*pat)->family = AF_INET6;
-+                            pataddr[3] = pataddr[0];
-+                            pataddr[2] = htonl (0xffff);
-+                            pataddr[1] = 0;
-+                            pataddr[0] = 0;
-+                            pat = &((*pat)->next);
-+                            no_data = 0;
-+                          }
-+                        else if ((*pat)->family == AF_UNSPEC
-+                                 || (*pat)->family == req->ai_family)
-+                          {
-+                            pat = &((*pat)->next);
-+
-+                            no_data = 0;
-+                            if (req->ai_family == AF_INET6)
-+                              got_ipv6 = true;
-+                          }
-+                        else
-+                          *pat = ((*pat)->next);
-+                      }
-                   }
-+
-+                no_inet6_data = no_data;
-               }
-             else
-               {
 commit 6e502e19455c6110dd4487d91b7b7d6d8121f9ba
 Author: Ulrich Drepper <drepper@gmail.com>
 Date:   Wed Jun 22 08:32:55 2011 -0400
@@ -453,145 +178,6 @@ index a13b6e3..b74774f 100644
    cached_result = result;
    atomic_write_barrier ();
    timestamp = ts.tv_sec;
-commit e12df166d37522c2ed434c2d70a1b04640d2d7c6
-Author: Andreas Schwab <schwab@redhat.com>
-Date:   Wed Jun 22 14:35:49 2011 -0400
-
-    Fix Ipv4&IPv6 lookup in getaddrinfo
-    
-    Problem introduced in the last patch.
-
-diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
-index 3a2737e..14e9270 100644
---- a/sysdeps/posix/getaddrinfo.c
-+++ b/sysdeps/posix/getaddrinfo.c
-@@ -894,7 +894,7 @@ gaih_inet (const char *name, const struct gaih_service *service,
-                             pat = &((*pat)->next);
-                             no_data = 0;
-                           }
--                        else if ((*pat)->family == AF_UNSPEC
-+                        else if (req->ai_family == AF_UNSPEC
-                                  || (*pat)->family == req->ai_family)
-                           {
-                             pat = &((*pat)->next);
-commit fa3fc0fe5f452d0aa7e435d8f32e992958683819
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Wed Jun 22 15:00:54 2011 -0400
-
-    Avoid __check_pf calls in getaddrinfo unless really needed
-
-diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
-index 14e9270..05c883d 100644
---- a/sysdeps/posix/getaddrinfo.c
-+++ b/sysdeps/posix/getaddrinfo.c
-@@ -2352,14 +2352,17 @@ getaddrinfo (const char *name, const char *service,
-   size_t in6ailen = 0;
-   bool seen_ipv4 = false;
-   bool seen_ipv6 = false;
--  /* We might need information about what interfaces are available.
--     Also determine whether we have IPv4 or IPv6 interfaces or both.  We
--     cannot cache the results since new interfaces could be added at
--     any time.  */
--  __check_pf (&seen_ipv4, &seen_ipv6, &in6ai, &in6ailen);
-+  bool check_pf_called = false;
-   if (hints->ai_flags & AI_ADDRCONFIG)
-     {
-+      /* We might need information about what interfaces are available.
-+       Also determine whether we have IPv4 or IPv6 interfaces or both.  We
-+       cannot cache the results since new interfaces could be added at
-+       any time.  */
-+      __check_pf (&seen_ipv4, &seen_ipv6, &in6ai, &in6ailen);
-+      check_pf_called = true;
-+
-       /* Now make a decision on what we return, if anything.  */
-       if (hints->ai_family == PF_UNSPEC && (seen_ipv4 || seen_ipv6))
-       {
-@@ -2441,6 +2444,10 @@ getaddrinfo (const char *name, const char *service,
-       struct addrinfo *last = NULL;
-       char *canonname = NULL;
-+      /* Now we definitely need the interface information.  */
-+      if (! check_pf_called)
-+      __check_pf (&seen_ipv4, &seen_ipv6, &in6ai, &in6ailen);
-+
-       /* If we have information about deprecated and temporary addresses
-        sort the array now.  */
-       if (in6ai != NULL)
-commit 034807a9cbddfa9e7d35df4cdb2ecce569a00851
-Author: Ulrich Drepper <drepper@gmail.com>
-Date:   Mon Jun 27 13:10:44 2011 -0400
-
-    Fix handling of RES_USE_INET6 big in nscd
-    
-    This fixes BZ #12350 also for nscd.
-
-diff --git a/nscd/aicache.c b/nscd/aicache.c
-index 3190a13..6c8d83a 100644
---- a/nscd/aicache.c
-+++ b/nscd/aicache.c
-@@ -534,7 +534,7 @@ next_nip:
-    }
-  out:
--  _res.options = old_res_options;
-+  _res.options |= old_res_options & RES_USE_INET6;
-   if (dataset != NULL && !alloca_used)
-     {
-commit 89f654c57b3b9a6aee480e25e37f88f06c898901
-Author: Andreas Schwab <schwab@redhat.com>
-Date:   Thu Jun 30 06:33:32 2011 -0400
-
-    Make sure RES_USE_INET6 is always restored
-
-diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
-index 05c883d..6d574c5 100644
---- a/sysdeps/posix/getaddrinfo.c
-+++ b/sysdeps/posix/getaddrinfo.c
-@@ -818,6 +818,7 @@ gaih_inet (const char *name, const struct gaih_service *service,
-             tmpbuf = malloc (tmpbuflen);
-             if (tmpbuf == NULL)
-               {
-+                _res.options |= old_res_options & RES_USE_INET6;
-                 result = -EAI_MEMORY;
-                 goto free_and_return;
-               }
-@@ -862,6 +863,7 @@ gaih_inet (const char *name, const struct gaih_service *service,
-                                               2 * tmpbuflen);
-                         if (newp == NULL)
-                           {
-+                            _res.options |= old_res_options & RES_USE_INET6;
-                             result = -EAI_MEMORY;
-                             goto free_and_return;
-                           }
-@@ -981,6 +983,8 @@ gaih_inet (const char *name, const struct gaih_service *service,
-                                     canonbuf = malloc (max_fqdn_len);
-                                     if (canonbuf == NULL)
-                                       {
-+                                        _res.options
-+                                          |= old_res_options & RES_USE_INET6;
-                                         result = -EAI_MEMORY;
-                                         goto free_and_return;
-                                       }
-commit 5e9b6af4a9bb2aad0e1929e88b52009d14cb6831
-Author: Roland McGrath <roland@hack.frob.com>
-Date:   Sat Jul 2 16:59:14 2011 -0700
-
-    Fail if format.lds comes out empty.
-
-diff --git a/Makerules b/Makerules
-index 3234fc2..d70a196 100644
---- a/Makerules
-+++ b/Makerules
-@@ -993,6 +993,7 @@ $(common-objpfx)format.lds: $(..)scripts/output-format.sed \
-       $(LINK.o) -shared $(sysdep-LDFLAGS) $(config-LDFLAGS) $(LDFLAGS.so) \
-                 -x c /dev/null -o $@.so -Wl,--verbose -v 2>&1 \
-       | sed -n -f $< > $@.new
-+      test -s $@.new
-       rm -f $@.so
-       mv -f $@.new $@
- common-generated += format.lds
 commit 2d4fa81e11abc464b5b1f6417525285e84ff787c
 Author: Roland McGrath <roland@hack.frob.com>
 Date:   Sat Jun 11 03:41:23 2011 -0700
@@ -776,7 +362,7 @@ diff --git a/Makerules b/Makerules
 index d70a196..a8b575c 100644
 --- a/Makerules
 +++ b/Makerules
-@@ -990,11 +990,15 @@ install: $(inst_slibdir)/libc.so$(libc.so-version)
+@@ -990,10 +990,14 @@ install: $(inst_slibdir)/libc.so$(libc.so-version)
  $(common-objpfx)format.lds: $(..)scripts/output-format.sed \
                            $(common-objpfx)config.make \
                            $(common-objpfx)config.h $(..)Makerules
@@ -786,7 +372,6 @@ index d70a196..a8b575c 100644
        $(LINK.o) -shared $(sysdep-LDFLAGS) $(config-LDFLAGS) $(LDFLAGS.so) \
                  -x c /dev/null -o $@.so -Wl,--verbose -v 2>&1 \
        | sed -n -f $< > $@.new
-       test -s $@.new
        rm -f $@.so
 +endif
        mv -f $@.new $@
index 222a162ffe26bbe2831cdc10e10d08a24e3fd601..5b9ab14c5877be7804f7101e7f1dd79f1502b571 100644 (file)
@@ -32,13 +32,13 @@ Summary(ru.UTF-8):  GNU libc версии
 Summary(tr.UTF-8):     GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
-Version:       2.14
-Release:       16
+Version:       2.14.1
+Release:       1.1
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 8f5f6b09f98d17c630819b4845e31e65
+# Source0-md5: 55501b8d037a4f1d330312b30fd6d4bc
 Source1:       http://ftp.gnu.org/gnu/glibc/%{name}-ports-%{ports_version}.tar.bz2
 # Source1-md5: 483f37cfdd619e81d8ca9e9d713944b5
 Source2:       nscd.init
@@ -85,8 +85,7 @@ Patch37:      0061_all_glibc-2.13-static-memset.patch
 Patch38:       1055_all_glibc-resolv-dynamic.patch
 Patch39:       %{name}-git.patch
 Patch40:       %{name}-bad-fix.patch
-Patch41:       %{name}-bug-12684.patch
-Patch42:       %{name}-revert-dso-breakout.patch
+Patch41:       %{name}-revert-dso-breakout.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf
@@ -952,9 +951,7 @@ mv %{name}-ports-%{ports_version} ports
 %patch39 -p1
 %patch40 -p1
 # revert broken fix
-%patch41 -p1 -R
-# revert broken fix
-%patch42 -p1
+%patch41 -p1
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
This page took 0.086263 seconds and 4 git commands to generate.