]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- more fixes from 2.22 branch
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 14 Sep 2015 09:07:14 +0000 (11:07 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 14 Sep 2015 09:07:14 +0000 (11:07 +0200)
glibc-git.patch

index e62ee57bfb8fe087e98c0633adc0f392bd574430..afb37ee583da539df31bb016eb54a2ad701cd87d 100644 (file)
@@ -1,8 +1,27 @@
 diff --git a/ChangeLog b/ChangeLog
-index cb9124e..f3027b0 100644
+index cb9124e..1c5ec45 100644
 --- a/ChangeLog
 +++ b/ChangeLog
-@@ -1,3 +1,69 @@
+@@ -1,3 +1,88 @@
++2015-09-11  Roland McGrath  <roland@hack.frob.com>
++
++      * sysdeps/nacl/Makefile [$(subdir) = misc] (sysdep_headers):
++      Use 'override' keyword to freeze the value here, preventing
++      the addition of sys/mtio.h by sysdeps/gnu/Makefile.
++
++2015-09-04  Roland McGrath  <roland@hack.frob.com>
++
++      [BZ #18921]
++      * sysdeps/posix/opendir.c (need_isdir_precheck) [O_DIRECTORY]:
++      Fix inverted sense of test of 'o_directory_works' value.
++      Reported by Pádraig Brady <P@draigBrady.com>, diagnosed by
++      Bernhard Voelker <mail@bernhard-voelker.de>.
++
++2015-08-31  Brett Neumeier <brett@neumeier.us>
++
++      [BZ #18870]
++      * sysdeps/sparc/sparc32/sem_open.c: Add missing #include
++
 +2015-08-28  Mike Frysinger  <vapier@gentoo.org>
 +
 +      [BZ #18887]
@@ -73,7 +92,7 @@ index cb9124e..f3027b0 100644
  
        * version.h (RELEASE): Set to "stable".
 diff --git a/NEWS b/NEWS
-index 4c31de7..2cfe5c1 100644
+index 4c31de7..d220c07 100644
 --- a/NEWS
 +++ b/NEWS
 @@ -5,6 +5,12 @@ See the end for copying conditions.
@@ -84,7 +103,7 @@ index 4c31de7..2cfe5c1 100644
 +
 +* The following bugs are resolved with this release:
 +
-+  18778, 18781, 18787, 18796, 18887.
++  18778, 18781, 18787, 18796, 18870, 18887, 18921.
 +\f
  Version 2.22
  
@@ -520,6 +539,24 @@ index b707c19..89d8baf 100644
      return (void *) value;
  }
 +rtld_hidden_def (_dl_symbol_address)
+diff --git a/sysdeps/nacl/Makefile b/sysdeps/nacl/Makefile
+index 6749a44..1748886 100644
+--- a/sysdeps/nacl/Makefile
++++ b/sysdeps/nacl/Makefile
+@@ -132,4 +132,13 @@ ifeq ($(subdir),misc)
+ # sysdeps/.../linux/ directories, but it's still a sysdeps decision to
+ # install it.
+ sysdep_headers += bits/mman-linux.h
++
++# This defeats sysdeps/gnu/Makefile's addition of sys/mtio.h, which
++# we do not want.  This is a total kludge, but it seems no worse for
++# now than making the sysdeps/gnu/Makefile code conditional on a
++# variable we set here.  If some sysdeps/.../Makefile that is later
++# in the list than sysdeps/gnu needed to add to sysdep_headers, this
++# would break it.  But sysdeps/gnu is close to last in the list and
++# this coming up seems unlikely.
++override sysdep_headers := $(sysdep_headers)
+ endif
 diff --git a/sysdeps/nacl/start.c b/sysdeps/nacl/start.c
 index a4b6dd3..8e8bc1a 100644
 --- a/sysdeps/nacl/start.c
@@ -544,6 +581,31 @@ index a4b6dd3..8e8bc1a 100644
                     nacl_startup_argc (info),
                     nacl_startup_argv (info),
                     nacl_startup_auxv (info),
+diff --git a/sysdeps/posix/opendir.c b/sysdeps/posix/opendir.c
+index 6509f5c..9edf056 100644
+--- a/sysdeps/posix/opendir.c
++++ b/sysdeps/posix/opendir.c
+@@ -105,7 +105,7 @@ need_isdir_precheck (void)
+     tryopen_o_directory ();
+   /* We can skip the expensive `stat' call if O_DIRECTORY works.  */
+-  return o_directory_works > 0;
++  return o_directory_works < 0;
+ #endif
+   return true;
+ }
+diff --git a/sysdeps/sparc/sparc32/sem_open.c b/sysdeps/sparc/sparc32/sem_open.c
+index 16cb9ad..59df2d7 100644
+--- a/sysdeps/sparc/sparc32/sem_open.c
++++ b/sysdeps/sparc/sparc32/sem_open.c
+@@ -29,6 +29,7 @@
+ #include <sys/mman.h>
+ #include <sys/stat.h>
+ #include "semaphoreP.h"
++#include <futex-internal.h>
+ #include <shm-directory.h>
 diff --git a/sysdeps/unix/sysv/linux/hppa/bits/atomic.h b/sysdeps/unix/sysv/linux/hppa/bits/atomic.h
 index abde83e..6e73504 100644
 --- a/sysdeps/unix/sysv/linux/hppa/bits/atomic.h
This page took 0.03205 seconds and 4 git commands to generate.