]> git.pld-linux.org Git - packages/glibc.git/blob - glibc.spec
- masive changes:
[packages/glibc.git] / glibc.spec
1 Summary:        GNU libc
2 Summary(de):    GNU libc
3 Summary(fr):    GNU libc
4 Summary(pl):    GNU libc
5 Summary(tr):    GNU libc
6 name:           glibc
7 Version:        2.1
8 %define         man_pages_ver 1.23
9 Release:        10
10 Copyright:      LGPL
11 Group:          Libraries
12 Group(pl):      Biblioteki
13 Source0:        ftp://sourceware.cygnus.com/pub/glibc/%{name}-%{version}.tar.gz
14 Source1:        ftp://sourceware.cygnus.com/pub/glibc/%{name}-linuxthreads-%{version}.tar.gz
15 Source2:        http://www.ozemail.com.au/~geoffk/glibc-crypt/%{name}-crypt-%{version}.tar.gz
16 Source3:        utmpd.init
17 Source4:        nscd.init
18 Source5:        ftp://ftp.win.tue.nl/pub/linux/docs/manpages/man-pages-%{man_pages_ver}.tar.bz2
19 Patch0:         glibc-info.patch
20 URL:            http://www.gnu.org/software/libc/
21 Provides:       ld.so.2
22 Obsoletes:      glibc-profile
23 Obsoletes:      glibc-debug
24 Autoreq:        false
25 BuildRoot:      /tmp/%{name}-%{version}-root
26
27 %description
28 Contains the standard libraries that are used by multiple programs on
29 the system. In order to save disk space and memory, as well as to
30 ease upgrades, common system code is kept in one place and shared between
31 programs. This package contains the most important sets of shared libraries,
32 the standard C library and the standard math library. Without these, a
33 Linux system will not function. It also contains national language (locale)
34 support and timezone databases.
35
36 %description -l de
37 Enthält die Standard-Libraries, die von verschiedenen Programmen im System
38 benutzt werden. Um Festplatten- und Arbeitsspeicher zu sparen und zur
39 Vereinfachung von Upgrades ist der gemeinsame Systemcode an einer einzigen
40 Stelle gespeichert und wird von den Programmen gemeinsam genutzt. Dieses
41 Paket enthält die wichtigsten Sets der shared Libraries, die
42 Standard-C-Library und die Standard-Math-Library, ohne die das Linux-System
43 nicht funktioniert. Ferner enthält es den Support für die verschiedenen
44 Sprachgregionen (locale) und die Zeitzonen-Datenbank.
45
46 %description -l fr
47 Contient les bibliothèques standards utilisées par de nombreux programmes
48 du système. Afin d'économiser l'espace disque et mémoire, et de faciliter
49 les mises à jour, le code commun au système est mis à un endroit et partagé
50 entre les programmes. Ce paquetage contient les bibliothèques partagées les
51 plus importantes, la bibliothèque standard du C et la bibliothèque
52 mathématique standard. Sans celles-ci, un système Linux ne peut fonctionner.
53 Il contient aussi la gestion des langues nationales (locales) et les bases
54 de données des zones horaires.
55
56 %description -l pl
57 W pakiecie znajduj± siê podstawowe biblioteki, u¿ywane przez ró¿ne programy
58 w Twoim systemie. U¿ywanie przez programy bibliotek z tego pakietu oszczêdza
59 miejsce na dysku i pamiêæ. Wiekszo¶æ kodu systemowego jest usytuowane w
60 jednym miejscu i dzielone miêdzy wieloma programami. Pakiet ten zawiera
61 bardzo wa¿ny zbiór bibliotek standardowych wspó³dzielonych (dynamicznych)
62 bibliotek C i matematycznych. Bez glibc system Linux nie jest w stanie
63 funkcjonowaæ. Znajduj± siê tutaj równie¿ definicje ró¿nych informacji dla
64 wielu jêzyków (locale) oraz definicje stref czasowych.
65
66 %description -l tr
67 Bu paket, birçok programýn kullandýðý standart kitaplýklarý içerir. Disk
68 alaný ve bellek kullanýmýný azaltmak ve ayný zamanda güncelleme iþlemlerini
69 kolaylaþtýrmak için ortak sistem kodlarý tek bir yerde tutulup programlar
70 arasýnda paylaþtýrýlýr. Bu paket en önemli ortak kitaplýklarý, standart
71 C kitaplýðýný ve standart matematik kitaplýðýný içerir. Bu kitaplýklar olmadan
72 Linux sistemi çalýþmayacaktýr. Yerel dil desteði ve zaman dilimi veri tabaný
73 da bu pakette yer alýr.
74
75 %package devel
76 Summary:        Additional libraries required to compile
77 Summary(de):    Weitere Libraries zum Kompilieren
78 Summary(fr):    Librairies supplémentaires nécessaires à la compilation.
79 Summary(pl):    Dodatkowe biblioteki wymagane podczas kompilacji
80 Summary(tr):    Geliþtirme için gerekli diðer kitaplýklar
81 Group:          Development/Libraries
82 Group(pl):      Programowanie/Biblioteki
83 Prereq:         /sbin/install-info
84 Requires:       %{name} = %{version}
85
86 %description devel
87 To develop programs which use the standard C libraries (which nearly all
88 programs do), the system needs to have these standard header files and object
89 files available for creating the executables.
90
91 %description -l de devel
92 Bei der Entwicklung von Programmen, die die Standard-C-Libraries verwenden
93 (also fast alle), benötigt das System diese Standard-Header- und Objektdateien
94 zum Erstellen der ausführbaren Programme.
95
96 %description -l fr devel
97 Pour développer des programmes utilisant les bibliothèques standard du C
98 (ce que presque tous les programmes font), le système doit posséder ces
99 fichiers en-têtes et objets standards pour créer les exécutables.
100
101 %description -l pl devel
102 Pakiet ten jest niezbêdny przy tworzeniu w³asnych programów korzystaj±cych
103 ze standardowej biblioteki C. Znajduj± siê tutaj pliki nag³ówkowe oraz pliki 
104 objektowe, niezbêdne do kompilacji programów wykonywalnych i innych bibliotek.
105
106 %description -l tr devel
107 C kitaplýðýný kullanan (ki hemen hemen hepsi kullanýyor) programlar
108 geliþtirmek için gereken standart baþlýk dosyalarý ve statik kitaplýklar.
109
110 %prep 
111 %setup -q -a 1 -a 2 -a 5
112 %patch -p1
113
114 %build
115 install -d sunrpc/cpp; ln -s /lib/cpp sunrpc/cpp/cpp 
116 CFLAGS="$RPM_OPT_FLAGS -pipe" \
117 %ifarch sparc sparc64
118 sparc32 \
119 %endif
120 ./configure \
121         --enable-add-ons=crypt,linuxthreads \
122         --disable-profile \
123         --prefix=/usr \
124         --disable-omitfp \
125         --enable-add-ons=yes \
126         %{_target}
127 make
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT/{etc/rc.d/init.d,usr/man/man3,var/db}
132
133 make install_root=$RPM_BUILD_ROOT install
134 make install_root=$RPM_BUILD_ROOT install-locales -C localedata
135
136 make -C linuxthreads/man
137
138 install linuxthreads/man/*.3thr man-pages-*/man3/* \
139         $RPM_BUILD_ROOT%{_mandir}/man3
140
141 rm -rf $RPM_BUILD_ROOT/usr/share/zoneinfo/{localtime,posixtime,posixrules}
142
143 ln -sf ../../../etc/localtime $RPM_BUILD_ROOT/usr/share/zoneinfo/localtime
144 ln -sf localtime $RPM_BUILD_ROOT/usr/share/zoneinfo/posixtime
145 ln -sf localtime $RPM_BUILD_ROOT/usr/share/zoneinfo/posixrules
146 ln -sf ../../usr/lib/libbsd-compat.a $RPM_BUILD_ROOT/usr/lib/libbsd.a
147
148 rm -f $RPM_BUILD_ROOT/etc/localtime
149
150 install %{SOURCE3} $RPM_BUILD_ROOT/etc/nsswitch.conf
151
152 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
153 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/utmpd
154
155 install nscd/nscd.conf          $RPM_BUILD_ROOT/etc
156 install nss/nsswitch.conf       $RPM_BUILD_ROOT/etc
157
158 install nss/db-Makefile $RPM_BUILD_ROOT/var/db
159
160 cat << EOF > $RPM_BUILD_ROOT/usr/bin/create-db
161 #!/bin/sh
162 /usr/bin/make -f /var/db/db-Makefile
163 EOF
164
165 ln -sf create-db $RPM_BUILD_ROOT/usr/bin/update-db 
166
167 rm -rf documentation
168 install -d documentation
169
170 cp linuxthreads/ChangeLog  documentation/ChangeLog.threads
171 cp linuxthreads/Changes documentation/Changes.threads
172 cp linuxthreads/README documentation/README.threads
173 cp login/README.utmpd documentation/
174 cp crypt/README documentation/README.crypt
175
176 cp ChangeLog ChangeLog.8 documentation
177
178 strip $RPM_BUILD_ROOT/{sbin/*,usr/{bin/*,sbin/*}} || :
179
180 gzip -9fn $RPM_BUILD_ROOT/usr/{man/man*/*,info/libc*} \
181         README NEWS FAQ BUGS NOTES PROJECTS documentation/*
182
183 %post   -p /sbin/ldconfig
184 %postun -p /sbin/ldconfig
185
186 %post devel
187 /sbin/install-info %{_infodir}/libc.info.gz /etc/info-dir
188
189 %preun devel
190 if [ "$1" = 0 ]; then
191         /sbin/install-info --delete %{_infodir}/libc.info.gz /etc/info-dir
192 fi
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files
198 %defattr(644,root,root,755)
199 %doc {README,NEWS,FAQ,BUGS}.gz
200
201 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/nscd.*
202 %config(noreplace) %verify(not mtime md5 size) /etc/nsswitch.conf
203 %config /etc/rpc
204
205 %attr(754,root,root) /etc/rc.d/init.d/*
206
207 %attr(755,root,root) /sbin/*
208 %attr(755,root,root) /usr/bin/*
209 %attr(755,root,root) /usr/sbin/*
210
211 %attr(755,root,root) /lib/ld-*
212 %attr(755,root,root) /lib/lib*
213
214 %dir /usr/lib/gconv
215 /usr/lib/gconv/gconv-modules
216 %attr(755,root,root) /usr/lib/gconv/*.so
217
218 /usr/share/i18n
219 /usr/share/locale
220 /usr/share/zoneinfo
221
222 %dir /var/db
223 %config /var/db/db-*
224
225 %files devel
226 %defattr(644,root,root,755)
227 %doc documentation/* {NOTES,PROJECTS}.gz
228
229 /usr/include/*.h
230 /usr/include/arpa
231 /usr/include/bits
232 /usr/include/db1
233 /usr/include/gnu
234 /usr/include/net
235 /usr/include/netash
236 /usr/include/netatalk
237 /usr/include/netax25
238 /usr/include/neteconet
239 /usr/include/netinet
240 /usr/include/netipx
241 /usr/include/netpacket
242 /usr/include/netrom
243 /usr/include/netrose
244 /usr/include/nfs
245 /usr/include/protocols
246 /usr/include/rpc
247 /usr/include/rpcsvc
248 /usr/include/scsi
249 /usr/include/sys
250
251 %{_infodir}/libc.inf*.gz
252
253 %attr(755,root,root) /usr/lib/lib*.so
254 /usr/lib/*.o
255 /usr/lib/lib*.a
256
257 %{_mandir}/man3/*
258
259 %changelog
260 * Mon Apr 19 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
261   [2.1-10]
262 - recompiled on new rpm.
263
264 * Tue Mar 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
265   [2.1-9]
266 - gzipping %doc,
267 - iconv modules moved to main,
268 - moved man pages level 3 from man-pages package.
269
270 * Mon Mar 15 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.
271   [2.1-7]
272 - on sparc{64} ./configure must be runed throw sparc32 wrapper.
273
274 * Sun Mar 14 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
275   [2.1-6]
276 - updated glibc-crypt to version-2.1
277
278 * Sat Mar 06 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
279   [2.1-5]
280 - removed striping of shared libraries -- no debug info in this libs,
281 - fixed permission of /var/db directory -- should be 755...
282
283 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
284   [2.1-4]
285 - removed man group from man pages,
286 - standarized {un}registering info pages (added libc-info.patch),
287 - changed base source url to ftp://sourceware.cygnus.com/pub/glibc/,
288 - changed URL,
289 - siplifications in %files devel,
290 - Group in devel changed to Development/Libraries,
291 - removed some %doc (INSTALL and outdated ChangeLog),
292 - removed %config and %verify rules fromn /etc/rc.d/init.d/* files,
293 - changed permission to 754 on /etc/rc.d/init.d/*,
294 - added striping shared libraries.
295
296 * Sun Feb 14 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
297   [2.1-3d]
298 - updated to stable version,
299 - fixed stripping ELF binaries,
300 - removed obsoletes /usr/include/{asm,linux}
301
302 * Fri Jan 29 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
303   [2.0.111-1d]
304 - updated to latest snapshoot,
305 - added utmpd.init, (don't run this piece of ... by default)
306 - added /var/db, (don't generate a data base by default)
307 - removed unused /usr/libexec/pt_ch*
308 - other changes.
309
310 * Sat Nov 07 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
311   [2.0.100-1d]
312 - updated to latest snapshoot,
313 - added install-locales,
314 - minor changes.
315
316 * Tue Oct 13 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
317   [2.0.99-1d]
318 - updated to 2.0.99,
319 - added Obsoletes: glibc-debug, glibc-profile
320
321 * Thu Aug 06 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
322   [2.0.96-1d]
323 - updated to 2.0.96,
324 - translation modified for pl, 
325   (follow the suggestions Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>)
326 - major changes.
327       (rewrote spec file -- follow the PLD policy)
328
329 * Wed Jul 16 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
330   [2.0.94-2d]
331 - added nscd.init and config
332 - fixed permision of pt_chown to 4711 
333 - added %defattr
334 - moved linux include links from kernel-headers to glibc-devel
335
336 * Tue Jun 2 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
337   [2.0.94-1d]
338 - updated to glibc 2.0.94
339
340 * Sun May 24 1998 Marcin Korzonek <mkorz@euler.mat.univ.szczecin.pl>
341   [2.0.93-1d]
342 - updated for glibc 2.0.93
343 - build prepare for PLD-1.1 Tornado
344 - removed glibc-debug and glibc-profile packages generation (it took too
345   long to compile the full featured version on my home linux box ;)
346 - compilation is now performed in compile directory as advised 
347   in Glibc HOWTO,
348 - start at invalid RH spec file.
349   [2.1.1-1]
350 - based on RH spec,
351 - spec rewrited by PLD team,
352   we start at GNU libc 2.0.92 one year ago ...
353 - pl translation by Wojtek ¦lusarczyk <wojtek@shadow.eu.org>.
This page took 0.058305 seconds and 3 git commands to generate.